
Uporaba računalniških orodij za
podporo pisarniškemu poslovanju

Izbrana poglavja

Borut Jereb
Darja Kukovič
Gregor Štrubelj

Univerza v Mariboru
Fakulteta za logistiko

Celje, 2015



Avtorji: JEREB, Borut; KUKOVIČ, Darja; ŠTRUBELJ, Gregor

Naslov: Uporaba računalniških orodij za podporo pisarniškemu poslovanju : izbrana poglavja
Visokošolski učbenik z recenzijo

URL (e-pub) http://labinf.fl.uni-mb.si/orodja-za-pisarnisko-poslovanje/

Recenzenti: izr. prof. dr. Viktorija Florjančič, doc. dr. Rok Rupnik, red. prof. dr. Maja Fošner

Jezikovni pregled: dr. Vesna Mia Ipavec

Založila: Univerza v Mariboru, Fakulteta za logistiko

Izdano: september 2015, Celje

Naklada: 150 izvodov

CIP - Kataložni zapis o publikaciji
Narodna in univerzitetna knjižnica, Ljubljana

005.334:656

JEREB, Borut, 1962-
Uporaba računalniških orodij za podporo pisarniškemu poslovanju : izbrana poglavja /

Borut Jereb, Darja Kukovič, Gregor Štrubelj. - Celje : Fakulteta za logistiko, 2015

ISBN 978-961-6962-09-4
1. Kukovič, Darja 2. Štrubelj, Gregor
280749568

CIP - Kataložni zapis o publikaciji
Narodna in univerzitetna knjižnica, Ljubljana

005.334:656(0.034.2)

JEREB, Borut, 1962-
Uporaba računalniških orodij za podporo pisarniškemu poslovanju [Elektronski vir] :

izbrana poglavja / Borut Jereb, Darja Kukovič, Gregor Štrubelj. - El. knjiga. - Celje :
Fakulteta za logistiko, 2015

ISBN 978-961-6962-10-0 (pdf)
1. Kukovič, Darja 2. Štrubelj, Gregor
280750336



Knjiga je urejena s programom LATEX. TEX je blagovna znamka American Mathematical Society.

To delo je objavljeno pod licenco Creative Commons: "Priznanje avtorstva – Nekomercialno
– Brez predelav (verzija 2.5. in več)". Besedilo licence je na voljo na internetnem naslovu
http://www.creativecommons.si, ali pa na naslovu: Inštitut za intelektualno lastnino, Streli-
ška 1, 1000 Ljubljana.

Pri pošiljanju predlogov za spremembe in dopolnitve te publikacije se predlagatelj strinja z nasle-
dnjo izjavo: "V kolikor bodo avtorji publikacije upoštevali moje predloge sprememb publikacije
in bodo le te dodane v novejšo verzijo publikacije, se odpovedujem vsem materialnim avtorskim
pravicam, ki izhajajo iz mojega avtorskega dela in se strinjam z objavo mojega imena med avtorji
publikacije". Naslov za pošiljanje predlogov je borut.jereb@um.si.

http://www.creativecommons.si
mailto:borut.jereb@um.si


4



Predgovor

Med orodji za podporo pisarniškemu poslovanju je LibreOffice postal ena izmed najboljših odpr-
tokodnih pisarniških zbirk. Tako so orodja iz zbirke LibreOffice zelo tehtna alternativa komerci-
alnim izdelkom – predvsem za urejanje besedil in za delo s preglednicami.

Odprtokodne rešitve postavljajo danes nove meje glede uporabnosti, ergonomičnosti, pri-
lagodljivosti, hitrosti zaganjanja, majhne zahtevnosti glede uporabe sistemskih virov ter glede
ostalih pomembnih ali celo ključnih parametrov. Za temi rešitvami stojijo tisoči programerjev,
ki s pomočjo strategije „več glav več ve“ hitro odpravijo morebitne hrošče v programju ter omo-
gočajo njegov hiter razvoj. Izjemne rezultate dajeta vsakodnevno testiranje in dokumentiranje
posameznih rešitev na način, da sta koda rešitve in dokumentacija že isti dan na voljo skupnosti
– to je vsem, ki pri razvoju sodelujejo na kakršenkoli način.

Urejevalnik besedil Writer uporablja standardne formate zapisov datotek, ki je zapisan v
mednarodnem standardu ISO/IEC 26300:2006, vendar je mogoče uporabljati tudi Microsoftova
formata .doc in .docx, preglednice v Calc-u pa berejo in zapisujejo v formatu .xls in .xlsx. To so
formati, na katere prisegajo talci oziroma ujetniki komercialnih rešitev. LibreOffice je mogoče
poganjati na vseh pomembnejših operacijskih sistemih – Linux, Windows (tudi na XP ali Vista)
in Mac OS X. LibreOffice je zastonj in z njegovo uporabo ne kršimo nobenih licenčnih pogojev.
Tudi zahteve po zmogljivostih strojne opreme so razpolovljene v primerjavi s komercialnimi
rešitvami.

Med zelo prodorne predstavnike odprtokodne skupnosti spadajo tudi slovenski strokovnjaki,
ki so pisarniško zbirko LibreOffice poslovenili ter pripravili obsežno pomoč uporabnikom, slovar
besed, pravila za deljenje in tudi slovar sopomenk. S tem je dosežena podobna uporabnost kot
jo ima Microsoftova pisarniška zbirka.

Uporaba odprtokodnih rešitev se zaradi njihovih dobrih lastnosti hitro širi. V realnosti se
pokaže, da je edini problem ta, da trgovcem ne daje zaslužka. Zaslužek daje tistim, ki ne proda-
jajo rešitev, temveč znanje, kako te rešitve uporabiti. Zato ima vsak del v mozaiku odprtokodne
skupnosti posebno vrednost, še posebej, če je slovenski in je namenjen domači javnosti.

V knjigi je predstavljena uporaba pisarniške zbirke LibreOffice ter znotraj nje najpogosteje
uporabljena programa pisarniških zbirk, urejevalnik besedil (Writer) in urejevalnik preglednic
(Calc). V dveh večjih enotah so tako v knjigi predstavljena enostavna in uporabna navodila
za uporabo obeh programov ter njunih najpomembnejših orodij z nekaterimi realnimi primeri
uporabe.
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V poglavju, kjer predstavljamo program za urejanje besedil Writer, smo najprej opisali de-
lovno okolje ter nastavitve programa, nato pa še urejanje slogov in pripravo predloge, tako da se
lahko uporabnik dobro pripravi na delo v tem programu. Šele nato smo predstavili konkretno
urejanje besedila, delo s slikami in tabelami ter ustvarjanje kazal in drugih seznamov. Poglavje
smo zaključili z dvema realnima primeroma – spajanjem pošte in izdelavo obrazca.

V poglavju o programu za delo s preglednicami Calc smo najprej predstavili program in
njegovo uporabno vrednost ter njegova osnovna orodja. Nato smo opisaili vnašanje, urejanje in
oblikovanje podatkov ter uporabo formul in funkcij, kjer smo prav tako predstavili dva realna
primera – izdelavo tabele s poštevanko in vodenje stanja zalog v skladišču. Poglavje smo zaključili
s predstavitvijo ustvarjanja grafikonov in grafov, ki pogosto sledi delu s podatki, saj so ti tako
bolj nazorno predstavljeni.

Knjigo zaključujejo mnenja treh recenzentov, katerim se za potrpežljivo branje in sugestije
najlepše zahvaljujemo. Vsi trije so ugledni profesorji različnih slovenskih univerz:

1. Izr. prof. dr. Viktorija Florjančič, Univerza na Primorskem, Fakulteta za management

2. Doc. dr. Rok Rupnik, PMP, Univerza v Ljubljani, Fakulteta za računalništvo in infor-
matiko

3. Red. prof. dr. Maja Fošner, Univerza v Mariboru, Fakulteta za logistiko

Ena izmed osnovnih predpostavk naše knjige je tudi njeno nenehno izboljševanje. Zavedamo
se, da je mogoče in potrebno v knjigi marsikaj izboljšati in dodati. Zato ste vabljeni vsi, ki imate
predloge v zvezi s knjigo, da nam pišete na naslov borut.jereb@um.si. Vse predloge bomo skrbno
proučili in vaša uporabna spoznanja vnesli v naslednje verzije.

Zahvaljujemo se tudi dekanu Fakultete za logistiko Univerze v Mariboru, izr. prof. dr.
Bojanu Rosiju, ki je prisluhnil željam in potrebam po pripravi in izdaji tega gradiva.

Izr. prof. dr. Borut Jereb, CISA, CISM, CGEIT

mailto:borut.jereb@um.si
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Poglavje 1

Pisarniške zbirke

1.1 Uvod

Pri študiju potrebujemo računalnik in programe, ki nam pomagajo pri pripravi najrazličnejših
pisnih izdelkov, predvsem seminarskih nalog in zaključnih del. Poleg urejevalnika besedil so nam
v veliko pomoč tudi druge aplikacije, natančneje pisarniške zbirke, kot sta na primer program za
delo s preglednicami in program za pripravo elektronskih predstavitev.

Računalnik in programe bomo potrebovali tudi po zaključku študija, saj trendi kažejo oziroma
narekujejo njihovo uporabo na vseh življenjskih področjih, predvsem pa pri delu. Poznavanje in
obvladovanje računalniških programov tako ne bo le prednost, temveč nuja.

Na trgu so danes dosegljivi različni programi in pod različnimi licencami. Najbolj znani so
komercialni in plačljivi programi Microsoft, zato ne čudi, da mnogo ljudi enači urejevalnik besedil
z Microsoft urejevalnikom Word, drugih različic pa ne poznajo.

Veliko bolj smiselne in predvsem prosto dostopne različice pisarniških zbirk, z uporabo
katerih tudi ne kršimo avtorskih pravic in jih lahko uporabljajo tako fizične kot pravne osebe
(npr. podjetja) ter delujejo na različnih operacijskih sistemih (in ne le v Windows), so tudi
OpenOffice.org, NeoOffice, LibreOffice in druge.

1.2 Zbirka programov za podporo pisarniškemu poslovanju
LibreOffice

Pisarniška zbirka LibreOffice kot privzeti format za shranjevanje dokumentov za vse
svoje aplikacije uporablja standardiziran format datotek mednarodnega ISO/IEC standarda
OpenDocument. Standard OpenDocument format (ODF), ali daljše OASIS Open Document
Format for Office Applications (format OASIS Open Document za pisarniške programe),
je bil razvit s strani tehniškega odbora znotraj konzorcija industrijskega združenja OASIS
(Organization for the Advancement of Structured Information Standards – organizacija za
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napredek standardov za strukturirane informacije) in temelji na datotečnem formatu na osnovi
XML, ki so ga ustvarili pri OpenOffice.org. Format datoteke OpenDocument je sedaj podprt
tudi s strani vseh prepoznavnih komercialnih aplikacij pisarniških zbirk, ne glede na to, ali so
lastniške ali odprtokodne [6].

OpenDocument format (ODF) je odprt datotečni format, ki je bil razvit z namenom
zagotavljanja odprte, na XML temelječe specifikacije datotečnega formata za pisarniške aplikacije
in je namenjen shranjevanju in izmenjavi pisarniških dokumentov, ki jih je moč urejati. Med
take dokumente spadajo besedilni dokumenti, preglednice, predstavitve, podatkovne zbirke in
grafikoni.

Pisarniška zbirka LibreOffice je s pomočjo različnih uvoznih/izvoznih filtrov kompatibilna
tudi z drugimi prepoznavnimi pisarniškimi zbirkami, vključno z najbolj razširjeno – Microsoft
Office. Datotečni formati Microsoft Office-a so dobro podprti, kljub temu, da se z nekaterimi
postavitvenimi lastnostmi oziroma oblikovnimi atributi znotraj posameznih aplikacij ravna
drugače, ali pa v filtrih niso v celoti podprti. LibreOffice je na voljo v več kot 110 jezikih
ter za različne računalniške platforme, vključno z Microsoft Windows, Mac OS X 10.6 Snow
Leopard ali novejše ali Linux (vključno z LibreOffice Viewer za Android). LibreOffice je privzeta
pisarniška zbirka najbolj priljubljenih programov Linux.

Zbirka vsebuje programe, ki omogočajo naslednje pisarniške aktivnosti:

• urejanje besedil: Writer (Dokument z besedilom),

• delo s preglednicami: Calc (Preglednica),

• pripravo elektronskih predstavitev: Impress (Predstavitev),

• risanje: Draw (Risba),

• oblikovanje formul: Math (Formule),

• urejanje zbirke podatkov: Base (Zbirka podatkov).

Pomembne so tudi razširitve programov, ki jih je trenutno nekaj sto ter so dostopne na:

• http://extensions.libreoffice.org/extension-center,

• http://extensions.services.openoffice.org/,

• http://libreplanet.org/wiki/Group:OpenOfficeExtensions/List.

Te razširitve so napisane s strani neodvisnih razvijalcev in obstajajo za vse programe iz
zbirke. Največ razširitev je za najpogosteje uporabljana programa, Writer in Calc. Med njimi
so razširitve, kot so slovarji za jezike, orodja za jezike, galerije slik, predloge za dokumente,
predstavitve, preglednice, dodatne posebne orodne vrstice, pregledovalniki črkovanja, dodatne
nastavitve za pomoč pri tiskanju, integracija črtnih kod, priprava koledarjev in druge.

To delo se osredotoča na v pisarniškem poslovanju najbolj uporabljana programa iz zbirke
Writer in Calc. Pri izdelavi smo se opirali predvsem na dokumentacijo LibreOffice [4] [3], ki še
ni prevedena v slovenščino. Pomanjkanje slovenske literature o LibreOffice je bila tudi glavna
motivacija za nastanek tega dela.
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Urejevalnik besedil

Vsesplošno razširjen program, ki je zamenjal pisalni stroj in se ga poslužuje že skoraj vsak sodoben
človek, je urejevalnik besedil. Ko delamo z informacijami, pravzaprav delamo z dokumenti v
različnih oblikah. Pri vseh opravilih, npr. izdelavi zapiskov, poročil, poglavij, objavi za tisk,
seminarski nalogi, diplomskemu delu itd., moramo znati izdelovati nove dokumente, vnašati
besedilo in si ogledovati dokumente v različnih oblikah. Posamezniki uporabljajo urejevalnik
besedil v šoli, službi in doma. Podjetja ga uporabljajo za vse, kar si lahko zamislimo. Urejevalnik
besedil se uporablja v samostojnih sistemih in omrežju; je standardna oblika za datoteke, ki se
pošiljajo po internetu z enega konca sveta na drugega.

Urejevalnik besedil uporabljamo za vnos, popravljanje, oblikovanje, shranjevanje in ponovni
priklic besedila oziroma dokumentov. Tipične zmožnosti urejevalnikov besedil so vstavljanje,
brisanje, kopiranje, tiskanje in preverjanje črkovanja. Znani urejevalniki besedil so na primer
Microsoft Word, LibreOffice Writer, OpenOffice Writer, NeoOffice Writer, Beležnica, Lotus
WordPro in Corel WordPerfect itd.

V gradivu se bomo podrobneje spoznali z urejevalnikom besedil Writer, ki je del orodij
LibreOffice. Večina urejevalnikov besedil ima podobna orodja oziroma opremo, tako se bomo
tudi pri Writer-ju seznanili z najpomembnejšimi.

Najprej pa je treba predstaviti delovno okolje aplikacije Writer.

2.1 Pregled delovnega okolja

2.1.1 Deli glavnega okna urejevalnika

Glavni delovni prostor v LibreOffice-u prikazuje slika 2.1. Vse prikazane elemente bomo opisali
v tem poglavju.
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Slika 2.1: Glavni delovni prostor LibreOffice Writer-ja

Naslovna vrstica (Title bar)

Naslovna vrstica se nahaja na vrhu okna Writer-ja in prikazuje ime datoteke trenutnega
dokumenta. Ko je dokument na novo oblikovan, se bo njegovo ime izpisalo kot Neimenovano X
(Untitled X), kjer je X številka.

Meniji (Menus)

Pod naslovno vrstico imamo menijsko vrstico z meniji. Ko izberemo določeni meni (Datoteka,
Urejanje, Pogled, itd.), se nam v sklopu posameznega menija pojavi seznam podmenijev in
ukazov, ki jih izbiramo glede na našo potrebo.

• Datoteka (File) vsebuje ukaze, ki se nanašajo na celoten dokument. To so npr. ukazi
Odpri (Open), Shrani (Save), Natisni (Print), in Izvozi v PDF (Export as PDF).

• Uredi (Edit) vsebuje ukaze za urejanje dokumenta. To so npr. Razveljavi: xxx
(Undo: xxx) (kjer xxx pomeni dejanje, ki naj se razveljavi) in Najdi in zamenjaj
(Find & Replace). Prav tako vsebuje tudi ukaze Izreži (Cut), Kopiraj (Copy) in
Prilepi (Paste) izbranih delov dokumenta oziroma besedila.

• Pogled (View) vsebuje ukaze za nastavitve zaslona. To so npr. Povečava (Zoom) in
Spletna postavitev (Web Layout).

• Vstavi (Insert) vsebuje ukaze za vstavljanje elementov v dokument. Ti elementi so npr.
Glava, Noga in Slika.
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Slika 2.2: Menijska vrstica z odprtim podmenijem

• Oblika (Format) vsebuje ukaze kot so Slogi in oblikovanje (Styles and For-
matting), Odstavek (Paragraph) in Označevanje in oštevilčenje (Bullets and
Numbering).

• Tabela (Table) prikazuje vse ukaze za vstavljanje in urejanje tabel v besedilu.

• Orodja (Tools) vsebujejo funkcije kot so Črkovanje in slovnica (Spelling and
Grammar), Prilagodi (Customize) in Možnosti (Options).

• Okno (Window) vsebuje ukaze za okno zaslona.

• Pomoč (Help) vsebuje povezave na LibreOffice Help file – datoteko za pomoč, Kaj je to?
(What’s This?) ter informacije o programu.

Orodne vrstice (Toolbars)

Writer ima v osnovi vidni dve orodni vrstici: Standard in Oblikovanje. Vrstica Standard je
enotna za vse LibreOffice aplikacije in je stalna, vrstica Oblikovanje pa je spremenljiva glede na
kontekst dela. To pomeni, da se spreminja glede na to, kje se nahaja kazalec – če je kazalec v
besedilu, se bodo v tej vrstici pojavila orodja za delo z besedilom, če je kazalec na sliki, pa se
bodo pojavila orodja za oblikovanje slik ipd.
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Slika 2.3: Orodni vrstici Standard in Oblikovanje

Dodajanje in odstranjevanje orodnih vrstic. Za dodajanje in odstranjevanje gumbov
za orodja izberemo Pogled→Orodne vrstice (View→Toolbars), nato kliknemo na orodno
vrstico s seznama. Aktivne orodne vrstice so obkljukane.

Podmeniji in posamične orodne vrstice. Orodne vrstice z malim trikotnikom na desni
strani bodo prikazale podmenije, posamične orodne vrstice in druge načine izbiranja orodij.
Orodne vrstice je možno tudi premikati in prilagajati.

Kontekstni meni – desni klik (right-click)

Z desnim klikom na besedilo, sliko itd. odpremo kontekstni meni. To je pogosto najhitrejši in
najenostavnejši način za izvrševanje funkcij, najpogosteje uporabljene ukaze namreč najdemo
kar na tem meniju.

Ravnila (Rulers)

S tem orodjem, ki ga najdemo v meniju Pogledi (View), lahko prikažemo ali skrijemo ravnila,
s katerimi odmerjamo, kolikšen del strani bomo namenili besedilu in kolikšen del bomo namenili
robovom.

Sprememba merskih enot. Če želimo spremeniti merske enote v ravnilu, v
meniju Orodja→Možnosti→LibreOffice Writer→Splošno (Tools→Options→LibreOffice
Writer→General) poiščemo Nastavitve→Merska enota in izberemo želeno mersko enoto.

Statusna vrstica (Status bar)

Ta se nahaja na dnu delovnega prostora in prikazuje informacije o trenutnem statusu dokumenta:

• stran (page) – na kateri strani dokumenta se nahajamo,

• število besed (word count),

• slog (page style) – npr. Privzeto,

• jezik (language) – npr. slovenski,

• način vstavljanja (insert mode) – brez ali Prepiši (uporabimo, ko prepisujemo),

• gumb Izbira (Selection) – npr. Standardno izbiranje (Standard selection),

• status sprememb (shranjene ali neshranjene spremembe),
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Slika 2.4: Statusna vrstica

• digitalni podpis (digital signature),

• informacije o poziciji besedila ali predmeta,

• pogled postavitve strani in

• povečava.

Poleg posredovanja informacij vrstica ponuja tudi bližnjice do pogovornih oken, ki se navezujejo
na izbrano informacijo. Tako na primer dvoklik na številko strani odpre Krmarja (glej stran 24),
kjer lahko izberemo, na katero stran se želimo premakniti. Z dvoklikom na število besed odpremo
okno z več informacijami, z dvoklikom na trenutni jezik ga lahko spremenimo, s premikom drsnika
pa izberemo povečavo.

2.1.2 Sprememba pogleda dokumenta

Writer ima tri načine pogleda dokumenta: Postavitev tiskanja (Print Layout), Spletna
postavitev (Web Layout) in Celozaslonski način (Full Screen). Vse tri najdemo v
meniju Pogled (View).

Privzeti način pogleda je Postavitev tiskanja, v katerem lahko dokument tudi povečamo
z ukazom Povečava (Zoom).

2.1.3 Shranjevanje dokumenta

Dokument shranimo na enega izmed treh načinov:

• pritisnemo kombinacijo tipk Ctrl+S,

• izberemo Datoteka→Shrani (File→Save) ali

• kliknemo gumb Shrani v orodni vrstici Standard.

Če želimo shraniti dokument pod novim imenom, ker želimo ohraniti prejšnjega (pred vnosom
sprememb), izberemo Datoteka→Shrani kot (File→Save As). Prav tako pa ta način shran-
jevanja pride v poštev, ko dokument shranjujemo prvič.

Avtomatsko shranjevanje

Writer ponuja tudi avtomatsko shranjevanje, kar pomeni, da bo program shranil spremembe po
določenem času, ki ga je treba nastaviti. Za nastavitev avtomatskega shranjevanja:

1. Izberemo Orodja→Možnosti→Nalaganje/shranjevanje→Splošno (Tools→Options
→Load/Save→General).
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Slika 2.5: Krmar

2. Kliknemo na Shrani podatke za samoobnovitev vsakih X minut in nastavimo časovni
interval. Privzeta vrednost je 15 minut.

Kako datoteko shraniti kot Microsoft Word dokument

Če želite datoteko izmenjati z uporabnikom starejše različice Microsoft Worda, ki ne more sprejeti
*.odt datotek, lahko dokument shranite tudi kot Microsoft Word datoteko.

1. Pomembno – najprej shranimo dokument v *.odt formatu, sicer se bodo vse spremembe,
ki so nastale od zadnjega shranjevanja, pojavile zgolj v Microsoft Word verziji dokumenta.

2. Nato kliknemo Datoteka→Shrani kot (File→Save As).

3. V komunikacijskem oknu poiščemo Vse vrste datotek (File type) izberemo Word
format, ki ga potrebujemo.

4. Kliknemo Shrani (Save).

Od zdaj naprej se bodo tudi vse nadaljnje spremembe dogajale v tem formatu, zato morate
format ponovno spremeniti, če želite delati v *.odt verziji.

2.1.4 Krmar

Krmarja smo že omenili pri izbiri strani dokumenta (glej stran 23). Gre za priročno orodje za
navigacijo po dokumentu. Vsebuje vse kategorije elementov dokumenta – delovne liste, tabele,
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Slika 2.6: Gumba Razveljavi in Uveljavi

okvire besedila, grafike, predmete OLE, odseke, hiperpovezave, sklice, kazala ali komentarje. Če
je pred kategorijo znak +, pomeni, da imamo v dokumentu vsaj en element te vrste. Če kazalec
premaknemo na ime kategorije, se v namigu prikaže število vseh takšnih elementov. S klikom na
+ odpremo kategorijo. Vsak element ima ime. Če ga nismo sami poimenovali, mu je dodeljeno
avtomatsko (npr. grafika1, Okvir20 ). Z izbiro elementa se v dokumentu takoj premaknemo na
mesto elementa.

Prikličemo ga s Pogled→Krmar (View→Navigator) ali z bližnjico F5. Velikost okna lahko
spreminjamo, lahko pa ga celo zasidramo na katerokoli stranico delovne površine.

2.1.5 Razveljavljanje in ponovno uveljavljanje sprememb

Ko je dokument odprt, lahko razveljavimo zadnjo spremembo s pritiskom na Ctrl+Z ali s
klikom na gumb Razveljavi (Undo) v orodni vrstici Standard ali v meniju Uredi→Razveljavi
(Edit→Undo) v menijski vrstici.

Če želimo videti vse spremembe, ki jih lahko razveljavimo, moramo klikniti na mali trikotnik
ob gumbu Razveljavi (Undo). Nato lahko izberemo katerekoli spremembe, ki jih želimo raz-
veljaviti. Ko spremembe razveljavimo, postane aktiven tudi ukaz Uveljavi, ki ga prav tako
najdemo v meniju Uredi→Uveljavi (Edit→Redo) ali pa obnovimo prejšnje stanje s pritiskom
na Ctrl+Y oziroma na gumb Uveljavi. Tudi ob tem gumbu je na desni strani mali trikotnik, s
katerim dobimo seznam vseh dejanj, ki jih lahko ponovno uveljavimo.

2.2 Nastavitve programa

2.2.1 Izbira možnosti pri vseh komponentah LibreOffice

V tem poglavju se bomo seznanili z nekaterimi nastavitvami, ki zadevajo vse komponente
LibreOffice (poleg Writer-ja še Calc, Impress, Draw, Math in Base) in so še posebej pomembne
za urejevalnik besedil Writer.

Te nastavitve najdemo in jih lahko spreminjamo v meniju Orodja→Možnosti (Tools
→Options), nekatere pomembnejše pa so podrobneje opisane v nadaljevanju.

Splošne možnosti

Možnosti v LibreOffice – Splošno so prikazane na sliki 2.7.

Primer. Pomoč – Namigi: To možnost obkljukamo, če še ne poznamo vseh gumbov in
njihovih funkcij. Ko kazalec usmerimo na enega izmed gumbov ne da nanj kliknemo, se nam
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Slika 2.7: Nastavitve splošnih možnosti LibreOffice

v tem primeru izpiše ime gumba oziroma njegova funkcija. Če to možnost odkljukamo, pa teh
namigov ne bo.

Pomnilnik

Pomnilnik v LibreOffice zadeva predvsem možnosti za Razveljavi, zalogo slik in predmetov v
dokumentu ter hitri start. To prikazuje slika 2.8.

Pri vseh možnostih lahko zmogljivost pomnilnika povečamo ali pomanjšamo, odvisno od tega,
s kakšnim dokumentom imamo opravka – ali ga veliko spreminjamo ali vsebuje veliko slik itd.
Pri tem pa se je potrebno zavedati, da povečanje velikosti pomnilnika, namenjenega LibreOffice,
vpliva na obremenjenost (zasedenost) celotnega pomnilnika našega računalnika.

Pogled

V tem oknu si nastavimo pogled menijev in orodnih vrstic, obnašanja miške itd. Vse možnosti
so razvidne s slike 2.9.

Poti

V LibreOffice – Poti (Paths) lahko spremenite lokacijo datotek, ki jih uporabljate v
LibreOffice. Privzete nastavitve namreč hranijo tekstovne dokumente v datoteki Moji doku-
menti (My documents). Če želite svoje dokumente hraniti kje drugje, to spremenite v oknu na
sliki 2.10.
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Slika 2.8: Nastavitve pomnilnika

Slika 2.9: Nastavitve pogleda
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Slika 2.10: Nastavitve poti

Druge možnosti

Na podoben način nato lahko nastavite še druge možnosti – Tiskanje, Podatki uporabnika,
Barve, Pisave, Varnost in Videz.

2.2.2 Izbira možnosti za nalaganje in shranjevanje dokumentov

Tudi te nastavitve se urejajo v meniju Orodja→Možnosti (Tools→Options). Podobno se nato
urejajo tudi vsi podmeniji, zato bomo opozorili le na najpomembnejše nastavitve.

V podmeniju Splošno je v kategoriji Shrani pomembna možnost nastavitve sprotnega
shranjevanja, ki ga nastavimo s kljukico pred Shrani podatke za samoobnovitev vsakih ...
in nato izberemo časovni interval. Če na primer izberemo 5 minut, se nam bodo spremembe
dokumenta shranile vsakih 5 minut, četudi jih ne bomo posebej shranili. To je predvsem
pomembno v primeru izpada električne energije, stanja, ki zahteva nasilno zaustavitev sistema
(reset) ali podobnih motenj.

Sicer pa si znotraj teh možnosti lahko nastavite še Lastnosti VBA, Microsoft Office in
Združljivost s HTML.

2.2.3 Izbira možnosti za urejevalnik besedil

V tem naboru možnosti si lahko nastavite vse, kar se nanaša na urejevalnik besedil Writer, to pa
pomeni, da se bodo te nastavitve odražale na izgledu vašega dokumenta. Izbiramo med merskimi
enotami, nastavljamo tabulatorska mesta, prilagajamo drsne trakove, vsebino natisnjenih strani,
nastavljamo privzete nastavitve tabel itd.
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Slika 2.11: Nastavitve jezika; jezik

2.2.4 Nastavitve jezika

Znotraj nastavitev jezika si lahko namestimo želeni slovar, spremenimo nekatere privzete
nastavitve in izberemo možnosti črkovanja.

Namestitev slovarjev

Nekaj slovarjev je v LibreOffice samodejno nameščenih, če pa želimo dodati še kakšnega,
se moramo najprej prepričati, ali smo povezani s svetovnim spletom. Nato v me-
niju Orodja→Jezik→Dodatni slovarji s spleta (Tools→Language→More Dictionaries
Online) v brskalniku, ki nam ga LibreOffice ponudi, poiščemo želeni slovar in ga namestimo
tako, da sledimo navodilom.

Sprememba privzetih nastavitev

Nekatere podrobnosti glede jezika je potrebno preveriti in po potrebi ponastaviti v
meniju Orodja→Možnosti→Nastavitve jezika→Jeziki (Tools→Options→Language set-
tings→Languages). Tu najdemo možnosti za izbiro jezika, kjer si za uporabniški vmesnik
in področno nastavitev lahko izberemo na primer slovenski jezik, obkljukamo pa tudi okno za
nastavitev decimalnega ločila, ki naj bo enaka kot področna nastavitev. Nastavimo lahko tudi
valuto in vzorce prepoznavanja datuma.

Pri možnostih za privzete jezike za dokumente izberemo Zahodne jezike, kjer med
različnimi možnostmi izberemo želeno – na primer slovenski.
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Slika 2.12: Nastavitve pripomočkov za pisanje

Slika 2.13: Izbira sloga

Možnosti črkovanja

Za nastavitve črkovanja po isti poti kot prej pridemo do možnosti Nastavitve jezika, kjer
izberemo podmožnost Pripomočki za pisanje. Izberemo nastavitve, ki nam osebno najbolj
koristijo. Nastavitve črkovanja prikazuje slika 2.12.

2.3 Urejanje slogov

Uporaba slogov je namenjena zagotavljanju doslednosti v našem dokumentu, prav tako pa olajša
spreminjanje dokumenta. V primeru, da želimo spremeniti obliko naslovov in podnaslovov v
našem dokumentu, bomo to najlažje in najhitreje dosegli z uporabo slogov.

Slog, ki ga trenutno uporabljamo, je zapisan v levem okvirčku v orodni vrstici Oblikovanje,
ki ima na desni strani mali trikotnik, s katerim odpremo seznam ostalih slogov, ki jih lahko
izberemo (glej sliko 2.13).
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Slika 2.14: Okno Slogi in oblikovanje

2.3.1 Okno za sloge in oblikovanje

Sloge lahko tudi urejamo v oknu Slogi in oblikovanje (slika 2.14). To okno odpremo, če
kliknemo na kvadratek na skrajni levi strani orodne vrstice za oblikovanje ali pritisnemo tipko
F11 ali pa izberemo Oblika→Slogi in oblikovanje (Format→Styles and Formatting).

Na sliki 2.14 je razvidno, da lahko sloge urejamo za odstavke, znake, okvirje, posamezne
strani in sezname, lahko pa jih tudi dodajamo. Z gumbom Način kopiranja slogov hitreje
prenesemo želeni slog na želeni del besedila, saj je izbiranje besedila in nato še klikanje zelo
zamudno. Ta gumb uporabimo tako, da v oknu Slogi in oblikovanje izberemo želeni slog,

nato pa kliknemo na gumb Način kopiranja slogov . Z vedrom barve, ki se nam prikaže
namesto kazalca miške, gremo skozi želeno besedilo, kot da bi ga želeli izbrati. Želeno besedilo
bo zdaj dobilo želeni slog. Če želimo prekiniti kopiranje slogov, ponovno pritisnemo na gumb
Način kopiranja slogov ali pritisnemo tipko Esc.

2.3.2 Uporaba slogov

Sloge uporabljamo tako, da označimo želeno besedilo in v orodni vrstici izberemo poljuben slog
(npr. Privzeto, Naslov 1, Naslov 2 ) (glej sliko 2.14). Osnovno besedilo običajno pišemo v slogu
Privzeto ali Telo besedila.
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Slika 2.15: Naslovi na nivoju Naslov 1 na novi strani

Naslove pa najprej v mislih strukturiramo na način, da razmislimo, kateri je po hierarhiji
najpomembnejši in kateri mu bodo podrejeni. Za naslove nato uporabimo sloge Naslov 1 (za
naslov na prvem nivoju), Naslov 2 (za naslov na drugem nivoju), Naslov 3 (za naslov na tretjem
nivoju) itd. Številčimo jih z arabskimi številkami.

Začnemo s slogom Naslov 1, za katerega izberemo besedilo, ki bo predstavljalo naslov na
prvem nivoju. Če želimo slog urediti, desno-kliknemo na izbrani nivo sloga in izberemo Uredi
slog odstavka, kjer lahko v pogovornem oknu izberemo nastavitve za Pisavo, Učinke pisave,
Barva pisave, Ozadje, Obrobe itn. Nastavimo lahko tudi to, da se bo vsako poglavje na tem
nivoju začelo na novi strani. To naredimo z izbiro zavihka Potek besedila, kjer v rubriki
Prelomi odkljukamo Vstavi (glej sliko 2.15).

Oštevilčevanje naslovov (glej sliko 2.16) lahko nastavimo tako, da izberemo Orodja→Orisno
številčenje (Tools→Outline Numbering). V pogovornem oknu v rubriki Raven izberemo
najprej Raven 1, nato v rubriki Oštevilčevanje za Slog odstavka izberemo Naslov 1, za
Število pa 1, 2, 3, . . . Na levi strani okna se nam bo izpisal Naslov 1, oštevilčen z 1 (1 Naslov 1 ).
Tako potem nadaljujemo na vseh nižjih ravneh. Izberemo lahko tudi med možnostima Ločilo
Pred/Za, kar npr. pomeni, ali bo za številkami naslovov pika ali ne. V tej rubriki pa lahko tudi
nastavimo, s katero številko naj se oštevilčevanje naslovov sploh začne (Začni z). Ko končamo
z nastavitvami, kliknemo V redu.

Pozorni moramo biti tudi na slog privzetega besedila, predvsem kadar besedilo kopiramo iz
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Slika 2.16: Oštevilčevanje naslovov

Slika 2.17: Odstranitev oblikovanja

kakšnega drugega vira. Takrat besedilo označimo in odstranimo oblikovanje, če želimo, da je
besedilo oblikovano skladno s privzetim slogom (glej sliko 2.17).

2.3.3 Ureditev sloga strani

Slog strani nam omogoča nastavitev postavitve strani (pokončno, ležeče), številčenje strani,
ozadje, glavo, nogo, obrobe, sprotne opombe itn. Slog strani urejamo v pogovornem oknu Slog
strani, ki ga prikličemo tako, da dvokliknemo na tretje polje v statusni vrstici, kjer je zapisan
trenutni slog strani (glej sliko 2.18 in sliko 2.19). V tem pogovornem oknu si lahko uredimo slog
strani glede na vse možnosti, ki jih okno ponuja.

Lahko pa si ustvarimo tudi nov slog za stran. To storimo tako, da odpremo pogovorno okno

Slogi in oblikovanje, kjer kliknemo na gumb Slogi strani in desno-kliknemo na slog
Privzeto, nato pa izberemo Nov (glej sliko 2.20) ter slog poimenujemo.

Na zavihkih, ki se ponujajo, urejamo nastavitve sloga strani, tako da npr. v zavihku Stran
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Slika 2.18: Statusna vrstica in slog strani

Slika 2.19: Pogovorno okno Slog strani
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Slika 2.20: Nov slog za stran
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Slika 2.21: Številčenje strani in nastavitev robov

Slika 2.22: Ročni prelom strani

določimo način številčenja strani, nastavimo robove itn. (glej sliko 2.21).

Stran, ki smo ji dodali nov slog, moramo zdaj vstaviti v naš dokument tako, da izberemo
Vstavi→Ročni prelom (Insert→Manual Break) (glej sliko 2.22), da se nam odpre pogovorno
okno Vstavi prelom, kjer v rubriki Vrsta izberemo Prelom strani, v rubriki Slog pa prej
ustvarjeni slog. Spodaj levo lahko nastavimo tudi številčenje oziroma neštevilčenje te strani. Če
želimo v nadaljevanju v ta sklop dokumenta vstaviti še kakšno podobno stran z ročnim prelomom,
številk strani ne nastavljamo več, saj bo številčenje sledilo prvi strani tega sklopa.

V nogo dokumenta vstavimo številko tekoče strani tako, da izberemo Vstavi→Polja
→Številka strani (Insert→Fields→Page Number) (glej sliko 2.23). V nogo ali glavo pa
lahko vstavimo tudi Število strani (da se nam izpiše številka tekoče strani in število vseh
strani, npr. 3/13), Datum, Čas, Avtorja, Naslov itn.

Na potek številčenja strani moramo biti še posebej pozorni, saj se to lahko nadaljuje s
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Slika 2.23: Vstavljanje številke strani

prejšnjih strani, lahko pa se začne na strani, na kateri smo uporabili nek nov slog.

2.3.4 Ureditev sloga odstavka

Slog odstavka lahko uredimo preko različnih zavihkov, ki jih najdemo v pogovornem oknu Slog
odstavka: Privzeto, če v oknu Slogi in oblikovanje pritisnemo na gumb Slog odstavka

, nato pa desno-kliknemo na slog Privzeto in izberemo Spremeni.
Med pomembnejšimi zavihki, ki jih tu lahko nastavimo, so:

• Pisava – izberemo velikost in vrsto pisave, jezik itn.

• Poravnava – izbiramo lahko med Poravnaj levo, Na sredini ali Poravnaj desno, pa
tudi Obojestransko.

• Zamiki in razmiki – nastavimo lahko Odmik (Pred besedilom, Za besedilom, Prva
vrstica), Razmik (Nad odstavkom, Pod odstavkom) in Razmik med vrsticami (Enojno,
Dvojno itn.) (glej sliko 2.24).

Podobno si lahko v okviru pogovornega okna Slogi in oblikovanje uredimo Znakovni
slog (za posamezne besede ali črke), Slog okvira (za okvirjanje želene vsebine dokumenta) in
Sloge seznama (za nastavitev načina označevanja seznamov).

2.4 Priprava predloge

2.4.1 Uporaba predloge za oblikovanje dokumenta

Predloge uporabljamo zato, da si olajšamo delo oziroma skrajšamo čas nastavljanja slogov za
vsak dokument posebej.
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Slika 2.24: Slog odstavka: Privzeto
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Slika 2.25: Shranjevanje predloge

2.4.2 Shranjevanje in odpiranje predloge

Predlogo shranimo potem, ko v novem dokumentu nastavimo vse možnosti za sloge. To storimo
tako, izberemo Datoteka→Shrani kot ali kliknemo na gumb Shrani kot v orodni vrstici in
se nam pokaže pogovorno okno Shrani kot, kjer pod Vrsto datoteke izberemo Predloga
dokumenta z besedilom ODF (.ott) (glej sliko 2.25):

Predlogo odpremo tako, da izberemo Datoteka→Nova→Predloge (File→New→Temp-
lates).

2.5 Urejanje besedila

2.5.1 Izbira besedila

Preden želimo urejati besedilo, ga moramo izbrati. Osnove izbiranja besedila so enake pri vseh
urejevalnikih besedil, zato bomo v tem poglavju predstavili naprednejše izbiranje besedila.

Izbiranje predmetov, ki niso zaporedni

Pri takšnem izbiranju si pomagamo z uporabo miške:

1. Izberemo prvi del besedila.

2. Držimo tipko Ctrl (Control) in nato z miško izberemo drugi del besedila.
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Slika 2.26: Izbiranje predmetov, ki niso zaporedni

3. Ponovimo pri katerikoli delih besedila.

Podobno pa lahko besedilo izberemo tudi s pomočjo tipkovnice:

1. Izberemo prvi del besedila.

2. Pritisnemo tipko Shift+F8. Ta ukaz bo sprožil način dodajanja izbire.

3. Uporabimo tipke s puščicami, da pridemo do začetka naslednje besede, ki jo želimo izbrati,
in pritisnemo tipko Shift. Izbrana je druga beseda.

4. Ponovimo pri katerihkoli delih besedila.

5. Za izhod iz tega načina izbiranja predmetov pritisnemo tipko Esc.

Zdaj lahko izbrano besedilo urejamo.

2.5.2 Izrezovanje, kopiranje in lepljenje besedila (Cut, copy, paste)

Izrezovanje in kopiranje delujeta podobno kot pri drugih aplikacijah. To pomeni, da lahko
besedilo kopiramo znotraj dokumenta ali med dokumenti, z vlečenjem ali z uporabo menijev,
gumbov ali bližnjic na tipkovnici. Kopiramo lahko tudi iz drugih virov kot je npr. spletna stran.
Nato kopiran element prilepimo v naš dokument.

Če želimo premakniti besedilo z uporabo miške, ga moramo povleči na novo lokacijo in ga
spustiti.

Če želimo besedilo kopirati, ga najprej označimo, nato pa držimo tipko Ctrl, medtem ko ga
z miško vlečemo na želeno lokacijo.

Če želimo izbrano besedilo izrezati in ga premakniti na novo lokacijo, pritisnemo Ctrl+X za
izrez besedila, nato kazalec premaknemo na želeno lokacijo in pritisnemo Ctrl+V, da besedilo
tja prilepimo. Lahko pa uporabimo tudi gumbe za izrezovanje in kopiranje v standardni orodni
vrstici.

Če pri lepljenju besedila kliknemo na gumb Prilepi, bo prilepljeno besedilo ohranilo izvirno
obliko.

Če želimo besedilo sinhronizirati z našim (kadar na primer ne želimo prenašati oblike), imamo
na voljo tri možnosti:

• izberemo Uredi→Posebno lepljenje (Edit→Paste Special) ali
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Slika 2.27: Orodna vrstica Najdi

• kliknemo mali trikotnik na desni strani gumba Prilepi ali

• kliknemo gumb Prilepi, ne da bi spustili levi gumb miške.

2.5.3 Iskanje in nadomestitev besedila ter oblikovanje

Imamo dve možnosti iskanja besedila v dokumentu:

• orodno vrstico Najdi ali

• pogovorno okno Najdi in zamenjaj.

Uporaba orodne vrstice Najdi (Find)

Če ta orodna vrstica ni vidna, jo lahko prikličemo tako, da izberemo Pogled→Orodne
vrstice→Najdi (View→Toolbars→Find) ali pritisnemo Ctrl+F. Orodno vrstico Najdi bomo
našli spodaj, tik nad statusno vrstico, lahko pa jo tudi prestavljamo.

Orodno vrstico Najdi uporabljamo tako, da kliknemo v okno in vtipkamo želeno besedilo,
nato pa pritisnemo Enter. Desno od okenca sta tudi gumba Najdi naslednje in Najdi
prejšnje, ki ju uporabljamo kot gumba Razveljavi in Uveljavi.

2.5.4 Vstavljanje posebnih znakov

Med posebne znake spadajo tisti, ki jih ni mogoče najti na standardni tipkovnici. Mednje spadajo
na primer: c© 3

4 æ ç Ł ñ ö ø
Če želimo vstaviti poseben znak:

1. Postavimo kazalec na mesto, kjer naj stoji poseben znak.

2. Kliknemo Vstavi→Poseben znak (Insert→Special Character), da odpremo pogo-
vorno okno.

3. Izberemo znake, ki jih želimo vstaviti, nato kliknemo V redu.

Vstavljanje nedeljenega presledka in vezaja

• Nedeljeni presledek – če želimo preprečiti, da bi se dve besedi ločili na koncu vrstice,
pritisnemo Ctrl+Shift medtem ko vtipkamo presledek med njima.

• Nedeljeni vezaj – če želimo preprečiti, da bi se vezaj med dvema besedama pojavil na
koncu vrstice, pritisnemo Ctrl+Shift+znak minus.
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Slika 2.28: Pogovorno okno za vstavljanje posebnih znakov

1 Slogi in oblikovanje 7 Podčrtano 12 Razmik med vrsticami: 1
2 Uporabi slog 8 Poravnaj levo 13 Razmik med vrsticami: 1,5
3 Ime pisave 9 Na sredini 14 Razmik med vrsticami: 2
4 Velikost pisave 10 Poravnaj desno 15 Oštevilčevanje vključeno/izključeno
5 Krepko 11 Obojestransko 16 Oznake vključene/izključene
6 Ležeče

Slika 2.29: Gumbi za oblikovanje odstavkov

2.5.5 Oblikovanje odstavkov

Pri oblikovanju odstavkov največ ukazov najdemo na gumbih orodne vrstice za oblikovanje.
Vsi gumbi v tej orodni vrstici niso vselej vidni, temveč si jih lahko izberemo v
meniju Orodja→Možnosti→LibreOffice→Pogled (Tools→Options→LibreOffice→View).
Še več gumbov lahko dodamo, če v tej orodni vrstici kliknemo desni gumb miške in v meniju
kliknemo na Vidni gumbi, kjer si izberemo množico želenih gumbov. Na sliki 2.29 so opisani
posamezni gumbi.

Pri obojestranski poravnavi zadnjo vrstico uredimo v meniju Oblika→Odstavek
(Format→Paragraph), kjer v zavihku Poravnava po svoje uredimo Zadnjo vrstico (Last
line) (levo, na sredini, obojestransko in možnost razširi eno besedo).

2.5.6 Oblikovanje znakov

Tudi za oblikovanje znakov uporabljamo orodno vrstico za oblikovanje, vendar druge gumbe. Na
sliki 2.30 so opisani posamezni gumbi.
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1 Slog in oblikovanje 5 Krepko 9 Podpisano
2 Uporabi slog 6 Ležeče 10 Barva pisave
3 Ime pisave 7 Podčrtano 11 Poudarjeno
4 Velikost pisave 8 Nadpisano 12 Barva ozadja

Slika 2.30: Gumbi za oblikovanje znakov

2.5.7 Samooblikovanje

Določene dele dokumenta bo uredil Writer sam glede na možnosti, ki so izbrane
(obkljukane) in jih je možno ponastaviti v meniju Orodja→Možnosti samopopravkov (Tools→
AutoCorrect Options), kot kaže slika 2.31.

2.5.8 Oštevilčevanje ali oznake

V orodni vrstici za oblikovanje najdemo tudi gumba Oštevilčevanje vključeno/izključeno
(Numbering On/Off) in Oznake Vključene/izključene (Bullets On/Off). Ta dva gumba
uporabimo, kadar naštevamo elemente vertikalno oziroma delamo seznam. Da nam ni treba
vsakič znova oštevilčiti ali označiti novega elementa v istem naštevanju, lahko uporabimo enega
izmed teh dveh gumbov, saj nam že pritisk na Enter oštevilči/označi nov element naštevanja.

V bolj sistematičnih dokumentih oziroma besedilih večkrat uporabimo kombinacijo obeh vrst
naštevanja. Kombinacije zahtevnejše uporabe teh dveh gumbov najdemo v pogovornem oknu
Označevanje in oštevilčevanje, ki ga odpremo tako, da v orodni vrstici izberemo Oblika in
poiščemo omenjeno pogovorno okno, ki ga prikazuje slika 2.32.

2.5.9 Uporaba sprotnih in končnih opomb

Za dodatna pojasnila in dopolnila v besedilih uporabljamo opombe, ki jih lahko dodajamo pod
črto na dnu iste strani – sprotna opomba ali pa jih zberemo na koncu dokumenta – končna
opomba.

To storimo tako, da v orodni vrstici izberemo Vstavi→Sprotna/končna opomba
(Insert→Footnote/Endnote), kjer se nam odpre pogovorno okno Vstavi sprotno/končno
opombo, ki ga prikazuje slika 2.33. V istem pogovornem oknu lahko nastavimo tudi oštevilčevanje,
ki je lahko samodejno (arabske številke) ali izberemo poljuben znak (npr. rimske številke). Če
kasneje besedilo z opombami prestavimo, se skupaj z njim prestavijo tudi vse opombe, ki so bile
dodane.
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Slika 2.31: Pogovorno okno Samopopravki

Slika 2.32: Pogovorno okno Označevanje in oštevilčevanje
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Slika 2.33: Vstavljanje sprotnih in končnih opomb

Slika 2.34: Pogovorno okno Črkovanje

2.5.10 Preverjanje črkovanja in slovnice

Črkovanje

Z Writer-jem lahko preverimo črkovanje z vgrajenim slovarjem, ki sicer služi tudi podčrtovanju
nepravilno zapisanih besed, ki ga je potrebno seveda posebej vključiti. Če nam Writer podčrta
besedo, lahko njen pravilen zapis najdemo med ponujenimi možnostmi (slika 2.34), do katerih
pridemo, če desno-kliknemo nanjo.

Slovnica

Preverjanje slovnice nastavimo, če izberemo Orodja→Možnosti→Nastavitve jezika→Pripo-
močki za pisanje→Možnosti (Tools→Options→Language Settings→Writing Aids→Op-
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Slika 2.35: Vstavljanje povezave do slike

Slika 2.36: Orodna vrstica Risba

tions), kjer poljubno nastavimo možnosti preverjanja slovnice.

2.6 Delo s slikami

2.6.1 Dodajanje slik v dokument

Pogosto v naše pisne izdelke dodajamo tudi slike, sheme itn. Te imamo lahko shranjene
v kakšni drugi datoteki, zato v tem primeru izberemo Vstavi→Slika→Iz datoteke
(Insert→Image→From File).

Če ne želimo prevelike datoteke, ki jo povzroči dodajanje slik, lahko sliko vstavimo tudi kot
povezavo (glej sliko 2.35). Prednost takega dodajanja slik je tudi v tem, da jih lahko kasneje v
posebni, od glavne datoteke ločeni datoteki brez skrbi spreminjamo. Prav tako pa lahko sliko
vstavimo tudi z uporabo optičnega čitalca – skenerja.

Četrti način vstavljanja slik je način povleci in spusti (Drag and Drop), pri čemer sliko iz
matičnega dokumenta potegnemo v naš dokument.

Peti način vstavljanja slik pa je način Kopiraj in Prilepi (Copy and Paste), pri čemer
desno-kliknemo na izbrano sliko in v kontekstnem meniju kliknemo Kopiraj, nato pa v našem
dokumentu desno-kliknemo na izbrano mesto in v konteksten meniju kliknemo Prilepi.

Pri dodajanju slik s spleta moramo upoštevati avtorske pravice.

2.6.2 Uporaba orodij za risanje

Če želimo sami narisati risbo ali shemo, vključimo orodno vrstico Risba tako, da v menijski vrstici
izberemo Pogled→Orodne vrstice→Risba (View→Toolbars→Drawing) (glej sliko 2.36). Ta
nam ponuja veliko različnih orodij za risanje, ki jih je treba preizkusiti.

2.6.3 Določanje položaja slik v besedilu

Če na sliko dvokliknemo, se odpre pogovorno okno Slika, ki vsebuje kar nekaj zavihkov (glej
sliko 2.37), ki ponujajo različne možnosti. Med zanimivejšimi zavihki so:
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Slika 2.37: Pogovorno okno Slika

Slika 2.38: Orodna vrstica za urejanje slike

• Vrsta – urejamo velikost slike itn.;

• Oblivanje – nastavimo vpetost slike v besedilo;

• Slika – sliko lahko obrnemo;

• Obreži – sliko lahko obrežemo;

• Obrobe – določimo slog in položaj obrobe.

Ko sliko vstavimo v dokument, se v orodni vrstici samodejno pojavi več novih orodij za
urejanje slik (glej sliko 2.38), ki jih ne bomo posebej opisovali. Z njimi lahko sliko stilsko uredimo.

2.6.4 Dodajanje napisov k sliki

Sliko, ki jo dodamo v dokument, moramo tudi poimenovati in oštevilčiti, zato je najlažje, da slike
označimo. To nam bo obenem zelo koristilo pri sestavljanju seznama slik, pa tudi pri navzkrižnem
sklicevanju.
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Slika 2.39: Pot do pogovornega okna Napis

Napis vstavimo tako, da najprej levo-kliknemo na sliko, nato pa v menijski vrstici izberemo
Vstavi→Napis (Insert→Caption). Enak učinek dosežemo tudi, če desno-kliknemo na sliko
in v kontekstnem meniju izberemo Napis (glej sliko 2.39).

Odpre se pogovorno okno Napis (glej sliko 2.40), kjer v rubriki Napis vpišemo ime slike,
v rubriki Lastnosti pod Kategorijo vpišemo vrsto slike (Slika, Ilustracija itn.), pod
Oštevilčevanje vpišemo vrsto številk (Arabske, Rimske itn.), pod Ločilo vpišemo npr.
dvopičje, pod Položaj pa izberemo, kje naj se napis nahaja. Na koncu kliknemo V redu.

2.6.5 Navzkrižno sklicevanje

Eden izmed razlogov za uporabo napisov je tudi možnost navzkrižnega sklicevanja. Klik na
takšen sklic vodi bralca neposredno na sliko.

Sklic vstavimo takole:

1. Kazalec postavimo, kamor želimo vstaviti navzkrižni sklic.

2. Izberemo Vstavi→Navzkrižno sklicevanje (Insert→Cross-reference).

3. Za vrsto sklica izberemo Slika oziroma tisto, kar smo izbrali za kategorijo. Seznam vseh
tabel z napisi se bo prikazal na desni strani. Izberemo tisto, na katero se želimo sklicati.

4. V zadnjem podoknu je potrebno izbrati še, kakšne oblike bo sklic:

• Stran – sklic na številko strani s sliko z napisom.
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Slika 2.40: Pogovorno okno Napis

• Poglavje – sklic na zaporedno številko poglavja, kjer je napis. Sklic bo prazen,
razen, če poglavja niso nastavljena v dokumentu.

• Sklic – vstavi vse atribute napisa – kategorijo, zaporedno številko in besedilo.

• Zgoraj/spodaj – vstavi besedo ”zgoraj” ali ”spodaj”, odvisno od položaja tabele glede
na sklic.

• Kot slog strani – vstavi številko strani napisa z uporabo stila strani.

• Kategorija in številka – vstavi kategorijo in zaporedno številko (na primer Slika
10 ).

• Besedilo napisa – vstavi besedilo napisa.

• Oštevilčevanje – vstavi le zaporedno številko.

5. Kliknemo V redu, nato Zapri.

2.7 Delo s tabelami

2.7.1 Vstavljanje in oblikovanje tabele

Velikokrat imamo opravka z najrazličnejšimi podatki, ki jih je potrebno nekje prikazati, zato
uporabljamo tabele.

Tabelo vstavimo tako, da v menijski vrstici izberemo Tabela→Vstavi→Tabela (Ta-
ble→Insert→Table), ko se nam odpre pogovorno okno Vstavi tabelo, ali pa v menijski
vrstici izberemo Vstavi→Tabela (Insert→Table).

V pogovornem oknu Vstavi tabelo nato v rubriki Ime vpišemo ime tabele, v rubriki
Velikost pa pod Stolpci in Vrstice izberemo želeno število stolpcev in vrstic.

Odločimo se lahko tudi za vnaprej določene oblike tabele, če v spodnji levi strani pogovornega
okna kliknemo Samooblikovanje. Odpre se namreč novo pogovorno okno Samooblikovanje, kjer
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Slika 2.41: Pogovorno okno Samooblikovanje

Slika 2.42: Orodna vrstica Tabela

si lahko izberemo želeno obliko. V tem pogovornem oknu lahko kliknemo tudi na gumb Dodatno,
kjer lahko izberemo še nekatere druge možnosti (Pisava, Obrobe itd.) (glej sliko 2.41).

Tabelo lahko vstavimo tudi tako, da v orodni vrstici kliknemo na gumb Tabela ali vtipkamo
Ctrl+F12 in izberemo želeno število stolpcev in vrstic, kot smo opisali zgoraj.

Za delo s tabelami si lahko vključimo tudi orodno vrstico Tabele, ki jo prikličemo tako, da
v menijski vrstici izberemo Pogled→Orodne vrstice→Tabela (View→Toolbars→Table). S
pomočjo te orodne vrstice lahko zelo hitro oblikujemo tabelo (glej sliko 2.42).

2.7.2 Vnos podatkov in manipuliranje v tabelah

Prehajanje med celicami

Za prehajanje med celicami v tabeli uporabljamo miško, smerne tipke ali tipko Tab.
S smerno tipko se premaknemo v naslednjo celico, če na poti kazalca ni besedila. Na primer,

če pritisnemo desno smerno tipko, bo se bo kazalec premaknil najprej na naslednji znak v besedilu
v trenutni celici. Ko bo prišel do konca besedila, se bo premaknil na sosednjo celico.

S tipko Tab se neposredno premaknemo na naslednjo celico. Če je kazalec v zadnji celici, Tab
ustvari novo vrstico. Kombinacija Shift+Tab premakne kazalec na prejšnjo celico. Na začetek
tabele skočimo s Ctrl+Home, na konec s Ctrl+End.

Sortiranje tabele

Kot je običajno pri preglednicah, tudi Writer omogoča sortiranje vsebine celic po vrstnem
redu. Omogočeno je največ tri-nivojsko sortiranje (na primer najprej številsko po starosti, nato
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abecedno po priimku in imenu znotraj vsake starosti).
Postopek sortiranja:

1. Izberemo tabelo oziroma del tabele.

2. Iz menija izberemo Tabela→Razvrsti (Table→Sort) ali gumb Razvrsti iz orodne
vrstice Tabela.

3. V pogovornem oknu Razvrsti:

(a) Izberemo, ali želimo sortirati po vrsticah ali stolpcih. Privzeta smer sortiranja so
vrstice, kar pomeni, da sortiramo vse vrednosti v določenem stolpcu.

(b) Izberemo do tri ključe (stolpce/vrstice), katere želimo sortirati.

(c) Za vsak ključ izberemo, ali je sortiranje številsko ali abecedno in ali je naraščajoče
ali padajoče.

(d) Izberemo V redu za potrditev sortiranja.

Izbrati moramo vse celice, ki bodo sodelovale pri sortiranju. Če izberemo le en stolpec v
tabeli, na ostale sortiranje ne bo vplivalo. Potrebno je biti pozoren, da ne pride do neželenega
mešanja podatkov.

Uporaba funkcij v tabeli

Writer vsebuje tudi osnovne matematične funkcije, katerih uporabe smo bolj vajeni pri elektron-
skih preglednicah. Writer obravnava tabelo kot delovni list s celicami. Vsaka celica je opredeljena
s črko (stolpec) in številko (vrstica). Celica C4 na primer je celica v tretjem stolpcu in četrti
vrstici. Ko izberemo celico s kazalcem, je ime tabele in celice vidno v statusni vrstici.

Funkcije se obnašajo enako kot pri Calc-u. Glavna razlika je pri zapisu celic. Sklic na celico
A2 (prva vrstica, drugi stolpec) zapišemo kot A2 (oz. $A$2 za absolutni sklic), pri Writer-ju pa
je ta sklic <A2>.

Recimo, da želimo števili v <B1> in <C2> sešteti in rezultat prikazati v celici <A1> (slika 2.43).
Postopamo takole:

1. Kliknemo na celico <A1> in vpišemo = ali v meniju izberemo Tabela→Formula
(Table→Formula) (bližnjica F2). Na vrhu zaslona pod orodnimi vrsticami se pojavi
vpisna vrstica.

2. Kliknemo celico <B1>. Zapis celice se takoj pojavi v vpisni vrstici in v celici <A1>.

3. Vnesemo +.

4. Kliknemo na celico <C2>. Končna formula =<B1>+<C2> je vnesena.

5. Pritisnemo Enter ali kliknemo na gumb Uporabi za izračun formule. Če želimo for-
mulo urediti, ponovno izberemo Tabela→Formula.
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Slika 2.43: Uporaba funkcij v tabeli

Seštevanje več celic, na primer, poteka takole:

1. Vpišemo = v prazno celico.

2. Vpišemo sum ali funkcijo vsote izberemo iz seznama vseh funkcij, ki ga prikličemo z
gumbom f(x). Nahaja se pred vnosno vrstico.

3. Izberemo obseg celic. Končna formula bo videti takole: =sum<A2:A5>.

4. Pritisnemo Enter ali kliknemo na gumb Uporabi za izračun formule.

2.7.3 Dodatne operacije v tabelah

Zaščita celic

Celice v tabeli lahko zaščitimo pred spremembami. Ta zaščita ni namenjena varnosti in ne
uporablja gesel. Je le stikalo, ki ščiti pred nenamernimi spremembami.

Celice zaščitimo tako, da jih izberemo, z desnim klikom prikličemo kontekstni meni in
izberemo Celica→Zaščiti (Cell→Protect).

Zaščito odstranimo na več načinov:

• Kazalec postavimo v celico ali izberemo obseg celic. Če je treba, izberemo
Orodja→Možnosti→LibreOffice Writer→Pripomočki za oblikovanje (Tools→Op-
tions→LibreOffice Writer→Formatting Aids) in omogočimo kazalko v zaščite-
nih območjih (Cursor in protected areas). Nato z desnim klikom iz kontekstnega
menija izberi Celica→Odstrani zaščito (Cell→Unprotect).

• V Krmarju izberemo tabelo in v kontekstnem meniju izberemo Tabela→Odstrani
zaščito.

• S kombinacijo Ctrl+Shift+T odstranimo zaščito v celotni trenutno izbrani tabeli.

Dodajanje napisov

Tabelo lahko opremimo z dodatnim besedilom, podobno kot pri slikah. Writer bo tabele z napisi
avtomatsko številčil in posodabljal vse povezave v besedilu.

Napis dodamo takole:
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1. Postavimo kazalec v tabelo.

2. Z desnim klikom v kontekstnem meniju izberemo Napis. Dosegljiv je tudi v glavnem
meniju pod Vstavi→Napis.

3. Vpišemo besedilo za napis, izbiro kategorije (besedilo, tabela, risba, ilustracija), tip
oštevilčevanja, ločilo in položaj (pod ali nad tabelo).

4. Kliknemo V redu.

Izdelamo lahko tudi svojo kategorijo. Recimo, da želimo tabele označiti kot Shema, oštevilčiti z
rimskimi številkami in za ločilo imeti piko:

Shema I. Besedilo
Shema II. Daljše besedilo
Shema III. Krajše besedilo

Postopek je naslednji:

1. Odpremo pogovorno okno Napis.

2. Izberemo kategorijo Besedilo in vpišemo Shema.

3. Za oštevilčevanje izberemo možnost Rimske (I II III).

4. Za ločilo izberemo piko.

Glava tabele

Če tabela nima glave, jo lahko dodamo tako, da izberemo prvo vrstico in iz menija izberemo
Tabela→Vstavi→Vrstice (Table→Insert→Rows). V pogovornem oknu, ki se odpre, preve-
rimo, ali vstavljamo pred izbrano vrstico. Novo ustvarjeno vrstico nato oblikujemo po želji preko
okna Slogi in Oblikovanje. Alternativno uporabimo samooblikovanje (Tabela→Samoobli-
kovanje (Table→AutoFormat)).

Spajanje/razdelitev tabel

Tabelo lahko razdelimo v dve tabeli, tako kot lahko dve spojimo v eno. Razdelimo jo lahko le
vodoravno (vrstice nad kazalcem gredo v gornjo tabelo, ostale vrstice v spodnjo).

Da tabelo razdelimo:

1. Postavimo kazalec v celico, ki bo v prvi vrstici druge tabele po razdelitvi.

2. Z desnim klikom preko kontekstnega menija izberemo Razdeli tabelo, ki je dosegljiva
tudi v meniju Tabela→Razdeli tabelo (Table→Split Table).

3. Odpre se pogovorno okno Razdeli tabelo. Izbira Brez naslova razdeli tabelo po
pričakovanjih, lahko pa tabeli oblikujemo tako, da se prva vrstica – glava prenese v drugo
tabelo.



54 Urejevalnik besedil

4. Kliknemo V redu. Tabela je s prazno vrstico razdeljena v dve tabeli.

Če uporabljamo formule v tabelah, je pri razdeljevanju tabele potrebno paziti. Formula ne sme
vsebovati sklicev na celice iz druge tabele, sicer pride do napake (** Izraz je napačen **).
Spomnimo se, da so imena celic relativna glede na tabelo.

Da spojimo dve tabeli:

1. Zbrišemo prazno vrstico med tabelama. Uporabite tipko Delete in ne Backspace.

2. Izberemo eno izmed celic.

3. Iz kontekstnega menija izberemo Spoji tabele.

Brisanje/kopiranje tabele

Tabelo zbrišemo tako, da:

1. Kliknemo na katerokoli celico v tabeli.

2. V meniju izberemo Tabela→Izbriši→Tabela (Table→Delete→Table).

Druga možnost je:

1. Označimo besedilo vključno od konca odstavka pred tabelo do začetka odstavka za tabelo.
Ta združi oba odstavka, kar mogoče ne želimo.

2. Pritisnemo tipko Delete ali Backspace.

Tabelo skopiramo tako, da:

1. Kliknemo na katerokoli celico v tabeli.

2. V meniju izberemo Tabela→Izberi→Tabela (Table→Select→Table).

3. Pritisnemo Ctrl+C ali kliknemo gumb Kopiraj iz orodne vrstice Standardno.

4. Kliknemo na želeno mesto v dokumentu.

5. Pritisnemo Ctrl+V ali kliknemo gumb Prilepi iz orodne vrstice Standardno.

2.7.4 Orodna vrstica Tabela

Vsi ukazi v tem poglavju so dosegljivi v menijski izbiri Tabela in v orodni vrstici Tabela (slika
2.44). Tabela 2.1 opisuje učinke vseh gumbov orodne vrstice. Ko ustvarimo ali izberemo tabelo,
se ta avtomatsko prikaže. Ročno jo prikažemo z izbiro Pogled→Orodne vrstice→Tabela
(View→Toolbars→Table). Orodna vrstica lahko lebdi kot na sliki 2.44, lahko pa jo zasidramo
na katerikoli rob glavnega okna.
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1 Slog črte 8 Zgoraj 15 Izberi tabelo
2 Barva obrobne črte 9 Sredina (navpično) 16 Izberi stolpec
3 Obrobe 10 Spodaj 17 Izberi vrstice
4 Barva ozadja 11 Vstavi vrstico 18 Samooblikovanje
5 Spoji celice 12 Vstavi stolpec 19 Lastnosti tabele
6 Razdeli celice 13 Izbriši vrstico 20 Razvrsti
7 Optimiziraj 14 Izbriši stolpec 21 Vsota

Slika 2.44: Orodna vrstica Tabela

2.8 Kazala in seznami

Kazala vsebine in podobne sezname lahko izdelamo ročno (česar ne bomo posebej predstavljali)
ali pa na podlagi predhodno urejenih slogov, kar je zelo hitro in enostavno.

V menijski vrstici izberemo Vstavi→Kazala vsebine→Kazala vsebine (Insert→
Indexes and Tables→Indexes and Tables) in pojavi se pogovorno okno Vstavi kazalo (glej
sliko 2.45). Na desni strani pogovornega okna v rubriki Vrsta in naslov zaenkrat nič ne
spreminjamo, odkljukamo pa Zaščiteno pred ročnim spreminjanjem, zato da bomo lahko
kasneje še kaj spremenili.

Če imamo opravka z relativno kratkim dokumentom, bomo izdelali kazalo za celoten
dokument, v obratnem primeru pa lahko izdelamo kazala za vsako poglavje posebej. To
nastavimo v rubriki Ustvari kazalo za celoten dokument/poglavje. Prav tako se sami
odločimo, ali bomo v kazalu zajeli naslove na vseh nivojih ali ne. To nastavimo v rubriki
Ustvari kazalo→Ovrednoti do ravni, kjer na desni strani izberemo, do katere ravni oziroma
nivoja naslovov naj bo izpisano naše kazalo.

Ozadje našega kazala se bo v dokumentu obarvalo sivo, saj gre za prikaz polj. Če želimo kazalo
spremeniti, lahko uredimo sloge posameznih ravni, tako da izberemo Slogi in oblikovanje,
kjer se na seznamu pojavijo ravni naslovov v obliki Naslov 1, Naslov 2 itn. Če torej želimo
katerokoli raven naslovov spremeniti, desno-kliknemo nanjo in izberemo Spremeni (glej sliko
2.46).

Vstavljeno kazalo lahko popravljamo tudi prek kontekstnega menija (glej sliko 2.47), kjer
lahko izberemo:

• Posodobi kazalo za dodajanje novih naslovov in podnaslovov ter popravljanje številk
strani,

• Uredi kazalo za nastavljanje kazala ali
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1 Slog črte Odpre podokno za izbiro sloga obrobe izbranih celic.
2 Barva obrobne črte Odpre paleto barv za obrobno črto izbranih celic.

3 Obrobe Odpre podokno za izbiro, katere strani izbranih celic
bodo imele obrobo.

4 Barva ozadja Odpre paleto barv za ozadje izbranih celic.
5 Spoji celice Spoji izbrane celice.

6 Razdeli celice Odpre pogovorno okno Razdeli celice, kjer
izberemo način razdelitve izbranih celic.

7 Optimiziraj
Odpre podokno, kjer se lahko odločimo za enakomerno
porazdelitev izbranih stolpcev/vrstic in optimalne
višine vrstice/širine stolpca glede na vsebino celic.

8 Zgoraj Poravna vsebino na vrh celice.
9 Sredina (navpično) Poravna vsebino na sredino celice.
10 Spodaj Poravna vsebino na dno celice.
11 Vstavi vrstico Vstavi vrstico pod izbrano vrstico.
12 Vstavi stolpec Vstavi vrstico za izbranim stolpcem.
13 Izbriši vrstico Izbriše izbrane vrstice iz tabele.
14 Izbriši stolpec Izbriše izbrane stolpce iz tabele.
15 Izberi tabelo Izbere celotno tabelo.
16 Izberi stolpec Izbere stolpec, v katerem je kazalec.
17 Izberi vrstice Izbere vrstico, v kateri je kazalec.

18 Samooblikovanje Odpre pogovorno okno Samooblikovanje za izbiro
predefiniranih oblikovanj tabele.

19 Lastnosti tabele

Odpre pogovorno okno Oblika tabele, kjer določamo
vse lastnosti tabele (ime, poravnave, razmike, širine
stolpcev, obrobe, ozadje). Dosegljiv je tudi preko
kontekstnega menija.

20 Razvrsti Odpre pogovorno okno Razvrsti, kjer izbiramo med
kriteriji razvrščanja.

21 Vsota Aktivira funkcijo sum to je v vnosno vrstico vpiše =
sum. Več o tem v razdelku Uporaba funkcij v tabeli.

Tabela 2.1: Funkcije gumbov na orodni vrstici Tabela
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Slika 2.45: Nastavljanje kazala

Slika 2.46: Spreminjanje slogov kazala
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Slika 2.47: Popravljanje kazala

• Izbriši kazalo za izbris kazala.

Sezname slik, tabel itn. ustvarjamo na zelo podoben način. Tudi v tem primeru namreč v
menijski vrstici izberemo Vstavi→Kazala vsebine→Kazala vsebine. Razlika je le v tem, da
v rubriki Vrsta in naslov za Vrsto izberemo npr. Kazalo ilustracij, Kazalo tabel itn.
(glej sliko 2.48).

Ker ni nujno, da bomo kazalo delali povsem na koncu, je velika verjetnost, da bomo v naš
dokument še kaj vnašali. To pa lahko pomeni spreminjanje številk strani posameznih naslovov.
Vendar nas zaradi dosledne uporabe slogov to ne bi smelo skrbeti, saj se polja samodejno
posodobijo in tako sledijo spremembam. Vse spremembe lahko sinhroniziramo sami tako, da
izberemo Orodja→ Posodobi→Posodobi vse (Tools→Update→Update All), ali pa se bodo
vsa polja posodobila sama, ko bomo dokument shranili.

2.9 Spajanje pošte

2.9.1 Kaj je spajanje pošte?

Večina modernih urejevalnikov besedil ponuja nekaj naprednejših funkcij za pomoč pri izdelavi
serijskih oziroma tipskih pisem. Tudi z Writer-jem lahko dokument izdelamo kot serijsko pismo,
ki ga pošljemo različnim strankam, ustvarimo pa lahko tudi ovojnice in nalepke zanje.

Za izdelavo serijskih pisem, ovojnic in nalepk potrebujemo seznam naslovnikov teh pisem.
Seznam hranimo v zbirki podatkov oziroma v podatkovni bazi.

Podatkovna baza je zbirka med seboj pomensko povezanih podatkov, ki so shranjeni v
računalniškem sistemu, a ne v klasični, datotečni obliki; dostop do njih je centraliziran in
omogočen s pomočjo sistema za upravljanje s podatkovno bazo (LibreOffice Base, Oracle, MS
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Slika 2.48: Seznam slik

Access, MS SQL Server ipd.). V LibreOffice Writer-ju so to izključno podatkovne baze sistema
za upravljanje s podatkovno bazo LibreOffice Base.

Writer omogoča enostavno pretvorbo vsakršnega tipa podatkov v zahtevano obliko. V
naslednji vaji bomo uporabili tabelo preglednice Calc.

Podatkovni vir pri izdelavi serijskih pisem je torej podatkovna baza, ki vsebuje imena, priimke
in poštne naslove, na podlagi katerih lahko naredimo seznam naslovnikov. Pisma in nalepke lahko
seveda natisnemo tudi brez uporabe podatkovnega vira, vendar je to zamudnejše, saj bi morali
izdelati toliko različnih dokumentov kot je naslovnikov.

V izdelanem osnovnem dokumentu z vsebino (npr. zahvala, vabilo, ponudba za delo itd.)
določimo posebna polja (naslovnik itd.), ki so spremenljiva in jih črpamo iz podatkovnega vira.
Na tak način lahko naenkrat izdelamo več podobnih dokumentov, nalepk, ovojnic ter pošljemo
več e-pisem.

2.9.2 Primer: Serijsko pismo

Izdelati želimo serijsko pismo, namenjeno našim poslovnim strankam.

1. V tabeli v elektronski preglednici (Calc) imamo shranjene naslednje podatke o naših
poslovnih strankah, ki jih moramo pripraviti za uporabo:

• naziv,

• ime,

• priimek,

• naslov,

• pošta,
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Slika 2.49: Osnovni dokument

• kraj,

• elektronski naslov.

2. Upoštevajmo še naslednje zahteve:

• Dokument naj vsebuje datum izdelave pisma v obliki polja, ki se samodejno
posodablja.

• Glede na spol naslovnika izpišite v pozdravni vrstici ”Spoštovani/a gospod/gospa
<ime>!”.

3. V nadaljevanju pripravimo še možnost tiskanja nalepk za kuverte.

Priprava osnovnega dokumenta

Dokument, ki ga želimo poslati našim poslovnim strankam, naj ima približno takšno obliko, kot
jo prikazuje slika 2.49. Za pisanje takšnega dokumenta uporabimo urejevalnik besedil Writer.

Baza poslovnih strank

V pismu na sliki 2.49 manjka naslovnik oziroma naslovni blok. Podatkovni vir za serijska pisma
je lahko tekstovna datoteka (končnica *.txt, *.csv), datoteka elektronske preglednice (končnica
*.ods, *.xls), adresar odjemalca elektronske pošte (MS Outlook, Thunderbird ipd.), lahko pa se
povežemo z že obstoječo podatkovno bazo.
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Slika 2.50: Čarovnik za zbirke podatkov

Elektronska preglednica je računalniška aplikacija, ki simulira delovni list. Sestavlja ga
mreža celic, kamor lahko vpisujemo besedilo, števila ali formule. Formula celice določa, kako
se bo vsebina izračunala iz drugih celic, kadarkoli se vsebina katerekoli druge celice spremeni.
Najbolj znani primeri preglednic, ki jih poznamo, so LibreOffice Calc, OpenOffice Calc, MS
Excel, Kspread ipd.

Pri tej vaji seznam strank hranimo v elektronski preglednici, torej datoteki formata Calc.
Da bi seznam uporabili kot dejanski vir podatkov, ga moramo najprej registrirati. To pomeni,
da izdelamo novo datoteko – podatkovno bazo, ki je zgrajena na podlagi izvirne datoteke.

Izdelava podatkovne baze je dosegljiva tudi preko menijske vrstice Write-rja, kjer izberemo
Datoteka→Nov→Zbirka podatkov (File→New→Database). Odpre se nam Čarovnik za
zbirke podatkov, s pomočjo katerega se bomo povezali z našo podatkovno bazo. Desno
spodaj izberemo Povezati se z obstoječo zbirko podatkov, kjer med možnostmi poiščemo
in kliknemo na Preglednico, nato pa kliknemo Naprej (glej sliko 2.50).

V naslednjem koraku kliknemo Prebrskaj (glej sliko 2.51), kjer se nam odpre dostop do vseh
naših datotek. Poiščemo podatkovno bazo, iz katere želimo črpati podatke ter kliknemo Odpri,
nato spodaj ponovno kliknemo Naprej.

V zadnjem koraku registriramo zbirko podatkov v LibreOffice tako, da to potrdimo z izbiro
prve možnosti Da, registriraj zbirko podatkov zame. V tem koraku pa tudi odkljukamo
možnost Odpri zbirko podatkov za urejanje, saj tega namena trenutno nimamo (glej sliko
2.52).

Odpre se nam pogovorno okno Shrani kot, kjer izberemo ime datoteke in kliknemo Shrani.
Na ta način je podatkovna baza shranjena in uporabna za delo v Writer-ju.
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Slika 2.51: Povezava na preglednico

Slika 2.52: Registracija zbirke podatkov v LibreOffice
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Slika 2.53: Vir podatkov za serijsko pismo

Sedaj v menijski vrstici izberemo Pogled→Viri podatkov (View→Data Sources) (glej
sliko 2.53). Če smo uspešno registrirali vir podatkov, se nam bo njegovo ime pojavilo v levem
zgornjem oknu, zato ga izberemo z dvoklikom in na desni strani se nam bodo prikazali podatki
(več na sliki 2.54).

V naslednjem koraku izberemo podatke, ki jih želimo imeti na našem dokumentu – oblikujemo
naslovni blok. To najhitreje in najenostavneje naredimo tako, da kliknemo na glavo stolpca (npr.
Podjetje), držimo in prenesemo na želeno mesto. Prikazali se bodo zaznamki, kamor se bodo
kasneje prenesli podatki iz baze (glej sliko 2.54).

Posebne zahteve

Na koncu pisma dodajmo še polje, kamor se bo samodejno vpisal datum zadnjega popravka. To
polje najdemo pod Vstavi→Polja→Drugo (Insert→Fields→Other), kjer v zavihku Podatki
o dokumentu v rubriki Vrsta izberemo Spremenjeno, v rubriki Izberi izberemo Datum, v rubriki
Oblika pa želeni način zapisa datuma (glej sliko 2.55) ter kliknemo Vstavi.

Datum je nastavljen, kar prikazuje slika 2.56.
Pismo želimo še bolj poosebiti: dodali bomo pozdrav, ki bo upošteval spol prejemnika.

Uporabili bomo eno izmed posebnih polj, ki jih lahko uporabimo pri spajanju. To storimo tako,
da v menijski vrstici izberemo Vstavi→Polja→Drugo, nato pa v zavihku Funkcije v rubriki
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Slika 2.54: Izdelava naslovnega bloka po načelu povleci in spusti

Slika 2.55: Polje Datum zadnje spremembe



2.9 Spajanje pošte 65

Slika 2.56: Izgled pisma, ko smo nastavili datum

Vrsta izberemo Pogojno besedilo. Le-to omogoča pogojni vpis besedila – glede na vrednost
poljubnega polja iz podatkovne baze. Za ta namen bomo uporabili polje Naziv. Ker v naši bazi
hranimo le dve možni vrednosti (”gospod” in ”gospa”), lahko uporabimo naslednjo logiko:

ČE je vrednost polja Naziv enaka ”gospod”,

POTEM izpiši ”Spoštovani gospod!”,

SICER izpiši ”Spoštovana gospa!” (glej sliko 2.57).

Posebnosti pri določanju pogoja:

• dobesedno besedilo pišemo z dvojnimi narekovaji,

• primerjalni operator je dvojni enačaj ==,

• na polja iz podatkovne baze se sklicujemo takole: Baza.Tabela.Polje (če imamo le eno
bazo/tabelo, jo lahko izpustimo in napišemo le Polje).

Nalepke za kuverte

Do nalepk za kuverte pridemo preko menijske vrstice Datoteka→Nova→Nalepke (File
→New→Labels). Uporabili bomo ista polja kot pri naslovnem bloku pisma, le da tu izbira
poteka preko izbirnega okna (glej sliko 2.58). Izberemo bazo, tabelo in polje v tabeli, ki ga s
klikom na puščico prenesemo tja, kamor kaže kazalec. Lahko ga premikamo, vstavljamo svoje
besedilo (presledke, novo vrstico, ...) in s tem oblikujemo izpis. Obliko kuverte nastavimo v
zavihku oblika, nato jo shranimo v nov dokument ali jo vključimo v obstoječ dokument kot novo
stran.

Pri izdelavi nalepk nas pričaka podobno izbirno okno, paziti je treba le še na pravilno izbiro
tipa nalepk. Vsak tip ima na škatli napisano tudi oznako (npr. Zweckform 4322 ).
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Slika 2.57: Vstavljanje pogojnega kazala

Slika 2.58: Uporaba polj za izdelavo kuverte
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Slika 2.59: Pismo s podatki iz baze

Spajanje

Z izdelavo pisma smo končali. Želimo preveriti, kaj se bo dejansko izpisalo, ko dokument spojimo
z virom podatkov. Izberemo želeno vrstico (glej sliko 2.59) in kliknemo na gumb Podatki v
polja v opravilni vrstici, ki se prikaže z virom podatkov.

Ostane nam le še tiskanje oziroma pošiljanje po elektronski pošti. Če želimo dokument
izpisati (Natisni v standardni orodni vrstici), Writer ugotovi, da uporabljamo spojna polja,
zato prikaže dodatno izbirno okno za nadaljnje ukaze. Za potrebe vaje bomo izbrali vse zapise
baze in rezultat shranili v eno datoteko. Posamezna pisma se bodo tako shranila kot ena stran
v novem dokumentu.

2.10 Obrazci

Večkrat želimo pripraviti dokument, ki ga bodo lahko drugi ljudje dopolnjevali samo delno.
Primeri so različne pogodbe ali poročila, kjer želimo, da nekdo vpiše posamezne podatke, po drugi
strani pa mora že vnaprej pripravljen tekst ostati nespremenjen. To storimo tako, da pripravimo
dokument, ki ga zaklenemo za spremembe, v njem pa pustimo polja, v katera je mogoče pisati.
Vnosom v teh poljih lahko določamo obliko ali pa izvajamo kakšne druge preproste obdelave.
Sicer LibreOffice vsebuje močne kontrolnike za izdelavo obrazcev v povezavi s podatkovnimi
bazami, a teh podrobnosti v tem delu ne bomo posebej predstavljali.
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2.10.1 Primer: Odprava pošiljke

Za primer vzemimo obrazec za odpremo pošiljke. Elementi tega dokumenta so podatki o
prejemniku pošiljke, vsebina pošiljke, podatki o osebi, ki je pošiljko pripravila in način dostave.
Slika 2.60 prikazuje primer takšnega dokumenta.

Pomembno: preden v dokument vstavite tabelo, vstavite prazno vrstico, da preskočite v
naslednjo vrstico, tabela se namreč ne sme začeti povsem na vrhu dokumenta, saj boste v tem
primeru imeli kasneje težave!

Oblikovali smo strukturo obrazca in napisali spremni, fiksni tekst. V obrazec je zdaj treba
vstaviti vnosna polja, kamor bodo kasneje uporabniki vpisovali zahtevane podatke.

V prvi tabeli Prejemnik bomo vstavili vnosna polja tako, da bomo v menijski vrstici izbrali
Vstavi→Polja→Drugo→Funkcije→Vnosno polje. V polje Sklic vnesimo ime polja (ko bo
uporabnik dejansko vnašal podatke, se mu bo odprlo okno s tem imenom). Polje vstavimo s
klikom na gumb Vstavi. Odpre se novo okno, kamor lahko vpišemo privzeto besedilo (glej sliko
2.61). To lahko pustimo prazno, lahko pa vpišemo testni podatek, če želimo preveriti nastavitve.

Enako postopamo pri drugi tabeli, le da zadnji stolpec cena skupaj pustimo prazen, saj
gre tu za izračun – produkt količine in cene enega kosa. Vnos formul je opisan v podpoglavju
Uporaba funkcij v tabeli. Za izračun celice <E2> vpišemo enačaj, kliknemo na celico C2, vnesemo
*, kliknemo na D2, formulo potrdimo z Enter (glej sliko 2.62).

Vajo ponovimo pri izračunu za vrednost skupaj – gre za seštevek treh celic nad celico za
skupno vrednost pošiljke (desno spodaj). Preko kontekstnega menija lahko celico tudi oblikujemo
npr. v valutno vrednost (Oblika števila→Valuta).

Tretja tabela Pošiljko odpravil vsebuje polja o odpravi pošiljke. Če imamo v podjetju
majhno število oseb, ki odpravljajo pošiljke, je smiselno, da jih izberemo s seznama, da ne bi
vedno znova vnašali podatkov. Vhodni seznam oblikujemo tako, da v menijski vrstici izberemo
Vstavi→Polja→Drugo→Vhodni seznam, kjer kliknemo zavihek Funkcije nato pa v rubriki
Element vpišemo ime in priimek prvega odpravnika pošiljk in kliknemo Dodaj. Tako lahko
dodamo poljubno število elementov v seznam, ki so vidni v rubriki Elementi na seznamu (glej
sliko 2.63).

Za vnosni polji, namenjeni datumu in uri odpreme, bomo uporabili trenutni datum in čas. To
storimo tako, da v menijski vrstici izberemo Vstavi→Polja→Datum (Insert→Fields→Date)
oziroma Vstavi→Polja→Čas (Time). Uporabnik bo lahko nato poljubno spreminjal vsebino
vnosnih polj.

Čaka nas le še tabela z načinom dostave. Privzemimo, da naše podjetje ponuja le dva načina
– navadno in hitro pošto. Uporabili bomo potrditveno polje (checkbox), ki ne spada pod običajna
polja. Je eno izmed preprostejših grafičnih kontrolnikov, ki nudijo obilico možnosti za pripravo
obrazcev.

Za delo s kontrolniki moramo priklicati orodno vrstico Kontrolniki obrazca (Form
Controls), ki jo najdemo, če v menijski vrstici izberemo Pogled→Orodne vrstice. Za
vstavljanje potrditvenega polja moramo najprej omogočiti oblikovanje, zato kliknemo na gumb
Oblikovalni način vključen/izključen. Nato se nam odprejo možnosti za oblikovanje, med
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Slika 2.60: Primer oblikovanja obrazca s tabelami
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Slika 2.61: Določanje vnosnega polja

Slika 2.62: Vnos izračuna
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Slika 2.63: Vhodni seznam

Slika 2.64: Vnašanje potrditvenega polja

katerimi poiščemo gumb Potrditveno polje in kliknemo nanj. S kazalcem miške nato označimo
mesto, kjer bi si želeli vstaviti potrditveno polje – zavzamemo več prostora, da bomo lahko
ob potrditvenem polju vpisali tudi besedilo. Če zavzamemo dovolj prostora, se bo v okvirčku
pojavilo besedilo Potrditveno polje X, kjer X pomeni zaporedno številko polja (glej sliko 2.64).

Ko obrazec oblikujemo, nastavljamo lastnosti, ki bodo prišle do izraza ob uporabi.
Do lastnosti kontrolnika pridemo, če desno-kliknemo na označeno mesto in izberemo gumb
Kontrolnik. Odpre se nam pogovorno okno, kjer v zavihku Splošno poiščemo Oznako in vpišemo
besedilo, ki ga želimo namesto besedila Potrditveno polje X, v našem primeru bo to ”navadna
pošta” v levi celici tabele ter ”hitra pošta” v desni. (glej sliko 2.65).

Možne so tudi ostale nastavitve kontrolnikov, vendar se v te podrobnosti ne bomo spuščali.
Ko z oblikovanjem – vstavljanjem potrditvenih polj zaključimo, izklopimo oblikovalni način
(ponovno kliknemo na gumb Oblikovalni način vključen/izključen) in v potrditvena polja
bo zdaj mogoče vnesti kljukico.

Izpolnjen obrazec mora izgledati kot na sliki 2.67.

Če smo zadovoljni z obrazcem, izbrišemo vse morebitne testne vnose. Želimo namreč
ustvariti predlogo za nove obrazce. To naredimo tako, da v menijski vrstici izberemo
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Slika 2.65: Oznaka potrditvenega polja

Slika 2.66: Končni izgled vnesenih potrditvenih polj
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Slika 2.67: Primer izpolnjenega obrazca
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Slika 2.68: Zaščita odseka pred pisanjem

Datoteka→Shrani kot (File→Save As), kjer v rubriki Vrsta datoteke izberemo Predloga
dokumenta z besedilom. Predloge so datoteke s končnico .ott, ki se navidez ne razlikujejo od
običajnih dokumentov. Edina razlika je ta, da se ob odprtju predloge ustvari nov neimenovan
dokument (z vsebino predloge). Pravzaprav se tudi pri odpiranju novega dokumenta v Writer-ju
uporabi predloga; tista, ki je nastavljena kot privzeta.

Ker želimo, da oblike obrazca nihče ne bo mogel spreminjati (vanj vpisovati ali brisati),
temveč ga bo možno izpolniti zgolj preko vnosnih polj, ga moramo še zakleniti z geslom. To
naredimo tako, da najprej izberemo celotno besedilo, kar najhitreje dosežemo s kombinacijo
Ctrl+A (All)1. Nato ustvarimo nov odsek, ki ga bomo zaščitili pred pisanjem: v menijski
vrstici izberemo Vstavi→Odsek (Insert→Section), kjer se nam odpre pogovorno okno, nato
pa v zavihku Odsek poiščemo rubriko Zaščita pred pisanjem, kjer obkljukamo Zaščiti ter Z
geslom. Odpre se novo pogovorno okno Vnesite geslo, kamor vpišemo geslo in ga potrdimo.
To pogovorno okno se zapre, odprto ostane le še prejšnje pogovorno okno, kjer za zaključek
kliknemo še Vnesi (glej sliko 2.68).

Obrazec je zaklenjen, le vnosna polja so izvzeta. Podatke lahko vpisujemo samo vanje – to
pa je ravno tisto, kar smo želeli doseči. Obrazec je pripravljen za uporabo.

1 Pri tem je treba opozoriti, da to ni mogoče, če se dokument začne s tabelo (na kar smo opozorili v
tretjem odstavku tega podpoglavja)



Poglavje 3

Preglednica

3.1 Predstavitev

3.1.1 Kaj je Calc?

LibreOffice med svojimi komponentami ponuja tudi urejevalnik preglednic Calc. V preglednice
vnašamo podatke (ponavadi številčne), s katerimi nato manipuliramo, da dobimo želene rezultate.

Poleg teh osnovnih funkcij Calc vsebuje tudi:

• funkcije, s katerimi lahko nastavimo formule za zahtevnejše izračunavanje podatkov,

• funkcije, s katerimi podatke urejamo, hranimo in selekcioniramo,

• dinamične tabele oziroma razširjene 2D in 3D tabele,

• makre za posnemanje in izvrševanje nekaterih nalog,

• zmožnost odpiranja, urejanja in shranjevanja Microsoft Excel preglednic,

• uvoz in izvoz preglednic v različnih formatih, vključno s HTML, CSV, PDF in PostScript.

3.1.2 Preglednice, delovni listi in celice (Spreadsheets, sheets, cells)

Calc vsebuje elemente imenovane preglednice, ki so sestavljene iz posameznih delovnih listov. Ti
vsebujejo celice, določene z vrsticami in stolpci, vsaka celica je namreč določena s številko vrstice
in stolpca. Vsaka preglednica lahko vsebuje veliko delovnih listov, ti pa lahko imajo veliko celic.

V celicah so posamezni elementi (besedilo, številke, formule, . . . ), ki predstavljajo podatke,
s katerimi lahko manipuliramo.

3.1.3 Deli delovnega okna Calc-a

Ko zaženemo Calc, se nam pokaže delovno okno, ki ga prikazuje slika 3.1.
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Slika 3.1: Deli delovnega okna

Naslovna vrstica (Title bar)

Zaslonske slike so bile zajete v operacijskem sistemu Ubuntu z uporabniškim vmesnikom Unity.
V želji po čimvečjem prihranku delovnega prostora so avtorji združili naslovno in menijsko vrstico
tako, da si delita prostor na vrhu delovnega okna. Vidna je ves čas, dokler se ji ne približamo
z miškinim kazalcem ali uporabimo menijsko bližnjico. Takrat se odpre menijska vrstica. To
obnašanje je unikatno temu vmesniku, običajno je menijska vrstica pod naslovno.

Sicer naslovna vrstica prikazuje ime trenutne preglednice. Če je ta ustvarjena na novo, jo
Calc poimenuje Neimenovano X, kjer X predstavlja številko. Ko preglednico prvič shranimo, jo
poimenujemo po svoji izbiri.

Menijska vrstica (Menu bar)

Menijska vrstica vsebuje menije s podmeniji:

• Datoteka (File) vsebuje ukaze, ki se nanašajo na celoten dokument. To so na
primer Odpri (Open), Shrani (Save), Čarovniki (Wizards), Izvozi v PDF (Export
as PDF) in Digitalni podpisi (Digital Signatures).

• Uredi (Edit) vsebuje ukaze za urejanje dokumenta kot so Razveljavi (Undo), Spre-
membe (Changes), Primerjaj dokument (Compare Document) in Najdi in zamenjaj
(Find and Replace).

• Pogled (View) vsebuje ukaze za spreminjanje pogledov kot so Orodne vrstice
(Toolbars), Celozaslonski način (Full Screen) in Povečava (Zoom).

• Vstavi (Insert) vsebuje ukaze za vstavljanje elementov v preglednico (celice, vrstice,
stolpci, delovni listi in slike).
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• Oblika (Format) vsebuje ukaze za spreminjanje izgleda preglednice. Sem spadajo
na primer Slogi in oblikovanje (Styles and Formating), Odstavek (Paragraph) in
Združi (Merge Cells).

• Orodja (Tools) vsebujejo funkcije kot so Črkovanje (Spelling), Galerija (Gallery)
in Makri (Macros).

• Podatki (Data) vsebujejo ukaze za manipuliranje s podatki v preglednici. Sem spadajo
na primer Določi obseg (Define Range), Razvrsti (Sort) in Filtriraj (Filter).

• Okno (Window) vsebuje ukaze za prikaz okna; na primer Novo okno (New Window) in
Zapri okno (Close Window).

• Pomoč (Help) vsebuje povezave na LibreOffice Help file – datoteko za pomoč, Kaj je to?
(What’s This?) ter informacije o programu.

Orodne vrstice (Toolbars)

Calc ima v osnovi vidne štiri orodne vrstice – Standard, Najdi, Oblikovanje in Formula.

Standard vrstica je enotna za vse Libreoffice aplikacije in je stalna, pojasnili pa smo jo že v
komponenti Writer (glej stran 21). Ostale orodne vrstice so pojasnjene spodaj. Funkcije gumbov
nam pojasnjujejo opisna okna, če kazalec postavimo na določen gumb.

Dodajanje in odstranjevanje orodnih vrstic in gumbov. Za dodajanje in
odstranjevanje gumbov za orodja izberemo Pogled→Orodne vrstice (View→Toolbars), nato
kliknemo na orodno vrstico s seznama. Aktivne orodne vrstice so obkljukane.

Prav tako lahko dodajamo ali odstranjujemo gumbe, če kazalec postavimo na orodno vrstico
in z desnim klikom prikličemo meni, v katerem izberemo Vidni gumbi (Visible buttons),
nato pa se odločimo, katere gumbe potrebujemo za svoje delo.

Podmeniji in posamične orodne vrstice. Orodne vrstice z malim trikotnikom na desni
strani bodo prikazale podmenije, posamične orodne vrstice in druge načine izbiranja orodij.
Privzeto so vse orodne vrstice zasidrane na vrhu delovnega prostora, lahko pa jih poljubno
premikamo in usidramo na katerokoli stranico Calc-ovega okna ali jih celo pustimo plavajoče.

Orodna vrstica Oblikovanje. Na levi strani te vrstice (slika 3.2), ki se nahaja pod vrstico
Standard, med drugim najdemo vnosni polji Ime pisave (Font name) in Velikost pisave
(Font size). Prav tako so v tej vrstici gumbi, ki so zelo podobno nameščeni kot pri Writer-ju.
Če v privzetih nastavitvah ne najdemo vseh gumbov, jih poiščemo na način, ki smo ga opisali
zgoraj.



78 Preglednica

Slika 3.2: Orodna vrstica Oblikovanje

Slika 3.3: Vrstica za formule

Orodna vrstica Vrstica za formule. Ta orodna vrstica (slika 3.3) se nahaja pod vrstico
Oblikovanje. Na levi strani te vrstice je vnosno polje Polje z imenom (Name box), ki vsebuje
črko in številko (npr. A1). To je sklic celice, sestavljen iz črke stolpca in številke vrstice izbrane
celice.

Na desni strani Polja z imenom se nahajajo gumbi Čarovnik za funkcije (Function
Wizard), Vsota (Sum) in Funkcija (Function). Sledi še Vnosna vrstica.

Če kliknemo na gumb Čarovnik za funkcije, se nam odpre okno s seznamom dostopnih
funkcij, na podlagi katerega lahko tudi vidimo, kako so funkcije oblikovane – v preglednicah
funkcije ne pomenijo zgolj matematičnih funkcij.

Če kliknemo
∑

(Samodejna vsota) v določeni celici, nam bo to dejanje seštelo vrednosti
vseh celic, ki so nad našo. Če številk oziroma vrednosti nad izbrano celico ni, bodo seštete
vrednosti levo od naše celice.

Če kliknemo gumb Funkcija, vstavimo enačaj (=) v izbrano celico in vnosno vrstico. Na ta
način omogočimo, da celica sprejme formulo.

Ko vpišemo v celico nov podatek, se gumba Vsota in Funkcija spremenita v gumba Prekliči
(Cancel) in Sprejmi (Accept).

Vsebino izbrane celice (podatek, formulo ali funkcijo) vidimo v vnosni vrstici, kjer jo lahko
tudi urejamo. Prav tako lahko vsebino urejamo v celici sami, če dvokliknemo nanjo.

Kontekstni meni

Z desnim klikom na predmet (celico, sliko, grafikon itd.) odpremo kontekstni meni. To je
pogosto najhitrejši in najenostavnejši način za izvrševanje funkcij. V meniju so namreč zbrane
najpogosteje uporabljane funkcije in lastnosti izbranega predmeta.

Posamezne celice

Največji del zaslona predstavljajo celice v obliki mreže. So presečišča vrstic in stolpcev.
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Slika 3.4: Statusna vrstica

Na vrhu stolpcev in na levi strani vrstic so sive celice s črkami in številkami, ki predstavljajo
oznake stolpcev in vrstic. Stolpci se začnejo s črko A in se nadaljujejo proti desni, vrstice pa se
začnejo s številko 1 in se nadaljujejo navzdol. Obe oznaki skupaj tvorita sklic celice.

Zavihki delovnih listov

Na dnu mreže s celicami se nahajajo zavihki delovnih listov, ki omogočajo dostop do posameznega
delovnega lista. Vidni – trenutni delovni list ima bel zavihek, ostali pa sive. Če kliknemo na
drug zavihek, se ta obarva belo in prikaže se nam drug delovni list.

Statusna vrstica (Status bar)

Ta se nahaja na dnu delovnega prostora (slika 3.4) in prikazuje informacije o trenutnem statusu
dokumenta:

• Delovni list št. (Sheet sequence number) – prikazuje trenutni delovni list in
njihovo skupno število,

• Slog strani (Page style) – npr. Privzeto,

• Vstavi način (Insert mode) – brez ali Prepiši (uporabimo, ko želimo, da besedilo za
kazalcem nadomestimo s tistim, kar pravkar pišemo),

• gumb Izbira (Selection) – Standardno izbiranje (Standard selection), Iz-
biranje s širjenjem (Extended), Izbiranje z dodajanjem (Add) ali Izbiranje v
blokih (Block Area),

• status sprememb (shranjene ali ne shranjene spremembe),

• Digitalni podpis (Digital signature),

• informacije o poziciji celice ali predmeta in

• Povečava.

3.1.4 Shranjevanje preglednice

Preglednice lahko shranimo na isti način kot v Writer-ju:

• pritisnemo Ctrl+S,

• izberemo Datoteka→Shrani (ali Shrani kopijo ali Shrani vse),

• kliknemo gumb Shrani na orodni vrstici Standard.
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Če preglednica še ni bila shranjena, potem bo vsaka izmed teh možnosti odprla pogovorno okno
Shrani kot. Tam nato preglednico poimenujemo in določimo mesto kamor jo bomo shranili.

3.1.5 Izbiranje predmetov v delovnem listu ali preglednici

Izbiranje celic

Celice lahko izbiramo na več načinov.

Posamezna celica. Posamezno celico izberemo z levim klikom miške, če smo izbrali pravo,
pa lahko preverimo v Polju z imenom.

Več povezanih celic. Več povezanih celic lahko izberemo z miško ali s tipkovnico.
Izbiranje z miško:

1. Kliknemo v celico.

2. Pritisnemo in držimo levi gumb miške.

3. Z miško vlečemo po ekranu, da zavzamemo želeni obseg celic.

4. Ko je želeni obseg povezanih celic osvetljen, miško spustimo.

Izbiranje s tipkovnico:

1. Izberemo celico, ki bo eden od kotov želenega obsega.

2. Držimo tipko Shift, med tem pa se s puščicami premikamo skozi celice, ki jih želimo
zajeti.

Več nepovezanih celic.

1. Izberemo celico ali več celic kot je opisano zgoraj.

2. Premaknemo kazalec miške na začetek naslednje skupine celic, ki jih želimo izbrati.

3. Držimo tipko Ctrl in kliknemo na celico oziroma potegnemo z miško skozi tiste celice, ki
jih želimo zajeti.

4. Ponovimo lahko tudi na drugih mestih.

Izbiranje stolpcev in vrstic

Posamezni stolpec ali vrstica. Če želimo izbrati posamezni stolpec, kliknemo na oznako
(črko) stolpca – npr. A. Če želimo izbrati posamezno vrstico, kliknemo na oznako (številko)
vrstice – npr. 1.
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Slika 3.5: Izbira celotnega delovnega lista

Več stolpcev ali vrstic. Za izbiranje več povezanih stolpcev ali vrstic:

1. Kliknemo na prvi stolpec ali vrstico v skupini.

2. Držimo tipko Shift.

3. Kliknemo zadnji stolpec ali vrstico v skupini.

Za izbiranje več nepovezanih stolpcev in vrstic:

1. Kliknemo na prvi stolpec ali vrstico v skupini.

2. Držimo tipko Ctrl.

3. Kliknemo na vse naslednje skupine stolpcev in vrstic, ki jih želimo izbrati, medtem ko
držimo Ctrl tipko.

Celotni delovni list. Če želimo izbrati celotni delovni list (slika 3.5), kliknemo na malo
okence med A oznako stolpca in 1 oznako vrstice ali pa pritisnemo Ctrl+A.

Izbiranje delovnih listov

Izberemo lahko enega ali več delovnih listov. Prednost izbiranja več listov naenkrat je v tem, da
lahko delamo spremembe dokumenta na vseh delovnih listih naenkrat.

Posamezni delovni list. Kliknemo na zavihek delovnega lista, ki ga želimo izbrati. Zavihek
se obarva belo.

Več zaporednih listov. Za izbiranje več zaporednih listov:

1. Kliknemo na zavihek prvega želenega delovnega lista.

2. Premaknemo kazalec miške do zavihka zadnjega želenega delovnega lista.

3. Držimo tipko Shift in kliknemo na izbrani zavihek.
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Več nezaporednih listov. Za izbiranje več nezaporednih delovnih listov:

1. Kliknemo na zavihek prvega želenega delovnega lista.

2. Premaknemo kazalec miške do zavihka naslednjega želenega delovnega lista.

3. Držimo tipko Ctrl in kliknemo na izbrani zavihek.

4. Ponovimo še na drugih zavihkih, če želimo.

Vsi delovni listi. Če želimo izbrati vse delovne liste, desno-kliknemo na katerikoli zavihek
in v kontekstnem meniju izberemo Izberi vse delovne liste (Select All Sheets).

3.1.6 Delo s stolpci in vrsticami (Columns, Rows)

Vstavljanje stolpcev in vrstic

Stolpce in vrstice lahko dodajamo posamezno ali v skupinah.

Posamezni stolpec ali vrstica. Uporaba menija Vstavi (Insert):

1. Izberemo celico, stolpec ali vrstico, kjer želimo dodati nov stolpec ali vrstico.

2. Izberemo ali Vstavi→Stolpec (Insert→Columns) ali Vstavi→Vrstica (Insert
→Rows).

Uporaba miške:

1. Izberemo celico, stolpec ali vrstico, kjer želimo dodati nov stolpec ali vrstico.

2. Desno-kliknemo oznako stolpca ali vrstice.

3. Izberemo ali Vstavi Stolpce (Insert Columns) ali Vstavi Vrstice (Insert Rows).

Skupina stolpcev ali vrstic.

1. Izberemo želeno število stolpcev ali vrstic tako, da držimo levi gumb miške, medtem ko
vlečemo skozi celice, ki jih želimo zajeti.

2. Nadaljujemo kot pri vstavljanju enega stolpca ali vrstice.

Brisanje stolpcev in vrstic

Stolpce in vrstice lahko brišemo posamezno ali v skupinah.
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Posamezni stolpec ali vrstica. Posamezni stolpec ali vrstico izbrišemo:

1. Izberemo stolpec ali vrstico, ki jo želimo izbrisati.

2. Izberemo Uredi→Izbriši celice (Edit→Delete Cells).

Ali takole:

1. Desno-kliknemo na oznako stolpca ali vrstice.

2. V kontekstnem meniju izberemo Izbriši stolpce (Delete Columns) ali Izbriši
vrstice (Delete Rows).

Skupina stolpcev ali vrstic.

1. Izberemo želeno skupino stolpcev ali vrstic tako, da držimo levi gumb miške, medtem ko
vlečemo skozi celice, ki jih želimo zajeti.

2. Nadaljujemo kot pri brisanju enega stolpca ali vrstice.

3.1.7 Delo z delovnimi listi

Kot vse ostale elemente Calc-a, lahko vstavljamo, kopiramo, premikamo, brišemo in
preimenujemo tudi delovne liste.

Vstavljanje novih delovnih listov

Obstaja več načinov vstavljanja novih listov, najhitreje pa to naredimo, če kliknemo na gumb
Vstavi delovni list.

Če želimo vstaviti več listov hkrati, ali jih želimo preimenovati ali pa bi želeli delovni list
vstaviti med že obstoječe, uporabimo drug način. Prvi korak za vsa našteta dejanja je izbira
lista, h kateremu bomo dodali nov list. Nato uporabimo eno izmed naslednjih možnosti:

• V menijski vrstici izberemo Vstavi→Delovni list (Insert→Sheet).

• Desno-kliknemo na zavihek lista in izberemo Vstavi delovni list.

• Kliknemo na prazno mesto na koncu zavihkov (za znakom +).

Vse naštete metode vodijo do tega, da se nam odpre pogovorno okno (slika 3.6), kjer lahko
izberemo, kje želimo imeti nov delovni list in koliko jih želimo. Če izberemo samo enega, ga
lahko tudi poimenujemo.

Prestavljanje in kopiranje delovnih listov

Znotraj preglednice lahko delovne liste premikamo ali kopiramo z uporabo miške ali pogovornih
oken. Uporaba miške pride v poštev le znotraj iste preglednice, sicer pa uporabimo pogovorna
okna.
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Slika 3.6: Pogovorno okno Vstavi delovni list

Uporaba miške. Za premik delovnega lista na drugo mesto kliknemo na zavihek delovnega
lista in ga potegnemo. Odložimo ga lahko med dva druga lista, kar nam pokažeta dva mala
trikotnika. Za kopiranje delovnega lista znotraj iste preglednice držimo tipko Ctrl, medtem pa
kliknemo na zavihek delovnega lista in ga povlečemo.

Uporaba pogovornih oken. Za premikanje in kopiranje lahko uporabimo tudi pogovorna
okna (slika 3.7):

1. V trenutnem dokumentu desno-kliknemo na zavihek delovnega lista, ki ga želimo
premakniti ali kopirati.

2. V kontekstnem meniju izberemo Premakni/Kopiraj delovni list (Move/Copy Sheet).

3. V pogovornem oknu:

(a) Izberemo dejanje: Premakni ali Kopiraj (Move ali Copy).

(b) V dokument (To document): Izberemo dokument, kamor želimo vnesti delovni list.
Če imamo odprto še eno preglednico, se bo njeno ime pojavilo na seznamu (poleg
imena trenutne preglednice).

(c) Vstavi pred (Insert before): izberemo pozicijo znotraj dokumenta.

(d) Novo ime (New name): delovni list lahko preimenujemo, sicer ime ostane enako.

(e) Ko končamo, kliknemo V redu (OK).
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Slika 3.7: Pogovorno okno Premakni/kopiraj delovni list

Brisanje delovnih listov

Delovne liste lahko izbrišemo posamezno ali v skupini.

Posamezni delovni list. Desno-kliknemo na zavihek delovnega lista, ki ga želimo izbrisati,
nato v kontekstnem meniju izberemo Izbriši delovni list (Delete Sheet), lahko pa
v menijski vrstici izberemo Uredi→Delovni list→Izbriši (Edit→Sheet→ Delete). V
vsakem primeru se bo pojavilo opozorilno okno z vprašanjem, ali smo prepričani, da želimo
izbrisati izbrane delovne liste. Kliknemo Da (Yes).

Skupina delovnih listov. Za brisanje skupine delovnih listov jih najprej po prejšnjih
navodilih izberemo, nato pa lahko ali desno-kliknemo na enega od zavihkov in v kontekstnem
meniju izberemo Izbriši delovni list (Delete Sheet) ali v menijski vrstici izberemo
Uredi→Delovni list→Izbriši (Edit→Sheet→Delete).

Preimenovanje delovnih listov

Privzeto ime novega delovnega lista je Delovni listX (SheetX), kjer X predstavlja številko. Ta
način je priročen za majhne razpredelnice z le nekaj delovnimi listi.

Za preimenovanje delovnih listov lahko:

• vpišemo ime v Polje z imenom, ko delovni list ustvarimo,
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Slika 3.8: Povečava in postavitev pogleda

• desno-kliknemo na zavihek delovnega lista in v kontekstnem meniju izberemo Preimenuj
delovni list (Rename Sheet) ter zamenjamo ime,

• dvokliknemo na zavihek delovnega lista, da se odpre pogovorno okno Preimenuj delovni
list.

3.1.8 Nastavitve pogleda

Uporaba povečave

Če želimo videti več oziroma manj celic v oknu, to uravnavamo s funkcijo Povečava (Zoom).
Povečavo lahko uporabimo v statusni vrstici ali pa odpremo pogovorno okno za povečavo

(slika 3.8). To storimo tako, da menijski vrstici izberemo Pogled→Povečava (View→Zoom).
Faktorje povečave uredimo po svoje.

Zamrznitev vrstic in stolpcev

Zamrznitev zaklene določeno število vrstic na vrhu preglednice oziroma stolpcev na levi strani.
Ob listanju zaslona tako ostanejo vidne, kar pride prav pri velikih tabelah, npr. če želimo ohraniti
glave stolpcev.

Na sliki 3.9 odebeljena vodoravna črta med vrsticama 1 in 26 ter odebeljena črta med
stolpcema C in G označuje zamrznjene dele. Vrstice od 2 do 25 ter stolpci od D do F niso
vidni, ker se je uporabnik premaknil navzdol in desno. Črto zamrznitve lahko nastavimo le za
vrstice, le za stolpce ali za oboje skupaj.

Zamrznitev vrstice ali stolpca posebej poteka takole:

1. Kliknemo na glavo zadnje vrstice ali stolpca, ki ga želimo ohraniti vidnega.

2. Izberemo Okno→Zamrzni (Window→Freeze). Pojavi se temna črta, ki ponazarja zamrz-
nitev.

Če želimo zamrzniti vrstice in stolpce, postopamo takole:
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Slika 3.9: Zamrznjene vrstice in stolpci

1. Kliknemo na celico, ki je takoj pod vrstico in takoj desno od stolpca, ki ga želimo zamrzniti.

2. Izberemo Okno→Zamrzni. Pojavita se temni črti, ki ponazarjata zamrznitev.

Za obnovitev prvotnega stanja preglednice – odmrznitev, ponovno izberemo Okno→
Zamrzni. Kljukica pri Zamrzni bo izginila.

Razdelitev zaslona

Obstaja še en način za spremembo pogleda. Okno lahko razdelimo vodoravno, navpično ali na
oba načina. Tako imamo lahko na zaslonu vidne štiri dele preglednice naenkrat.

Za primer vzemimo veliko tabelo s celico, ki jo uporabljamo v formulah na treh različnih
delih tabele. Z razdelitvijo zaslona si lahko prilagodimo videz tako, da spremljamo spremembe
v vseh odvisnih celicah.

Vodoravna razdelitev zaslona.

1. Miško premaknemo nad navpični drsni trak (scrollbar) na desni strani zaslona, na zgornji
gumb s puščico (glej sliko 3.11).

2. Nad tem gumbom se nahaja črna črtica. Če miško ustavimo nad tem delom, se miškin
kazalnik spremeni v dvojno navpično puščico.

3. Če držimo levi miškin gumb, se črta pojavi čez cel delovni list. Odvlečemo jo na želeno
mesto. Zaslon se razdeli na dva dela, vsak s svojim drsnim trakom.

Navpična razdelitev zaslona. Navpično razdelitev izvedemo podobno, le da tu uporabimo
vodoravni drsni trak.

Zaslon lahko razdelimo tudi preko menijske vrstice. Vnaprej izberemo vrstico, stolpec ali
celico, kjer želimo razdelitev in kliknemo na Okno→Razdeli (Window→Split).
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Slika 3.10: Primer razdelitve zaslona

Slika 3.11: Razdelitvena črta na navpičnem drsnem traku
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Združitev razdeljenega zaslona. Razdelitev lahko odstranimo na tri načine:

• dvokliknemo na razmejitveno črto;

• črto primemo in odvlečemo na rob drsnega traka;

• odstranimo kljukico pri menijski izbiri, tako da jo izberemo.

3.2 Vnašanje, urejanje in oblikovanje podatkov

3.2.1 Vnašanje podatkov s pomočjo tipkovnice

Večino podatkov lahko vnesemo s pomočjo tipkovnice.

Vnašanje številk

Kliknemo v celico in vtipkamo številko. Če želimo vtipkati negativno številko, lahko uporabimo
znak minus (-) pred številko ali številko vtipkamo v oklepaj. Številke so po privzetih nastavitvah
desno poravnane.

Vnašanje besedila

Kliknemo v celico in vpišemo besedilo. Besedilo je po privzetih nastavitvah levo poravnano.

Vnašanje ure in datuma

Izberemo celico in vtipkamo datum in uro. Datum lahko zapišemo s poševnico ali s pomišljajem,
lahko pa mesec zapišemo tudi z okrajšanim besedilom (npr. Oct za oktober) in Calc bo prepoznal
različico zapisanega datuma. Uro zapišemo s pomočjo dvopičja (npr. 10:45).

Vnašanje posebnih znakov

Posebne znake vnašamo enako kot pri Writer-ju (glej stran 41).

3.2.2 Hitro vnašanje podatkov

Hitro vnašanje podatkov pride prav predvsem takrat, ko imamo opravka s ponavljajočo se
vsebino. Zato ima Calc na voljo nekaj funkcij: orodje Zapolni, Seznam izborov ter zmožnost
vstavljanja informacij v več zavihkov istega dokumenta.

Uporaba orodja Zapolni

Orodje Zapolni je način za podvajanje vsebine celic. Izberemo celico, ki jo želimo kopirati
in kliknemo Kopiraj (desni klik), potegnemo z miško v katerokoli smer, nato pa izberemo
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Slika 3.12: Uporaba orodja Zapolni

Slika 3.13: Določanje začetka niza zapolnjevanja

Uredi→Zapolni (Edit→Fill) ter smer, v katero bi radi kopirali: Navzdol, Desno, Navzgor
ali Levo.

Za kopiranje celic ponavadi uporabljamo bližnjico. Izbrana celica ima na spodnji desni strani
ročico – odebeljeno točko, ki jo z metodo Povleci in spusti (Drag&Drop) povlečemo v želeno smer.
Če celica vsebuje številko, bomo nadaljevali s številčenjem, če celica vsebuje besedilo, ga bomo
kopirali v vsako celico (slika 3.12).

Uporaba Niza zapolnjevanja

Če želimo v razpredelnico vnesti cel niz podatkov, ki niso isti, a želimo, da se ta niz nekje
spet pojavi, lahko uporabimo to funkcijo. To naredimo tako, da izberemo celice, ki jih želimo
zapolniti, nato izberemo Uredi→Zapolni→Niz (Edit→Fill→Series). V pogovornem oknu
izberemo smer in vrsto niza, kjer izberemo Samozapolnitev (Autofill), za Začetno vrednost
(Start value) pa izberemo predmet, s katerim naj se niz začne (slika 3.13).



3.2 Vnašanje, urejanje in oblikovanje podatkov 91

Izbirni seznam

Ta je namenjen le za besedilo, ki je že bilo vneseno v istem stolpcu. Z desnim klikom v
kontekstnem meniju izberemo Seznam izborov, kjer se pokaže abecedni seznam vseh besed, ki so
bile v tem stolpcu že vnesene. Izberemo tisto, ki jo potrebujemo.

3.2.3 Deljenje vsebine med delovnimi listi

Če želimo isto vsebino vnesti v iste celice na več delovnih listov, izberemo Uredi→Delovni
list→Izberi (Edit→Sheet→Select). S tem izberemo vse delovne liste, šele nato vnesemo
informacije na trenutni delovni list.

3.2.4 Veljavnost vsebine celic

Z nadgrajevanjem znanja smo sposobni opravljati tudi nove naloge pri delu s preglednicami.
Kmalu se znajdemo v vlogi izdelovalca preglednic za druge ljudi, ne le za svoje potrebe. Tu
nastopi potreba po veljavnosti vnosov oziroma preverjanju, ali so bili vneseni podatki primerni
za celico. Seveda lahko uporabimo veljavnost tudi zase kot vodiča za posebej kompleksne vnose.

Z orodjem Zapolni in izbirnimi seznami lahko obvladamo določene vrste podatkov, a
smo omejeni z vnaprej podanimi informacijami. Za veljavnost vnesenih podatkov v izbrano
celico izberemo Podatki→Veljavnost (Data→Validity) in izberemo, kakšne vrste podatkov
uporabnik lahko vnese. Recimo, celica zahteva vnos datuma ali celo število, ne sme biti prazna
ipd. (slika 3.14).

Možnosti za nastavitev vključujejo še definicijo intervala dovoljenih vrednosti in sporočila
za pomoč ob vnosu nedovoljenih vnosov. Nastavimo lahko, da celica vnose zavrne ali sprejme z
opozorilom.

Če so neveljavni vnosi vseeno dovoljeni, jih najdemo z orodjem Detektiv (Orodja→
Detektiv→Označi neveljavne podatke (Tools→Detective→Mark Invalid Data)). Ta
označi vse neveljavne vrednosti z rdečim krogom okoli celice.

Pravila veljavnosti spadajo pod oblikovanje celice. Če izberemo Oblikuj→Počisti
neposredno oblikovanje (Format→Clear Direct Formatting), se zbriše. Če pravilo želi-
mo prenesti, ga prenesemo z obliko (Uredi→Posebno lepljenje→Oblike (Edit→Paste
Special→Formats)). Seveda se prenese tudi z navadnim lepljenjem (Uredi→Prilepi
(Edit→Paste)).

Primer uporabe veljavnosti si bomo ogledali na konkretnem primeru na strani 133.

3.2.5 Urejanje podatkov

Urejanje podatkov poteka po enakem principu kot vnašanje. Najprej je potrebno izbrati celico s
podatki, ki jih želimo urediti.
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Slika 3.14: Običajne izbire pri testu veljavnosti

Brisanje vsebine celic

Brišemo lahko vrednosti, obliko ali oboje hkrati.

Če želimo zbrisati le vrednost celice, pritisnemo tipko Delete. Na ta način oblika celice
ostane – nov vnos bo enake oblike.

Do več možnosti pridemo s tipko Backspace (ali desni klik→Izbriši vsebino ali
Uredi→Izbriši vsebino (Edit→Delete Contents)), ki odpre pogovorno okno (slika 3.15).
Tu izbiramo, katere lastnosti celice bomo brisali. Za izbris vsebine in oblike izberemo Izbriši
vse.

Zamenjava celotne vsebine celic

Za zamenjavo vsebine preprosto prepišemo staro vsebino. Novi podatki bodo ohranili prejšnje
oblikovanje.

Delna zamenjava vsebine celic

Včasih je potrebno vsebino popraviti. Da je ne bi ponovno pisali od začetka, jo lahko popravljamo
na dva načina:

• S tipkovnico – po izbiri celice stisnemo tipko F2 in tako postavimo kazalec na konec
vrednosti. Nato uporabimo smerne tipke za navigacijo te vrednosti.

• Z miško – z dvoklikom na ustrezno mesto v celici.
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Slika 3.15: Pogovorno okno Izbriši vsebino

Oblikovanje podatkov

Podatke lahko oblikujemo na več načinov. Kot v Writer-ju, tudi tu obstajajo slogi, le da so tu
osnovne enote celice in ne besedilo. Tako lahko obliko določimo kot del sloga celice, da se pri
vnosu avtomatsko aplicira, lahko pa jo nastavimo ročno. Bolj uporabljane možnosti so dosegljive
kar preko orodnih vrstic, za več možnosti pa označimo želen obseg celic in v kontekstnem meniju
izberemo Oblikuj celice (ali Oblika→Celice (Format→Cells), z bližnjico Ctrl+1).

Oblikovanje večvrstičnega besedila

V eno celico lahko stisnemo več vrstic besedila. Na voljo imamo dve metodi, samodejni prelom
besedila ali uporaba ročnega preloma vrstice.

Samodejni prelom besedila. V kontekstnem meniju izberemo Oblikuj Celice (slika
3.16). V razdelku Poravnava→Lastnosti (Alignment→Properties) izberemo Samodejno
prelomi besedilo (Wrap text automatically). Rezultat je prikazan na sliki 3.17.

Ročni prelom vrstice. Ročni prelom vrstice vstavimo s kombinacijo tipk Ctrl+Enter.
Prelom širine celice ne spremeni. Na sliki 3.18 so štirje prelomi.

Krčenje besedila v celici

Ena izmed nastavitev oblike celic je tudi Skrči na velikost celice (Shrink to fit cell
size) (slika 3.16). Velikost pisave se tako samodejno prilagodi širini celice. Rezultat je prikazan
na sliki 3.19.
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Slika 3.16: Razdelek Poravnava okna Oblikuj celice

Slika 3.17: Samodejni prelom besedila

Slika 3.18: Celica z ročnimi prelomi vrstic

Slika 3.19: Krčenje besedila v celicah



3.2 Vnašanje, urejanje in oblikovanje podatkov 95

Slika 3.20: Gumbi za številsko obliko (valuta, odstotek, datum, znanstvena oblika,
standardna, dodaj/odvzemi decimalno mesto)

Oblikovanje številk

Številkam lahko določimo več različnih oblik. V orodni vrstici Oblikovanje so v enem izmed
razdelkov zbrani gumbi za številčne oblike (slika 3.20).

Privzeto jih je sicer nekaj skritih, a za več kontrole nad obliko raje izberemo želeno obliko iz
razdelka Številke v pogovornem oknu Oblikuj celice.

Oblikovanje pisave

Za hitro izbiro pisave imamo na voljo v orodni vrstici Oblikovanje (Formatting), kombiniran
kontrolnik/vnosno polje, ki prikazuje trenutno pisavo. Ali vpišemo ime želene pisave ali pa s
puščico na desni strani kontrolnika prikličemo vse nameščene pisave.

Naslednji kontrolnik nastavlja velikost pisave, sledijo gumbi za krepko, ležečo in podčrtano
pisavo.

Vse te možnosti so dosegljive v razdelku Pisava v pogovornem oknu Oblikuj celice. Tu
lahko dodatno nastavimo jezik celice. S tem omogočimo, da bo črkovalnik kljub večim jezikom
pravilno deloval.

V naslednjem razdelku Učinki pisave izbiramo med dodatnimi možnostmi (slika 3.21).
Barva pisave je ena izmed teh. Izbiramo lahko med prednastavljenimi barvami. Če
želimo barvo ustvariti sami, to naredimo preko Orodja→Možnosti→LibreOffice→ Barve
(Tools→Options→LibreOffice→Colors). Tu nastavimo parametre barve (po RGB ali
CMYK barvnem modelu) in jo poimenujemo, da bo dosegljiva v vseh ostalih kontrolnikih.

Možnosti se nadaljujejo z različnimi načini nad-, pod- in prečrtovanja besedila, kjer lahko
izberemo tip (pikčasto, črtkano, valovito, . . . ) in barvo črte.

Zadnja izbira je relief besedila, kjer izbiramo med izbočenim, vrezanim besedilom, dodamo
lahko še senčenje in oris.

Nastavitve poravnave in orientacije celic

Kot pri številskih oblikah, vse poravnave in orientacije privzeto niso dosegljive na orodni vrstici.
Za prikaz vseh kliknemo na katerikoli gumb orodne vrstice (slika 3.22).

Razdelek Poravnava v pogovornem oknu Oblikuj celice ponuja več možnosti. Besedilo
lahko rotiramo, navpično poravnamo ali navpično naložimo.



96 Preglednica

Slika 3.21: Učinki pisave

Slika 3.22: Poravnava in orientacija celic
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Slika 3.23: Razdelek Obrobe

Oblikovanje obrob celic

Za hiter dostop do obrob je na voljo gumb Obrobe (Borders) v orodni vrstici Oblikovanje. Tu
lahko izberemo le eno izmed vseh podmnožic robov celic oziroma obsega celic. Izbor bo očrtan
s tanko črno črto. Obrobno črto oblikujemo z gumboma Slog črte (Line Style) in Barva
črte (Line Color). Če gumba nista prikazana, ju omogočimo preko menija Vidni gumbi.

Večji nadzor nad možnostmi imamo v razdelku Obrobe v pogovornem oknu Oblikuj celice,
kjer lahko nastavimo še širino črte, dodamo senco in spremenimo razmik do vsebine v celicah
(slika 3.23).

Pri delu z obrobami je potrebno biti pozoren na to, da obrobo nastavimo samo izbranim
celicam. Spreminjati jih je možno izključno pri urejanju le-teh. Recimo, da celici C3 dodamo
zgornji rob. Ta rob lahko odstranimo le z izbiro C3, ne pa tudi C2, čeprav je to navidez spodnji
rob celice C2.

Če se zadovoljimo z gumbom Obrobe iz orodne vrstice, imamo na voljo dva načina dela.
Ob kliku na gumb z želeno obrobo celice obrobimo. Če pri tem držimo tipko Shift, celicam to
obrobo odstranimo.

Oblikovanje ozadja celic

Za hiter dostop do ozadja celic je na voljo gumb Barva Ozadja (Background Color) v orodni
vrstici Oblikovanje. Prikaže se barvna paleta, podobna paleti pri izbiri barve pisave. Barvna
paleta je dosegljiva tudi preko razdelka Ozadje v pogovornem oknu Oblikuj celice.
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Slika 3.24: Pogovorno okno Samooblikovanje

3.2.6 Samooblikovanje celic in delovnih listov

Za oblikovanje tabel Calc predlaga nekaj všečnih oblikovanj. Samooblikovanje skupine celic (slika
3.24) uporabimo na naslednji način:

1. Izberemo obseg vsaj 3x3 celic, vključno z glavo stolpcev in vrstic.

2. V glavnem meniju izberemo Oblika→Samooblikovanje (Format→AutoFormat).

3. V pogovornem oknu Samooblikovanje izberemo želeno obliko s seznama.

4. Izberemo, katere izmed oblikovanj naj samooblikovanje upošteva.

5. Kliknemo na gumb V redu, da zapremo dialog.

Obstaja tudi možnost, da si nastavimo svoje samooblikovanje, kar pride prav, če želimo
ohraniti obliko tabel skozi več preglednic.

3.2.7 Slog celice

Slogi so množica oblikovanj, ki jih lahko uporabimo na elementih dokumenta, da hitro
spremenimo njihov videz. Veliko uporabnikov namreč oblikuje celice brez uporabe slogov in
atribute celic nastavlja ročno. Celicam posamično določa fizične atribute, kot so vrsta, velikost,
oblika pisave, poravnavo ipd. Glede na Writer lahko tu določamo še črtno obrobo celice, ozadje
in ščitenje celice pred spremembami.

Slogi so logični atributi. Z uporabo slogov celicam prenehamo nastavljati fizične atribute
(npr. Times New Roman, 14pt, krepko, leva poravnava), določimo jim slog, na primer Naslov1.
Določanje slogov je zamudno le na začetku, potem je delo z njimi lažje od ročnega določanja
atributov. Je hitrejše, veča konsistentnost in kar je najpomembnejše, zmanjšuje možnost za
napake. Uporaba slogov olajša tudi večje spremembe oblikovanja. Recimo, da želimo zamenjati
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Slika 3.25: Osnovni slogi celic

izgled vseh vmesnih seštevkov v preglednici, veliki 15 delovnih listov. Dovolj je posodobiti njihov
slog v želeno obliko.

Prednastavljenih je že nekaj osnovnih slogov. Vsi so izpeljani iz sloga Privzeto, ki je nadrejen
ostalim (glej sliko 3.25). Če spremenimo Privzeto, se bodo spremenili tudi slogi, ki so nižje v
hierarhiji.

Uporaba slogov

Za uporabo slogov imamo na voljo tri možnosti, ki so predstavljene v nadaljevanju.

Pogovorno okno Slogi in oblikovanje.

1. S klikom na Oblika→Slogi in oblikovanje (Format→Styles and Formatting) (bliž-
njica F11) odpremo pogovorno okno.

2. S klikom na gumb Slogi celic dobimo seznam vseh slogov.

3. Označimo obseg celic, katerim želimo določiti slog.

4. Dvokliknemo na ime sloga in celice bodo dobile izbrano obliko.

Pogovorno okno lahko zasidramo na stranice glavnega okna.
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Način kopiranja slogov. Ta način je uporaben, če želimo uporabiti enak slog na večih
razpršenih celicah.

1. Odpremo pogovorno okno s klikom na Oblika→Slogi in oblikovanje.

2. Izberemo slog.

3. Kliknemo na gumb Način kopiranja slogov . Kazalec se spremeni v obliko, podob-
no pritisnjenemu gumbu.

4. Kliknemo na vsako celico, ki jo želimo spremeniti.

5. Po uporabi ponovno kliknemo na gumb in zapremo pogovorno okno.

V tem načinu z desnim klikom kamorkoli v dokumentu razveljavimo zadnjo uporabo sloga.

Seznam Uporabi slog. Spustni seznam Uporabi slog privzeto ni viden v orodni vrstici
Oblikovanje. Postopek, da ga dodamo, je naslednji:

1. Kliknemo kamorkoli na orodni vrstici Oblikovanje, nato na Vidni gumbi iz kontekstnega
menija.

2. Kliknemo na Uporabi slog. Kontekstni meni se bo zaprl in seznam Uporabi slog se bo
pojavil na levi strani orodne vrstice.

Slog s seznama uporabimo takole:

1. Izberemo obseg celic.

2. S klikom na puščico ob polju Uporabi slog prikličemo spustni seznam.

3. Izberemo želeni slog in celice bodo dobile izbrano obliko.

4. Vsak slog v spustnem seznamu je prikazan s predogledom, a na seznamu ni vseh. S klikom
na Dodatno ... odpremo pogovorno okno Slogi in oblikovanje, kjer so na izbiro vsi
slogi.

Izdelava novega sloga

Slog izdelamo na dva možna načina, z uporabo pogovornega okna Slogi in oblikovanje ali
preko izbire.

Nov slog preko okna Slogi in oblikovanje.

1. Odpremo pogovorno okno s klikom na Oblika→Slogi in oblikovanje.

2. S klikom na gumb Slogi celic dobimo seznam vseh slogov.

3. V oknu desno-kliknemo in izberemo Nov ... iz kontekstnega menija.
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Slika 3.26: Pogovorno okno Slog celice, zavihek Organizator

4. V pogovornem oknu Slog celice (slika 3.26) izberemo množico atributov in poimenujemo
nov slog.

5. Kliknemo V redu, da slog shranimo.

Nov slog preko izbire.

1. Odpremo pogovorno okno s klikom na Oblika→Slogi in oblikovanje.

2. S klikom na gumb Slogi celic dobimo seznam vseh slogov.

3. Izberemo celico s slogom, ki bo osnova za nov slog.

4. Kliknemo gumb Nov slog iz izbora , da odpremo novo pogovorno okno Ustvari
slog (slika 3.27).

5. Vpišemo ime novega sloga v polje s seznamom. Seznam prikazuje vse že izpeljane sloge.

6. Kliknemo V redu, da shranimo slog. Naredili smo kopijo sloga, potrebno ga je še spreme-
niti.

7. Desno-kliknemo na slog in izberemo Spremeni ... iz kontekstnega menija.

8. V pogovornem oknu Slog celice izberemo množico atributov.

9. Kliknemo V redu, da shranimo spremembe.

Spreminjanje, brisanje, skrivanje slogov. V pogovornem oknu Slogi in oblikovan-
je upravljamo s posameznimi slogi. Z desnim klikom na slog prikličemo kontekstni meni, kjer
ga lahko spremenimo, zbrišemo ali skrijemo. Pri spremembi se pojavi pogovorno okno Slog
celice, kjer nastavimo atribute. Razlika med skrivanjem in izbrisom sloga je v tem, da skriti
slog lahko prikličemo nazaj, medtem ko izbrisanega ne moremo. Skrite sloge prikažemo tako, da
v spodnjem delu okna v spustnem seznamu izberemo Skriti slogi. Nato z desnim klikom v
kontekstnem meniju izberemo Pokaži.
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Slika 3.27: Pogovorno okno Ustvari slog

3.2.8 Pogojno oblikovanje

Oblika celic se lahko avtomatsko spreminja glede na pogoje, ki jih nastavimo. S takšnim obliko-
vanjem poudarimo vrednosti ali jim dodamo vizualno komponento.

Uporaba pogojnega oblikovanja

1. Preverimo, ali je funkcija Samodejno izračunaj (Orodja→Vsebina celice→Samodej-
no izračunaj (Tools→Cell Contents→AutoCalculate)) omogočena. Privzeto je.

2. Izberemo celice, ki bodo pogojno oblikovane.

3. Pod Oblika→Pogojno oblikovanje→Pogoj (Format→Conditional Formatting→
Condition) (slika 3.28) ali Barvna lestvica (Color Scale) (slika 3.29) ali Podatkovna
vrstica (slika 3.30) ali Nabor ikon (slika 3.31) najdemo pogovorno okno Pogojno
oblikovanje. Če celica že ima pogojno obliko, jo prikaže.

4. Kliknemo gumb Dodaj in definiramo dodaten pogoj.

5. Izberemo slog izmed že definiranih slogov iz spustnega seznama.

6. Alternativno, izberemo prvo možnost seznama Nov slog ... za pogovorno okno Slog
celice, kjer lahko ustvarimo nov slog.

7. Kliknemo V redu, da shranimo pogoje in zapremo pogovorno okno.

Na sliki 3.32 so prikazani rezultati pogojnega oblikovanja s prejšnjih slik.

Vrste pogojnega oblikovanja

Pogoj je osnovna oblika pogojnega oblikovanja. Ponavadi ga uporabimo, če želimo poudariti
podatek, ki izstopa ali ni v skladu s pričakovanji. Recimo rdeče številke v računovodstvu, kritično
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Slika 3.28: Pogojno oblikovanje – Pogoj

Slika 3.29: Pogojno oblikovanje – Barvna lestvica

Slika 3.30: Pogojno oblikovanje – Podatkovna vrstica

Slika 3.31: Pogojno oblikovanje – Nabor ikon
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Slika 3.32: Primeri pogojnega oblikovanja

stanje zalog itd. Pogojno oblikovanje se zanaša na sloge. Deluje tako, da če pogoj velja, Calc
nad celico uporabi izbrani slog.

Z barvno lestvico določimo ozadje celice glede na njeno vrednost. Ta možnost je na voljo
le, če izberemo za pogoj Vse celice. V barvni lestvici imamo lahko dve ali tri barve.

S podatkovno vrstico podatkom dodamo grafični prikaz, ki temelji na vrednosti v izbranem
obsegu. Ta možnost je na voljo le, če izberemo za pogoj Vse celice. Za obseg in barvo
podatkovne vrstice kliknemo na gumb Dodatne možnosti.

Z naborom ikon prikažemo ikone poleg podatkov v izbranih celicah z namenom grafičnega
prikaza, v katero kategorijo sodi vrednost. Izbiramo med nekaj nabori – barvnimi, sivimi
puščicami, zastavicami, semaforji, smeški, ocenami moči signala, četrtinami kroga. Nabori ikon
so dosegljivi le, če izberemo za pogoj Vse celice.

Upravljanje pogojnega oblikovanja

Za prikaz vseh pogojnih oblikovanj na delovnem listu:

1. Izberi Oblika→Pogojno oblikovanje→Upravljaj (Manage).

2. V pogovornem oknu, ki sledi (slika 3.33), izberi obseg s seznama in klikni Uredi za popravek
pogojnega oblikovanja.

3. Izberi obseg in klikni Odstrani za izbris pogojnega oblikovanja. S tem ga neposredno
izbrišemo s seznama.

4. Izberi Dodaj za novo pogojno oblikovanje.

5. S klikom na gumb V redu shranimo spremembe in zapremo pogovorno okno.

3.2.9 Skrivanje in prikazovanje podatkov

V Calc-u lahko skrijemo posamezne elemente, tako da niso več vidni na zaslonu in da niso več
natisljivi. Še vedno jih lahko kopiramo, če izberemo sosednje elemente. Recimo, da je stolpec B
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Slika 3.33: Pogovorno okno Upravljaj pogojno oblikovanje

skrit in izberemo stolpca A in C. Tako bo ob kopiranju prenesen tudi stolpec B. Ko skriti element
potrebujemo, proces skrivanja obrnemo in ga tako ponovno prikažemo.

Skrivanje vrstic, stolpcev in delovnih listov

1. Izberemo list, vrstico ali stolpec, ki ga želimo skriti.

2. V glavnem meniju izberemo Oblika→Vrstica/Stolpec/Delovni list (Format→
Row/Column/Sheet).

3. Izberemo možnost Skrij (Hide) in vrstica oziroma stolpec oziroma delovni list ne bo
več viden. Alternativno lahko desno-kliknemo na glavo vrstice, glavo stolpca ali zavihek
delovnega lista in izberemo Skrij iz kontekstnega menija.

Skrivanje celic

1. Izberemo celice, ki jih želimo skriti.

2. Izberemo Oblika→Celice iz glavnega menija ali Oblikuj celice iz kontekstnega menija
ali vtipkamo bližnjico Ctrl+1 za pogovorno okno Oblikuj celice.

3. Kliknemo na zavihek Zaščita celice (Cell Protection) in v razdelku Zaščita izbe-
remo Skrij vse (slika 3.34).

4. Stisnemo gumb V redu, da shranimo spremembo in zapremo okno.

Že v pogovornem oknu je omenjeno, da bo zaščita celic učinkovita le v primeru, ko je zaščiten
tudi delovni list.

5. Izberemo Orodja→Zaščiti dokument→Delovni list (Tools→Protect Document→
Sheet).

6. V pogovornem oknu (slika 3.35) izberemo Zaščiti ta delovni list in vsebino za-
ščitenih celic.

7. Vnesemo geslo in ga potrdimo.

8. Opcijsko izberemo Vsem uporabnikom tega delovnega lista dovoli, tako da uporab-
niki lahko izbirajo zaščitene ali nezaščitene celice.

9. Stisnemo gumb V redu, da shranimo spremembo in zapremo okno. Izbrane celice bodo
prazne, vsebina bo ponovno vidna le, če bomo odstranili zaščito.
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Slika 3.34: Zavihek Zaščita celice pogovornega okna Oblikuj celice

Slika 3.35: Pogovorno okno Zaščiti delovni list
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Ponovni prikaz vrstic, stolpcev in delovnih listov

1. Izberemo liste, vrstice oziroma stolpce na obeh straneh skritega elementa.

2. V glavnem meniju izberemo Oblika→Vrstica/Stolpec/Delovni list.

3. Izberemo možnost Prikaži in skriti element se bo prikazal in bo natisljiv. Alternativno
lahko desno-kliknemo na glavo vrstice, glavo stolpca ali zavihek delovnega lista in izberemo
Prikaži iz kontekstnega menija.

Ponovni prikaz celic

1. Izberemo Orodja→Zaščiti dokument→Delovni list.

2. V pogovornem oknu vnesemo geslo za odstranitev zaščite in kliknemo V redu.

3. Izberemo Oblika→Celice iz glavnega menija ali Oblikuj celice iz kontekstnega menija
ali vtipkamo bližnjico Ctrl+1 za pogovorno okno Oblikuj celice.

4. Kliknemo na zavihek Zaščita celice in odstranimo vse možnosti skrivanja celic.

3.2.10 Združevanje in oris

Ta funkcionalnost pride prav pri večkratnem skrivanju in ponovnem prikazovanju enih in istih
celic. Podatke lahko orišemo. Vrstice ali stolpce hierarhično razporedimo v skupine, ki jih lahko
nato skrijemo ali prikažemo z enim klikom. Vidnost skupine upravljamo z znakoma + in -, ki
se pojavita kot gumba, ko elemente združimo. Skupine lahko tudi gnezdimo. Takrat se pojavijo
kazalniki nivoja za skupine.

Združevanje vrstic ali stolpcev

1. Izberemo celice, ki jih želimo združiti.

2. Izberemo Podatki→Združi in oriši→Združi (Data→Group and Outline→Group). Ali
uporabimo bližnjico F12.

3. Prikaže se pogovorno okno Združi, kjer lahko izberemo ali vrstice ali stolpce. Na sliki 3.36
smo združili prvi dve vrstici tabele. Pasica s kazalnikom skupine se prikaže na levi strani
okna.

Skrivanje podrobnosti

Če želimo skriti podrobnosti katerekoli skupine vrstic ali stolpcev:

1. Kliknemo na znak minus (-) na kazalniku skupine.

2. Alternativno izberemo celico na vsaki strani skrite skupine in v glavnem meniju izberemo
Podatki→Združi in oriši→Skrij podrobnosti (Hide Details).

3. Vrstice ali stolpci so skriti in minus (-) znak se spremeni v plus (+).
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Slika 3.36: Kazalnik skupine

Prikaz podrobnosti

Če želimo skriti podrobnosti katerekoli skupine vrstic ali stolpcev:

1. Kliknemo na gumb plus (+) na kazalniku skupine.

2. Alternativno izberemo celico na vsaki strani skrite skupine in v glavnem meniju izberemo
Podatki→Združi in oriši→Pokaži podrobnosti (Show Details).

3. Vrstice ali stolpci so prikazani in plus (+) znak se spremeni v minus (-).

Razdruževanje

Če želimo razdružiti skupine vrstic ali stolpcev:

1. Preverimo, ali so skupine vrstic/stolpcev prikazane.

2. V glavnem meniju izberemo Podatki→Združi in oriši→Razdruži (Ungroup) ali
uporabimo bližnjico Ctrl+F12.

3. Če izbrane celice ležijo v skupinah stolpcev in vrstic, potem v pogovornem oknu Razdruži
izberimo še, katero skupino bomo razdružili.

Če imamo gnezdene skupine, razdružimo le najnižjo skupino vrstic/stolpcev. Za popolno
odstranitev združevanja izberemo Podatki→Združi in oriši→Odstrani (Remove).

3.2.11 Filtriranje

Filter je seznam pogojev za vsak vnos. Če pogoji niso izpolnjeni, potem vnos ni prikazan. Calc
nudi tri tipe filtrov:

• Samodejni – filtrira podatke glede na določeno vrednost ali besedilo. Avtomatsko določi
obseg vrednosti in prikaže seznam, od koder lahko izberemo element, ki ga želimo prikazati.

• Standardni – določi logične pogoje za filtriranje.

• Napredni – pogoje prebere iz izbranih celic.
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Slika 3.37: Primer samodejnega filtra

Dodajanje samodejnega filtra

Samodejni filter doda spustni seznam v prve vrstice izbranega obsega celic. Elementi tega
seznama so vse unikatne vrednosti izbranih celic, sortirane po leksikografskem vrstnem redu.

Samodejni filter dodamo na naslednji način:

1. Kliknemo v obseg celic, kjer želimo filtrirati.

2. Menijska izbira Podatki→Filtriraj→Samodejni filter (Data→Filter→AutoFil-
ter) doda gumb s puščico v glavo vsakega stolpca v obsegu.

3. Klik na gumb prikaže vse vrednosti ali niz, ki ga lahko določimo za pogoj filtra (slika 3.37).

4. Izberemo vse vrednosti ali nize, ki jih želimo v pogoju. Prikažejo se zapisi, ki ustrezajo
pogojem.

Dodajanje standardnega filtra

Ta tip je bolj kompleksen kot samodejni filter. Vnesemo lahko do osem pogojev, ki jih združimo
z logičnima operatorjema IN ali ALI. Uporabljamo ga predvsem pri filtriranju številk, ima pa
vgrajenih tudi nekaj pogojev za besedila.



110 Preglednica

Slika 3.38: Pogovorno okno Standardni filter

1. Izberemo obseg celic.

2. V glavnem meniju izberemo Podatki→Filter→Standardni filter za pogovorno okno
Standardni filter (slika 3.38).

3. Določimo pogoje in možnosti filtriranja.

4. Kliknemo gumb V redu. Zapisi, ki ustrezajo filtru, bodo prikazani, ostali ne.

Filter sestavljajo vrstice, ki predstavljajo po en pogoj. Vsaka vrstica vsebuje štiri vnosna
polja – operator (tip vrstice), ime polja, pogoj in vrednost.

• Operator določa, v kakšnem logičnem razmerju je pogoj z ostalimi pogoji (IN/ALI).

• Ime polja (Filed Name) določa, katero polje v trenutni tabeli bo uporabljeno. Če tabela
nima glave, bodo na izbiro oznake stolpcev (npr. Stolpec A).

• Pogoj (Condition) določi primerjalni operator, ki veže izbrano polje z vrednostmi.

• Vrednost (Value) določi vrednost za filtriranje izbranega polja. Iz spustnega seznama,
ki se prikaže, izberemo eno od vseh možnih vrednosti za polje. Na voljo sta tudi vrednosti
Prazno in Ni prazno.

V razdelku Možnosti so na voljo še naslednja potrditvena polja:

• Razlikuj velike in male črke (Case sensitive) – z uporabo te možnosti pri filtri-
ranju ločimo med malimi in velikimi črkami.

• Obseg vsebuje oznake stolpcev (Range contains column labels) – s tem Calc
vzame prvo vrstico in jo uporabi za oznake stolpcev.

• Kopiraj rezultate v (Copy results to) – rezultat filtra lahko kopiramo drugam, če
ne želimo prevoziti izbranega obsega.
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Slika 3.39: Pogovorno okno Napredni filter

• Regularni izraz (Regular expressions) – v polju Vrednost lahko uporabljamo regu-
larne izraze, če za Pogoj izberemo vrednost = (enako) ali <> (neenako). Seznam vseh
regularnih izrazov, ki jih LibreOffice podpira, najdemo v Pomoči za LibreOffice (bližnjica
F1).

• Brez podvajanja (No duplications) – izloči podvojene vrstice iz seznama filtriranih
podatkov.

• Obdrži pogoje filtriranja (Keep filter criteria) – to možnost lahko izberemo
po izbiri Kopiraj rezultate v. S tem dosežemo, da ciljni obseg ostane povezan z vi-
rom. Vir – obseg, ki ga filtriramo, mora biti definiran preko Podatki→Določi obseg
(Data→Define Range). Tako lahko spremenimo podatke v viru in filter ponovno
apliciramo z menijsko izbiro Podatki→Osveži obseg (Data→Refresh Range).

Dodajanje naprednega filtra

Struktura naprednega filtra je podobna strukturi standardnega filtra. Razlikuje se le v podajanju
argumentov filtra, ki jih ne določimo v pogovornem oknu, temveč jih vpišemo v celice v
preglednici.

1. Izberemo obseg celic v preglednici.

2. V meniju izberemo Podatki→Filter→Napredni filter (Advanced Filter) za pogo-
vorno okno (slika 3.39).

3. V razdelku Preberi pogoje filtra (Read filter criteria from) izberemo poimeno-
van obseg ali vnesi obseg, ki vsebuje pogoje filtra.

4. Kliknemo V redu. Prikažejo se zapisi, ki ustrezajo pogojem.
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Slika 3.40: Pogovorno okno Razvrsti – Pogoji razvrščanja

3.2.12 Razvrščanje (sortiranje) zapisov

Razvrščanje v Calc-u uredi celice delovnega lista pod pogoji, ki jih določimo. Razvrščanje je
uporabno, če iščemo določen element, še bolj pa pride prav v kombinaciji s filtriranjem.

Za primer vzemimo vnašanje novih podatkov v preglednico. Če je ta dolga, je vrstice laže
dodajati na dnu lista kot pa jih vstavljati tam, kamor spadajo. Po vnosu razvrstimo celice in
preglednica je posodobljena.

Pogovorno okno Razvrsti

Da celice razvrstimo s pomočjo pogovornega okna (slika 3.40):

1. Izberemo celice za razvrščanje.

2. V meniju izberemo Podatki→Razvrsti (Data→Sort) in zavihek Pogoji razvrščanja
(Sort criteria).

3. Izberemo pogoje iz spustnih seznamov, ki sestojijo iz izbranih celic.

4. Izberemo ali naraščajoči (A-Ž, 1-9) ali padajoči (Ž-A, 9-1) vrstni red.

5. Kliknemo V redu in razvrščanje se bo izvedlo.

V drugem zavihku pogovornega okna določamo možnosti razvrščanja (slika 3.41):

• Razlikuj velike in male črke (Case sensitive) – razvrsti najprej po velikih, nato
po malih črkah.

• Obseg vsebuje oznake stolpcev (Range contains column labels) – izpusti prvo
vrstico oziroma prvi stolpec iz razvrščanja.

• Vključi oblike (Include formats) – ohrani trenutno oblikovanje celic.



3.2 Vnašanje, urejanje in oblikovanje podatkov 113

Slika 3.41: Pogovorno okno Razvrsti – Možnosti

• Omogoči naravni algoritem razvrščanja (Enable natural sort) – naravno razvrš-
čanje je algoritem, ki razvrsti števila z besedilno predpono glede na vrednost
številskega dela in ne na običajen način razvrščanja besedil. Na primer, da želimo
razvrstiti zaporedje A1, A2, A3, ..., A19, A20, A21. Če vnesemo te vrednosti v
obseg celic in poženemo razvrščanje (privzeto se uporabi leksikografsko), dobimo A1,
A10, A11, A12, A13, ..., A19, A2, A20, A21, A3, A4, A5, ..., A9, kar pa je
vsaj v tem primeru nezaželeno. Z izbiro naravnega razvrščanja so takšne vrednosti
razvrščene pravilno.

• Kopiraj rezultate razvrščanja v (Copy results to) – kopira razvrščen seznam v
izbran obseg celic. Lahko izberemo imenovan obseg ali pa ga vpišemo v vnosno polje.

• Vrstni red po meri (Custom sort order) – razvrsti celice po meri. Predefiniranih
je že nekaj razvrščanj (kot npr. ponedeljek. . . nedelja, januar. . . december). Če želimo
ustvariti novega, to storimo preko Orodja→Možnosti→LibreOffice Calc→
Razvrščevalni seznami.

• Jezik (Language) – izbere jezik, določa pravila razvrščanja.

• Možnosti (Options) – nekateri jeziki imajo več možnosti razvrščanja.

• Smer – Od zgoraj navzdol (Direction – Top to bottom) – razvrsti vrstice po vred-
nostih v aktivnih stolpcih izbranega obsega.
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Slika 3.42: Orodna vrstica Najdi

• Smer – Od leve proti desni (Direction – Left to Right) – razvrsti stolpce po
vrednostih v aktivnih vrsticah izbranega obsega.

Hitro razvrščanje

Če imajo stolpci glave v tekstovni obliki, lahko uporabimo hitro razvrščanje:

1. Izberemo celico ali obseg.

2. Kliknemo na gumb Razvrsti naraščajoče (Sort Ascending) ali Razvrsti pa-

dajoče (Sort Descending) iz orodne vrstice Standardno.

3.2.13 Najdi in zamenjaj

V Calc-u iščemo na dva načina – z orodno vrstico Najdi (slika 3.42) in s pogovornim oknom
Najdi in zamenjaj (slika 3.43).

Orodna vrstica Najdi

1. Orodno vrstico Najdi (slika 3.42) prikličemo ali z menijsko izbiro Pogled→Orodne
vrstice→Najdi ali z menijsko izbiro Uredi→Najdi (Edit→Find) ali z bližnjico Ctrl+F.
Privzeto se orodna vrstica zasidra na spodnji levi del Calc-ovega okna, a jo lahko odsidramo
in premaknemo kamorkoli želimo.

2. Iskalni pojem vpišemo v vnosno polje.

3. Če želimo bolj omejiti iskanje, vklopimo možnost Razlikuj velike in male črke. Tako
bo na primer iskalni pojem ”Preglednica” našel le ”Preglednica” z veliko začetnico in ne
”preglednica”.

4. Z gumboma Najdi naslednje in Najdi prejšnje se sprehajamo med vsemi
primeri najdenih pojmov.

5. Z gumbom Najdi vse označimo vse primere.
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Slika 3.43: Pogovorno okno Najdi in zamenjaj

Pogovorno okno Najdi in zamenjaj

Iskanje.

1. Menijska izbira Uredi→Najdi in zamenjaj, gumb Najdi in zamenjaj na orodni vrstici
Najdi ali bližnjica Ctrl+H prikliče pogovorno okno (slika 3.43).

2. Iskalni pojem vpišemo v vnosno polje Išči.

3. Če je potrebno, razširimo Razne možnosti s klikom na + pred tekstom. Možnosti povečajo
število iskalnih filtrov in so opisane na koncu tega podpoglavja.

4. Kliknemo na gumb Najdi, da poiščeš prvi primerek iskalnega pojma.

5. Ponovno kliknemo na gumb Najdi, da poiščemo naslednji primer.

6. Kliknemo Najdi vse, da poiščemo vse primerke iskalnega pojma. Celice, ki vsebujejo
pojem, se bodo označile.

Zamenjava.

1. Menijska izbira Uredi→Najdi in zamenjaj, gumb Najdi in zamenjaj na orodni vrstici
Najdi ali bližnjica Ctrl+H prikliče pogovorno okno (slika 3.43).

2. Vpišemo iskalni pojem v vnosno polje Išči.
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3. Vpišemo pojem za zamenjavo v vnosno polje Zamenjaj z.

4. Če je potrebno, razširimo Razne možnosti s klikom na + pred tekstom. Možnosti povečajo
število iskalnih filtrov in so opisane na koncu tega podpoglavja.

5. Kliknemo na gumb Zamenjaj za zamenjavo prvega primera iskalnega pojma.

6. Ponovno kliknemo na gumb Zamenjaj za zamenjavo naslednjega pojma.

7. Kliknemo Zamenjaj vse za zamenjavo vseh primerkov iskalnega pojma.

Možnosti pri iskanju in zamenjavi pojmov. Možnosti so naslednje:

• Išči (Search for) – vnosno polje za vpis iskalnega pojma. S spustnega seznama lahko
izberemo tudi prejšnje vnose.

• Zamenjaj z (Replace with) – vnosno polje za pojem, s katerim bomo zamenjali iskalni
pojem. S spustnega seznama lahko izberemo tudi prejšnje vnose.

• Razlikuj velike in male črke (Match case) – z uporabo te možnosti ločimo med
malimi in velikimi črkami.

• Cele celice (Entire cells) – iskalni pojem primerja s celotno vsebino celic.

• Samo trenutni izbor (Current selection only) – išče le v izbranem obsegu celic.

• Nazaj (Backwards) – iskanje se začne pri kazalcu in gre nazaj do začetka pregledni-
ce/izbora.

• Regularni izrazi (Regular expressions) – pri iskanju lahko uporabljamo regularne
izraze. Seznam vseh regularnih izrazov, ki jih LibreOffice podpira, najdemo v Pomoči za
LibreOffice (bližnjica F1).

• Išči sloge celice (Search for Cell Styles) – išče besedilo, oblikovano z določenim
slogom. V polje Išči vnesemo iskani slog in v polje Zamenjaj z (Replace with) izbere-
mo nadomestni slog.

• Iskanje podobnosti (Similarity search) – išče pojme, ki so podobni iskalnem pojmu.
Definirati je potrebno še parametre podobnosti, ki jih najdemo s klikom na gumb ....

• Išči na vseh listih (Search in all sheets) – išče na vseh delovnih listih
preglednice.

• Išči v (Search in) – možnosti Formule (Formulas), Vrednosti (Values) in Opombe
(Notes) določajo, kje se bo iskanje vršilo – v rezultatih formul, vrednostih ali opombah.

• Smer iskanja (Search direction) – določimo vrstni red iskanja po vrsticah ali po
stolpcih.
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3.3 Uporaba formul in funkcij

3.3.1 Uvod

V prejšnjih poglavjih smo vnašali dve vrsti podatkov – številke in besedila. Velikokrat pa
je vsebina ene celice odvisna od drugih. V ta namen uporabljamo tretji tip podatkov –
formule. Formule so enačbe, ki uporabljajo števila, besedila in spremenljivke, da vrnejo vrednost.
Spremenljivke so v našem primeru lokacije celic, katerih vsebina se uporabi pri izračunu.

Funkcije so vnaprej definirane formule, ki izračunajo vrednost na osnovi vrednosti, ki jih
podamo ob klicu formule. S funkcijami si pomagamo pri izdelavi končnih formul za dosego
želenih rezultatov.

Pri pripravi obsežnejše preglednice se splača planirati vnaprej, da se izognemo tipičnim
napakam, recimo vnašanju fiksnih vrednosti v formule. Dobro je vključiti krajši opis o namenu
preglednice, imeti sistem preverjanja formul in jih komentirati, če niso trivialne.

Past vnašanja fiksnih vrednosti v formule

Veliko uporabnikov v formule vnaša fiksne vrednosti. Kot primer, zakaj to ni najbolje, vzemimo
pretvorbo valut. To zahteva poznavanje trenutnega menjalnega tečaja. Če v celico C1 vnesemo
=0,78*B1, kolikor znaša vrednost enega ameriškega dolarja v evrih, bo potrebno ob spremembi
tečaja popravljati formulo. Lažje je imeti tečajno vrednost v eni celici in se nanjo sklicevati v
formuli. Razbijanje kompleksnih formul na manjše dele zmanjša možnost za napako.

Pomanjkanje dokumentacije

V življenjskem ciklu preglednice se ta dostikrat posodablja in postaja vedno bolj kompleksna.
Brez dokumentacije je njeno metodologijo težko razvozlati, prvotni namen preglednice je
zamegljen. V takem primeru je dostikrat hitreje začeti znova. Z uporabo komentarjev olajšamo
delo sebi in ostalim za nami.

Formule za preverjanje napak

Pri seštevanju več stolpcev podatkov ali več območij celic pride do napak zaradi spuščanja celic,
izbiranja napačnega obsega, dvojnega štetja celic. Splača se vpeljati preverjanja. Recimo, da
želimo izračunati vsoto po stolpcih (glej sliko 3.44). Uporabimo funkcijo SUM. Da preverimo, ali
ni prišlo do napake pri kakšnem izračunu, dodamo vsote po vrsticah in jih seštejemo. Vsota po
stolpcih in vsota po vrsticah morata biti enaki, sicer vemo, da se je nekje vrinila napaka.

Lahko celo nastavimo formulo, ki izračuna razliko med obema vrednostima in javi napako,
če ni enaka 0.
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Slika 3.44: Preverjanje napak pri formulah

3.3.2 Izdelava formul

Formule vnašamo na dva načina – neposredno v celico ali v vnosno vrstico. V obeh primerih
formule začnemo z enačajem, plusom ali minusom, sicer bo formula obravnavana kot besedilo.

Vsaka celica lahko vsebuje ali podatke ali pa nudi prostor za izračun. Primer na sliki 3.45
prikazuje različne možnosti izračuna vsote dveh števil.

Vsoto lahko izračunamo v eni sami celici, kot prikazuje izračun na levi strani, a moč
preglednice pride do izraza, če uporabimo več celic. Podatke vpišemo, v našem primeru, v
celici B3 in B4, v izračunu v B5 pa se nanje skličemo. Formula za celico B5 je =B3+B4. Vsebino
celic B3 in B4 seštejemo in rezultat prikažemo v celici, kjer smo vpisali formulo. Ta koncept velja
za vse formule. Tabela 3.1 prikazuje nekaj primerov izračunov.

Sklici nam omogočajo, da v formulah uporabimo podatke iz kateregakoli delovnega lista celo
v katerikoli datoteki, če je ta odprta. Na celice v drugih listih se sklicujemo tako, da pred imenom
celice dopišemo ime lista in ga ločimo s piko. Če ime lista vsebuje presledke, ga moramo zapisati
v enojnih navednicah, npr. =naloga2.B12 + ’Delovni list3’.A11.

Za pogosto uporabljane obsege celic Calc nudi poimenovanje obsegov. V podmeniju
Vstavi→Imena lahko obseg B3:B10 po želji poimenujemo.

Calc vključuje tudi logične funkcije. V gornji tabeli je prikazana uporaba stavka IF, ki
ima tri parametre. Prvi je logični test, ki ima lahko vrednost true ali false. Funkcija vrne
drugi parameter, če logični test vrne vrednost true, sicer vrne tretji parameter. Vzemimo
primer =IF(A2>=0, "Pozitivno", "Negativno"). Če je v A2 vrednost 3, potem funkcija vrne
”Pozitivno”, če je -9, vrne ”Negativno”.
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Slika 3.45: Preprost izračun

Formula Opis
=A1+10 prikaže vsebino A1 plus 10
=A1*16% prikaže 16% vsebine A1
=A1*A2 prikaže zmnožek A1 in A2

=ROUND(A1, 1)
prikaže zaokroženo vsebino A1 na eno decimalno
mesto

=EFFECTIVE(5%, 12)
izračuna neto letno obrestno mero za 5% letno
nominalno obrestno mero z mesečnimi plačili

=B8-SUM(B10:B14) izračuna B8 minus vsota celic od B10 do B14

=SUM(B8,SUM(B10:B14))
izračuna vsoto od B10 do B14 in sešteje z
vrednostjo B8

=SUM(B1:B1048576) sešteje vsa števila v stolpcu B

=AVERAGE(KrvniTlak)
prikaže povprečje obsega celic z imenom
KrvniTlak

=IF(C31>140, "VISOK",
"V REDU")

Prikaže rezultat analize podatkov iz dveh virov.
Če je vsebina C31 večja od 140, potem prikaže
VISOK, sicer prikaže V REDU.

Tabela 3.1: Nekaj primerov formul
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Operator Operacija Primer
+ seštevanje = 1+1
- odštevanje = 2-1
- negacija = -5
* množenje = 2*2
/ deljenje = 10/5
% odstotek 15%
ˆ potenciranje = 2ˆ3

Tabela 3.2: Aritmetični operatorji

Operator Relacija Primer
= je enako A1=B1
> je večje A1>B1
< je manjše A1<B1
>= je večje ali enako A1>=B1

<= je manjše ali
enako A1<=B1

<> ni enako A1<>B1

Tabela 3.3: Primerjalni operatorji

Operatorji

V Calc-u obstajajo aritmetični, primerjalni, besedilni in referenčni operatorji.

Aritmetični operatorji. Seštevanje, odštevanje, množenje in deljenje so binarni operatorji,
to je zahtevajo dva operanda in vrnejo številske vrednosti. Negacija in odstotek sta unarna
operatorja, to je zahtevata en operand. Tabela 3.2 prikazuje tudi primer potence.

Primerjalni operatorji. Primerjalne operatorje najdemo v formulah, ki uporabljajo
funkcijo IF in vrnejo ali pravilen ali nepravilen odgovor. Neposredno se vrednost true ali false
da dobiti na primer s formulo =B6>B12. Če je vrednost B6 res večja od tiste v B12, potem je
odgovor true, sicer je false.

Če A1 vsebuje številsko vrednost 4 in B1 vsebuje 5, bi primeri v tabeli 3.3 vrnili false, false,
true, false, true, true.

Besedilni operatorji. Besedilo je sestavni del podatkov v preglednicah, zato je logično, da
želimo izvajati operacije nad besedilom. Lahko ga stikamo, določamo dele, ki bodo prikazani in
kako bodo ti prikazani. Slika 3.46 prikazuje primer.
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Slika 3.46: Stikanje besedila

A2:B4 Sklic na pravokotnik s 6 celicami, širine 2 stolpcev in
3 vrstic.

(A2:B4):C9
Sklic na pravokotnik z zgornjim robom v A2 in
spodnjim desnim v C9. Ta način sklicevanja razširi
prvotni obseg A2:B4 v A2:C9.

List1.A3:List3.D4
Sklic na kvadrasti obseg s 24 celicami, širine 4 stolpcev,
višine 2 vrstic in globine 3 listov.

Tabela 3.4: Primeri obsegov

V tem primeru smo združili tekst iz treh celic. Dodali smo tudi presledek in vejico. Dobesedno
besedilo ovijemo v navednice. Formula =B2 & " " & C2 & ", " & D2 prikaže datum, oblikovan
kot na sliki. Obstaja tudi funkcija CONCATENATE, ki izvede isto operacijo kot operator &.

Referenčni operatorji. Najenostavnejša oblika sklica je sklic na eno celico, lahko pa se
sklicujemo tudi na pravokotnik celic ali celo kvader celic (tretja dimenzija gre po zaporedju
delovnih listov). Za sklicevanje potrebujemo referenčne operatorje.

Spomnimo, da je posamezna celica določena z identifikatorjem stolpca (črke) in
identifikatorjem vrstice (številke), ki jih najdemo na zgornjem in levem robu delovnega lista.
Zgornja leva celica je A1.

Operator obsega. Operator obsega zapišemo kot dvopičje. Sintaksa zapisa obsega celic
je naslednja – levi sklic : desni sklic. Operator zgradi sklic v najmanjšem obsegu, ki še
vsebuje oba robna sklica.

Vpisi B4:A2 ali A4:B2 niso napačni, a jih bo Calc popravil v A2:B4 tako, da celica pred
dvopičjem vedno predstavlja zgornji levi rob, celica za dvopičjem pa spodnjega desnega. Ne
moremo se sklicevati na celoten stolpec A:A ali vrstico 1:1.
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Operator referenčnega stika. Operator referenčnega stika zapišemo kot tildo (˜).
Sintaksa je naslednja: levi sklic ˜ desni sklic. Rezultat tega izraza je referenčni seznam, ki
je oštevilčen seznam sklicev. Določene funkcije jih lahko sprejmejo za parametre, recimo SUM,
MAX, INDEX.

Referenčni stik je pogosto imenovan tudi unija, čeprav ni enak pojmu unije, kot ga poznamo
iz teorije množic. Število celic v obsegu A1:C3˜B2:D2, kar preštejemo s funkcijo COUNT(
A1:C3˜B2:D2), je 12 (=9+3), medtem ko prava unija teh dveh množic obsega 10 celic.

Opozoriti velja še na eno podrobnost. SUM(A1:C3˜B2:D2) ni enako SUM(A1:C3, B2:D2),
čeprav izračuna vrneta enak rezultat. Prvi izračun je klic funkcije z enim parametrom, to je
seznam sklicev, drugi izračun je klic funkcije z dvema parametroma, to sta vsak zase sklica na
obseg celic.

Operator preseka. Operator preseka zapišemo kot klicaj. Sintaksa je naslednja: levi
sklic ! desni sklic. Če oba sklica predstavljata posamična obsega, je rezultat sklic na obseg,
ki vsebuje vse celice, ki so v obeh obsegih, torej presek obeh obsegov.

Za primer vzemimo A2:B4 ! B3:D6. Rezultat je obseg B3:B4, ker so te celice znotraj A2:B4
in znotraj B3:D6.

Operator preseka ima prednost pred operatorjem stika. Operacijo, ki jo želimo izvršiti prej,
damo v oklepaje.

Relativni in absolutni sklici

Sklicevanje je način, kako uporabimo lokacijo celice pri izračunu. Poznamo relativno (glede na
trenutno celico) in absolutno (fiksno).

Relativni sklici. Najlaže je prikazati razliko med sklicevanjema s primerom. Potek izdelave
primera je naslednji:

1. Števili 4 in 11 vpišemo v C3 in C4.

2. Formulo kopiramo v B5 (=B3+B4) v celico C5. To storimo s splošnim ukazom kopiraj
in prilepi (copy&paste), lahko pa s principom povleci in spusti (drag&drop), kot je to
prikazano na sliki 3.47.

3. Kliknemo na celico C5. V vnosni vrstici se izpiše formula =C3+C4 in ne =B3+B4, rezultat je
15, vsota 4 in 11, kar so vrednosti C3 in C4.

V celici B5 imamo relativne sklice na B3 in B4. Calc interpretira formulo v B5, jo uporabi v
stolpcu B in vrne rezultat v B5. Pri kopiranju formule v drugo celico se uporabi enaka procedura,
to pot formula v C5 uporabi stolpec C.

Na relativne sklice lahko gledamo kot na par odmikov od trenutne celice. Celica B1 je 1
stolpec levo in 4 stolpce nad celico C5. Lokacijo bi lahko napisali kot R[-1]C[-4] (Row, Column).
Pravzaprav so starejše preglednice dovolile takšno notacijo v formulah.
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Slika 3.47: Relativni sklici

Kadarkoli kopiramo formulo iz C5 v drugo celico, bo rezultat vedno vsota števil iz celic
neposredno nad celico s formulo.

Relativno sklicevanje oziroma naslavljanje je privzet način sklicevanja v Calc-u.

Absolutni sklici. Pogosto želimo stolpec števil pomnožiti s fiksno vrednostjo. Recimo, da
imamo stolpec vrednosti v ameriških dolarjih, ki jih želimo pretvoriti v evre. To preprosto
naredimo tako, da jih pomnožimo z menjalnim tečajem (1USD = 0,79 EUR na dan pisanja).
Primer na sliki 3.48 pokaže, kakoje smiselno pristopiti k tej nalogi:

1. V celico D1 vpišemo menjalni tečaj EUR:USD (0,79). V celice D2, D3 in D4 vpišemo
vrednosti v USD, recimo 100, 1000 in 2000.

2. V celico E2 vpišemo formulo =D2*D1.

3. Formulo v celici E2 kopiramo v E3. Rezultat je napačen! Calc je kopiral formulo z uporabo
relativnega sklicevanja. Formula v E3 je =D3*D2 in ni tisto, kar želimo (=D3*D1).

4. V celici E2 uredimo formulo v =D2*$D$1. Kopiramo jo v celici E3 in E4.

Znak $ pred D in 1 spremeni sklic na celico D1 v absolutnega. Če takšno formulo kopiramo
drugam, bo drugi faktor ostal nespremenjen, torej $D$1. Interpretacija formule je takšna: ”Vzemi
vrednost celice za eno v levo v isti vrstici in jo zmnoži z vrednostjo v celici D1”.

Pravzaprav obstajajo štiri oblike sklicev, relativni, absolutni in mešani, kjer je fiksen le
stolpec oziroma vrstica celic (tabela 3.5).

Bližnjica za hitro spreminjanje sklica je Shift+F4.
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Slika 3.48: Absolutni sklici

Sklic Opis

D1
relativen sklic – v E3 predstavlja celico, ki je en stolpec
levo in dve vrstici nad njo

$D$1 absolutni sklic – v E3 predstavlja celico D1

$D1
mešani sklic – v E3 predstavlja celico, ki je v stolpcu
D in dve vrstici nad njo

D$1
mešani sklic – v E3 predstavlja celico, ki je en stolpec
levo in v vrstici 1

Tabela 3.5: Sklici
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+
Ta operator sešteje dve števili. SUM() po drugi strani
sešteje skupine več obsegov.

*
Ta operator zmnoži dve števili. PRODUCT() po drugi
strani zmnoži skupine več obsegov.

Tabela 3.6: Operator seštevanja in množenja

3.3.3 Razumevanje funkcij

Calc vsebuje čez 350 funkcij. Precejšen delež teh se uporablja za manipulacijo števil, ostale se
uporabljajo za delo z datumi, časi, besedili. Funkcije se razlikujejo tudi po kompleksnosti, od
seštevanja dveh števil, do izračuna standardnega odklona vzorca, hiperboličnega tangensa itd.

Ime funkcije tipično sestoji iz okrajšanega angleškega opisa, kar funkcija dejansko dela.
Funkcija FV na primer vrne bodočo vrednost naložbe (Future Value), funkcija BIN2HEX pretvori
binarno število v šestnajstiško. Funkcije praviloma pišemo z velikimi črkami, čeprav Calc
prepozna zapise z malimi črkami ali celo z velikimi in malimi črkami skupaj.

Nekaj osnovnih funkcij je primerljivih z operatorji, recimo seštevanje in množenje (tabela
3.6).

Vsaka funkcija ima določeno število parametrov, ki jih je potrebno podati, če želimo dobiti
rezultat. V nekaterih primerih so vrednosti že predefinirane in se moramo zateči h Calc-ovi
pomoči, a v večini so to vrednosti, ki jih vpišemo ročno ali pa se že nahajajo v celicah. Vrednosti
lahko podamo tako, da vpišemo njihovo ime ali obseg, lahko pa jih izberemo z miško. Če se
vrednosti spremenijo, se bo to odrazilo tudi v rezultatu funkcije.

Zaradi kompatibilnosti so imena funkcij in parametrov v Calc-u skoraj vedno identična tistim
v Microsoft-ovem Excel-u, a so izjeme, tako da je pri napaki pri uvozu/izvozu smiselno preveriti
imena.

Struktura funkcij

Vse funkcije imajo podobno strukturo. Če uporabimo čarovnika za izgradnjo funkcij, se lahko
učenju strukture izognemo, a še vedno jo je smiselno poznati, že zaradi hitrejšega popravljanja
ob morebitni napaki.

Strukturo funkcije si bomo ogledali na primeru pogojne vsote =SUMIF(obseg; pogoji;
obseg_vsote).

Funkcija mora biti del formule. Tudi če predstavlja celoten izračun, se mora formula začeti z
enačajem. Kjerkoli se že funkcija nahaja v formuli, se začne z imenom in nadaljuje s parametri
v oklepajih. Podati je potrebno vse parametre, razen, če je izrecno napisano, da so opcijski.
Parametre med sabo ločimo s podpičjem.

Funkcije v Calc-u imajo do 30 parametrov. To se ne sliši veliko, a parametri so lahko tudi
obsegi, ki vsebujejo več (tisoč) celic, tako da pravzaprav omejitev ni.

Glede na naravo funkcij lahko parametri zavzamejo različne oblike (glej tabelo 3.7).
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”besedilo” Navednice označujejo, da gre za besedilo
9 Številka 9 smo vnesli kot število.
”9” Število 9 smo vnesli kot besedilo.
A1 Vrednost parametra je enaka vrednosti v celici A1.

Tabela 3.7: Oblike parametrov

Vgnezdene funkcije

Funkcije lahko uporabimo kot parametre drugih funkcij. Takšnim funkcijam pravimo, da so
vgnezdene.

Primer uporabe: =SUM(2; PRODUCT(5, 7)).
Recimo, da oblikujemo modul za samoučenje. Učenci morajo opraviti tri kvize in končne

rezultate vpisati v celice A1, A2 in A3. Povprečje rezultatov izračunamo z AVERAGE(A1:A3),
učencu pa raje vrnemo še povratno informacijo s funkcijo IF:

=IF(AVERAGE(A1:A3)>85; "Čestitamo! Po kratkem predahu vas čaka naslednji
sklop vaj"; "Več sreče prihodnjič!")

Glede na povprečje bo učenec dobil ustrezno sporočilo. Pazite, vgnezdena funkcija ne
potrebuje enačaja!

Seznam funkcij

Seznam funkcij nam olajša vnašanje funkcij, najdemo ga pod Vstavi→Seznam funkcij
(Insert→Function List). Avtomatično se zasidra kot podokno na desni strani (slika 3.49).
Če želimo, kliknemo na zgornji rob podokna in ga odvlečemo na levo, tako da se spremeni v
plavajoče okno.

Seznam vsebuje kratek opis funkcij in parametrov, ko funkcijo izberemo. Okno z opisom
lahko povečamo, če povlečemo razdelilno črto navzgor. Z dvoklikom na funkcijo jo dodamo v
izbrano celico, skupaj s prostornikom (ang. placeholder) za vsakega izmed parametrov funkcije.

Na levi strani podokna se nahaja razmejitvena črta s petimi pikami in dvema puščicama. S
klikom nanjo skrijemo podokno, ob ponovnem klikom pa jo prikažemo.

Uporaba seznama funkcij je skoraj tako hitra kot ročno vnašanje in ima to prednost, da si ni
potrebno zapomniti točnega imena funkcije in števila ter vrstnega reda parametrov. Poleg tega
imamo na voljo še prikaz nazadnje uporabljenih funkcij.

Čarovnik za funkcije

Funkcije najpogosteje vnašamo s čarovnikom (slika 3.50). Tega prikličemo z Vstavi→ Funkcija
(Insert→Function) ali kliknemo na gumb fx na orodni vrstici za formule ali s kombinacijo
tipk Ctrl+F2. Čarovnik ponuja enako pomoč pri vnašanju kot seznam funkcij in doda še polji s
trenutnim rezultatom funkcije in polje z rezultatom širše formule, katere del je funkcija.
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Slika 3.49: Zasidran seznam funkcij

Slika 3.50: Zavihek s funkcijami Čarovnika za funkcije
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Slika 3.51: Zmanjšani čarovnik za funkcije

Najprej izberemo kategorijo funkcij, da skrajšamo seznam, nato najdemo želeno funkcijo.
Po izbiri se na desni strani pogovornega okna prikaže opis funkcije. Z dvoklikom preidemo na
naslednjo stran. Na desni strani zdaj lahko ročno vpisujemo vrednosti za parametre funkcije ali
pa kliknemo na gumb za pomanjšanje, da zmanjšamo čarovnika (slika 3.51). Tako lahko izberemo
celice z delovnega lista.

Celico označimo s klikom, obseg povlečemo kot običajno. Ko smo zadovoljni z izbiro, ponovno
kliknemo na gumb za pomanjšanje ali stisnemo Enter. To ponovimo za vse zahtevane parametre,
stisnemo gumb V redu in dobili bomo rezultat.

Zavihek Zgradba (Structure) uporabimo, če si želimo ogledati drevo oziroma strukturo
formule, ki nam pokaže, kako je formula zgrajena.

3.3.4 Odpravljanje napak

Pri delu s formulami boste kmalu naleteli na sporočilo o napaki. Kljub vsem orodjem v Calc-u
se hitro zmotimo.

Calc nudi nekaj orodij za analizo formul in celic, na katere se sklicujejo – sporočila o napaki,
barvno kodiranje in Detektiva.

Sporočila o napaki

Najosnovnejše orodje so sporočila o napaki. Prikažejo se v celici ali v čarovniku za formule
namesto rezultata.

Sporočilo za formulo je ponavadi trimestno število od 501 do 527 ali pa neoprijemljivo kratko
besedilo kot #NAME?, #REF, #VALUE. Koda napake se izpiše v celici, krajša obrazložitev pa na
desni strani statusne vrstice. Večina sporočil se nanaša na težave pri vnosu formule, nekaj jih je
takšnih, ki sporočajo o omejitvah ali Calc-a ali trenutnih nastavitev.

Sporočila niso uporabnikom prijazna, podajajo pa dragocene namige za razreševanje težav.
Obširne razlage najdemo v vgrajeni pomoči, v tabeli 3.8 pa je zbranih nekaj najobičajnejših.

Primeri pogostih napak

Deljenje z 0 (#DIV/0!). Ta napaka nastane pri deljenju z 0 ali pri deljenju s prazno celico.
Slaba, a najpogostejša rešitev je, da takšne rezultate ročno popravimo. Obstaja boljša, preprosta
rešitev – uporaba pogojne funkcije. Slika 3.52 prikazuje deljenje stolpca B s stolpcem C, kjer pride
do dveh napak.
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#NAME? Napaka s kodo 525 (Nap:525). Neveljavno ime.

#REF!
Napaka s kodo 524 (Nap:524). Manjka stolpec, vrstica ali
list v sklicani celici.

#VALUE!
Napaka s kodo 519 (Nap:519). Vrednost enega od
parametrov ni pravilnega tipa. Ali ni dvojnih narekovajev
za besedilo ali je število na mestu besedila ali obratno.

#DIV0! Napaka s kodo 532 (Nap:532). Deljenje z 0.

#NUM
Pri izračunu je prišlo do napake prekoračitve (overflow)
intervala vrednosti.

509 Pri formuli manjka operator.
510 Pri formuli manjka spremenljivka.

Tabela 3.8: Običajne kode napak

Slika 3.52: Primer napake #DIV/0!
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Slika 3.53: Rešitev napake #DIV/0!

Slika 3.54: Nepravilen vnos povzroči napako #VALUE

Pri zbiranju podatkov se pogosto srečamo z napačnimi ali nepopolnimi podatki, zato je
potrebno biti pazljiv pri nastavljanju formul. Popravljena funkcija za stolpec C bi bila: =IF(C3>0;
B3/C3; ”Ni podatka”). Torej, če je vrednost C3 večja od 0, izračunaj B3 deljeno s C3, sicer
napiši ”Ni podatka”. Zadnji parameter lahko spremenimo v prazne navednice (””, besedilo dolžine
0).

Napačna vrednost #VALUE in Napačen sklic #REF. Napaka #VALUE je tudi pogosta.

Ponavadi pride do te napake, ko celica vsebuje nepravilen tip vrednosti. Na sliki 3.54 je v
celici C8 vpisan tekst ”brez”, formula za stolpec D pa pričakuje številko.

Napako #REF povzroči manjkajoči sklic. V primeru na sliki 3.55 se formula sklicuje na delovni
list, ki je bil zbrisan.
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Slika 3.55: Napaka #REF

Slika 3.56: Barvno kodiranje

Barvno kodiranje

Drugo orodje za preverjanje formul je barvno kodiranje. Pri izbiri formule, ki je že vnesena, se
za lažjo zaznavo vsaka celica oziroma obseg celic obrobi z isto barvo kot je barva parametra.

Calc uporablja 8 barv, začenši z modro barvo za prvi parameter. Sledijo rdeča, rožnata,
zelena, temnomodra, rjava, vijoličasta in rumena. Pri naslednjih parametrih se barve ponovijo.

Detektiv

Pri zahtevnejši preglednici barvno kodiranje postane manj uporabno. Tu nastopi Detektiv, ki
ga najdemo pod menijsko izbiro Orodja→Detektiv (Tools→Detective). Gre za orodje za
analizo celic, ki nastopajo kot parametri v formuli (predhodniki/precedents) in formul, kje je
le-ta uporabljena (odvisniki/dependents). Detektiv je uporaben tudi za sledenje napakam in
označevanje neveljavnih podatkov (v smislu nepravilnih podatkovnih tipov v formuli).

Za uporabo orodja izberemo celico s formulo in ga zaženemo. Na preglednici vidimo črte –
oglišče s krogom ponazarja predhodnika, oglišče s puščico pa odvisnika. Črte ponazarjajo tok
informacij.

Kot primer si oglejmo sledenje predhodnikom v formuli (slika 3.57). Kliknemo na želeno
celico in v meniju izberemo Orodja→Detektiv→Sledi predhodnikom (Trace Precedents)
ali pritisnemo Shift+F7.

3.3.5 Primer: Izdelava tabele s poštevanko

Izdelati želimo tabelo, v kateri bodo izračunani produkti števil iz prve vrstice in prvega stolpca.
Poudarili bomo še ”težje zapomnljiva” števila nad 36. Na videz preprost problem se bo izkazal
za dobrega pri utrjevanju tega poglavja.

Postopamo takole:
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Slika 3.57: Sledenje predhodnikom

Slika 3.58: Poštevanka
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Slika 3.59: Pogojno oblikovanje za ”težje” zmnožke

1. V celico B1 vpišemo 1, v celico C1 vpišemo 2. Označimo obe celici, primemo ročico na
spodnjem desnem robu celice C1 in povlečemo na desno do celice K1. To funkcionalnost
smo že omenili v kontekstu kopiranja vsebine celic. V tem primeru ne gre za dobesedno
kopiranje vsebine, kopirali smo implicitno formulo za naslednji člen aritmetičnega
zaporedja. Če želimo dobiti zaporedne številke, je pravzaprav dovolj vpisati le prvi člen.

2. V celico A2 vpišemo 1 in ponovimo korak 1 navzdol.

3. V notranjosti tabele bodo izračuni. Formula za A3 je =A2*B1. Tega ne bomo ponavljali
za vsako celico, ker poznamo mešane sklice. Da bi kopirali formulo po vrstici, moramo
”fiksirati” prvi faktor, torej =$A$2*B1. S tem smo si olajšali delo za faktor 10, a obstaja
enotna formula za celo tabelo: =$A2*B$1. Formulo si lahko razložimo tako, da je prvi
faktor ”fiksno” v stolpcu A, vrstica pa se relativno spreminja. Drugi faktor je fiksno v
vrstici 1, stolpec pa je relativen.

4. Obseg B2:K11 bomo pogojno oblikovali. Pogoj za rdeče ozadje je, da je vrednost celice
večja od 36. Ker pa otroci pri poštevanki števila 10 nimajo težav, bomo dodali pogoj, da
celica ni deljiva z 10. To malenkost zakomplicira izbiro v pogovornem oknu. Pogoj bo
sedaj sestavljen iz dveh podpogojev, vezanih z logičnim IN, zato uporabimo formulo (slika
3.59). Drugi pogoj je, da vrednost ni deljiva z 10, oziroma, da ostanek pri deljenju z 10
ni enak nič: MOD(B2;10)<>0. Vse skupaj nato povežemo z logično funkcijo AND, torej se
končna formula glasi tako: AND(B2>36; MOD(B2;10))<>0. Omeniti velja še sklic na celico
B2. Če v formuli uporabimo relativen sklic na zgornjo levo celico obsega, potem pogojno
oblikovanje velja za vrednosti v celotnem obsegu.

3.3.6 Primer: Stanje zalog v skladišču

Obdelali bomo še en primer uporabe preglednice, to pot bo logistično obarvan. Izdelati želimo
delovni list, kjer bomo računali stanje zalog na skladišču vulkanizerskega podjetja. Pri tem bomo
vodili stanje treh različnih izdelkov – platišč, gum in vijakov. Stanje vodimo tedensko.

Vhodni podatki za preglednico so:

• začetno stanje zalog v skladišču,

• vrednost posameznega kosa izdelka in
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• kapaciteta skladišča (največja vrednost).

Skladiščnik v preglednico sproti vpisuje vse prejeme in izdaje. Izdaje so označene z
negativnimi vrednostmi, prejemi pa s pozitivnimi.

Izračunati želimo:

• trenutno stanje zalog in njihovo vrednost,

• promet v trenutnem tednu in vrednost tega prometa,

• zasedenost skladišča po posameznih izdelkih.

Obenem bomo upoštevali:

• pravilo, da za vsako platišče izdamo tudi eno gumo in pet vijakov (1:1:5),

• veljavnost vnosov.

Če se zaloge znižajo pod 8 %, je potrebno uporabnika na to dejstvo posebej opozoriti (uporaba
pogojnega oblikovanja za barvo ozadja celice). Prav tako je potrebno pravilno formatirati vse
podatke (denarne, količinske in odstotkovne).

Iz slike 3.60 so razvidne različne oblike podatkov. Oblikujemo jih z menijsko izbiro
Oblika→Celice. Primer oblikovanja za valutno vrednost v celici B4 prikazuje slika 3.60.

Izračune in pogojno oblikovanje prepuščamo bralcu za vajo, medtem ko pravilo 1:1:5 in
veljavnbost zahtevata dodatno razlago.

Podjetje ima torej politiko, da za vsako platišče proda tudi eno gumo in pet vijakov. Stranka
ne more kupiti posamične gume brez platišča. Po drugi strani pa, če podjetje nabavi platišče,
ni nujno, da zraven nabavi tudi gume. Vrednost za gume je tako določena, če je vrednost za
platišča negativna (izdaja platišča). Če je vrednost za platišča pozitivna (nabava), je vrednost
za gume nedoločena oziroma 0 oziroma prazno besedilo ””. Uporabili bomo prazno besedilo,
ker ne želimo nepotrebnih ničel v preglednici. Formula za C6 (prvo polje za gume) se tako
glasi: =IF(B6<0;B6;""). Formulo nato prekopiramo navzdol do C17. Podobno ravnamo v
primeru vijakov, le da v tem primeru upoštevamo v formuli faktor 5. To napravimo s pogojem
=IF(B6<0;5*B6;"").

Z veljavnostjo vnosov lahko delno preprečimo neveljavne vnose. V primeru platišč to
pomeni, da je smiselno ob vnosu podatkov testirati vrednost vnosa, ki mora zadostiti naslednjima
pogojema:

1. ob razknjižbi izdelkov iz skladišča ne moremo izdati več blaga kot ga je na zalogi in hkrati

2. ob vknjižbi blaga v skladišče ne moremo sprejeti več blaga kot je kapaciteta skladišča.

Pravilo za veljavnos vpišemo v pogovorno okno, ki ga prikazuje slika 3.62 in ga prikličemo
prek menuja Podatki→Veljavnost (Data→Validity). Na drugem zavihku vpišemo tekst, ki
ga želimo izpisati uporabniku vsakič, ko vstopi v celico. Na tretjem zavihku vpišemo akcijo, ki
se sproži ob napačnem vnosu s pripadajočim tekstom opozorila. Akcije so prenehanje izvajanja
vnosa, izpis napake in vrnitev v prejšnje stanje, izpis opozorila ali zgolj izpis informacije.
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Slika 3.60: Stanje zalog v skladišču

Slika 3.61: Primer oblikovanja številk
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Slika 3.62: Veljavnost vnosov

Slika 3.63: Odstranitev zaščite celic

Želimo torej napisati pogoj za veljavnost vnosov za platišča. Uporabili bomo možnost vpisa
samo celih števil in vpis podatkov med dvema vrednostma – izbira veljaven obseg iz spustnega
seznama Podatki (slika 3.62).

Po vnosu trenutno stanje zalog za platišča ne sme presegati kapacitete in ne sme biti
negativno: (0 ≤ vnos+B20 ≤ B27). V tej neenačbi odštejemo vrednost B20 in tako dobimo
omejitvi za veljaven vnos: najmanj -B$20 in največ B$27-B$20. Ker pogoj velja za celoten obseg
B6:B17, fiksiramo vrstice pri sklicu.

Na koncu zbrišemo testne podatke in stran zaščitimo pred vpisovanjem v polja, ki niso na
področju A6:D17. Ko zaščitimo delovni list, se privzeto zaščitijo vse celice, zato moramo najprej
odstraniti zaščito področja (zavihek Zaščita pod Oblika→Celice), kot je prikazano na sliki
3.63. Šele nato z geslom zaščitimo delovni list pod Orodja →Zaščiti dokument→Delovni
list (Tools→Protect Document→Sheet) in preglednica je pripravljena za uporabo.
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Slika 3.64: Primer podatkov za izdelavo grafikona

3.4 Ustvarjanje grafikonov in grafov

Grafikon (ang. chart) je prikaz številskih podatkov s sliko. V uporabnem računalništvu se
pojavlja pojem graf (ang. graph) kot sinonim za grafikon, a vseeno ima matematično konotacijo.
Držali se bomo ožje, matematične definicije, ki pravi, da je graf krivulja, ki v koordinatnem
sistemu prikazuje odvisnost dveh ali več količin. Grafi so potem podmnožice grafikonov.

V Calc-u imamo na voljo veliko različnih vrst grafikonov. Področje, ki se ukvarja z vizualno
prezentacijo, pokrivajo druge knjige [5]. Tu se bomo osredotočili na izdelavo grafikonov pod
predpostavko, da vemo, kako bomo podatke prikazali na čimbolj nazoren način.

3.4.1 Čarovnik za izdelavo grafikonov

Grafikone v Calc-u izdelamo s čarovnikom. Grafikon se obravnava kot predmet preglednice, ki
mu lahko naknadno spreminjamo tip, obseg podatkov in ostale atribute s funkcijami čarovnika.
Vsaka sprememba se takoj odrazi v grafikonu, tudi če spremenimo vsebino podatkov – grafikon
je ”živ”.

Izdelava grafikonov in grafov

Izdelavo si oglejmo na primeru podatkov na sliki 3.64.

1. Izberimo celice, ki jih želimo uporabiti v grafikonu.

2. Pojdimo na Vstavi→Predmet→Grafikon (Insert→Object→Chart) v meniju ali klik-

nimo na gumb Grafikon v orodni vrstici Standardno za prikaz pogovornega okna
Čarovnik za grafikon (slika 3.65). Poleg tega se kot predmet vstavi v preglednico tudi
osnovni grafikon (slika 3.66) na podlagi izbranih celic.

Pri izbiri celic ni nujno, da so v enotnem bloku, izberemo lahko samostojne celice ali skupine
celic. To storimo tako, da najprej izberemo prvi niz podatkov, nato pa držimo tipko Ctrl in
izberemo naslednjega. Oba niza podatkov ne smeta biti v isti vrstici ali stolpcu, sicer bo Calc
predpostavil, da gre za en sam niz.
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Slika 3.65: Čarovnik za grafikon – izbira vrste grafikona

Slika 3.66: Privzeti grafikon za primer podatkov
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Obstaja še ena poenostavitev pri izbiri celic. Če želimo, lahko izberemo le eno celico
podatkovne tabele in čarovnik bo sam ugotovil obseg podatkov. Lahko se seveda tudi zmoti
pri kompleksnejših vrstah grafikonov, zato ne pozabimo preveriti obsegov.

Izbira vrste grafikona

Calc ponuja deset vrst grafikonov, vsaka vrsta ima svoj nabor nastavitev. Čarovnikova privzeta
vrsta je dvodimenzionalni navpični stolpčni grafikon, kar je razvidno v predogledu na sliki 3.66.

Za spremembo vrste grafikona:

1. Izberemo vrsto grafikona s seznama (slika 3.65).

2. Izberemo ikono grafikona z najustreznejšo obliko te vrste.

3. Za stolpčni, tortni in ploščinski grafikon lahko dodatno izberemo 3D videz.

4. Izberemo še ostale, od vrste odvisne možnosti.

5. Kliknemo Naprej>> za naslednji korak in spremembe obsega podatkov (slika 3.67).

6. Če smo zadovoljni z grafikonom, kliknemo Dokončaj. Predmet je umeščen na delovni list.

Obseg podatkov in oznake osi

Nadaljujmo z našim primerom. V tem koraku čarovnika (slika 3.67) lahko ročno popravimo
morebitne napake v izbiri podatkov za grafikon, izberemo način izrisa in oznako osi. Na tem
mestu velja ločiti med obsegom podatkov in nizom podatkov. Pod obseg podatkov pojmujemo
vse podatke, ki bodo vir za grafikon, vključno z oznakami. V primeru je to $A$2:$D$8. Niz
podatkov je ena vrstica ali stolpec števil, ki so v grafikonu predstavljena z elementi z neko
skupno lastnostjo. Imamo tri nize podatkov – avtomobil ($B$3:$B$8), motocikel ($C$3:$C$8)
in kolo ($D$3:$D$8). Nizi so vedno podani absolutno, vključujejo tudi ime delovnega lista. To
je zahtevek Calc-a, saj le tako lahko zagotovi, da bodo podatki pravilno preslikani v grafikon, ne
glede na njegovo lokacijo.

1. Če je potrebno, spremenimo vrstice in stolpce podatkov tako, da uredimo sklic na celice
v vnosnem polju Obseg podatkov. Primer sklica je $DelovniList1.$A$1:$A$5. Podatki
niso nujno v enotnem bloku. Če želimo za obseg imeti podatke s področij, ki niso soležni,
vnesemo najprej prvi obseg, dodamo podpičje, nato vnesemo še druge obsege. Podpičje je
v splošnem ločilo med parametri.

2. Čarovnik sam ugotovi, ali so nizi podatkov v stolpcih ali v vrsticah. Popravimo, če se je
zmotil.

3. Čarovnik sam ugotovi, ali podatki vsebujejo oznake v prvi vrstici/stolpcu ali ne.
Popravimo, če se je zmotil.

4. Kliknemo Naprej>> za naslednji korak.
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Slika 3.67: Čarovnik za grafikon – obseg podatkov

Slika 3.68: Čarovnik za grafikon – nizi podatkov

5. Če smo že zadovoljni z grafikonom, kliknemo Dokončaj. Predmet je umeščen na delovni
list.

Niz podatkov

V tem koraku (slika 3.68) lahko spreminjamo vse nize podatkov, vključno z oznakami. Vsak
imenovan niz podatkov ima zapisane obsege za ime in Y-vrednosti. Tako lahko spreminjamo
obseg kategorij, brišemo neželene nize ali jih dodajamo z drugih celic.

V izbirnem polju Niz podatkov so prikazani vsi podatkovni nizi trenutnega grafikona. Za
urejanje:

1. Izberemo enega izmed nizov.

2. Kliknemo Dodaj za nov niz pod izbranim. Nov niz bo enake vrste kot izbrani niz.

3. Kliknemo Odstrani za izbris izbranega niza.
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Slika 3.69: Gradniki grafikona

4. Gumba s puščicama gor in dol premikata izbran niz po seznamu. S tem ne spreminjamo
vrstnega reda v tabeli, ampak le v grafikonu.

5. Za spremembo imena obsega podatkov kliknemo na Ime seznama Obsegi podatkov in
popravimo sklic na celice v polju Obseg za Ime.

6. Za spremembo kategorij podatkov (vrednosti na vodoravni osi v našem primeru) kliknemo
na Ime seznama Obsegi podatkov in popravimo sklic na celice v polju Kategorije.

7. Kliknemo Naprej>> za zadnji korak.

8. Če smo že zadovoljni z grafikonom, kliknemo Dokončaj. Predmet je umeščen na delovni
list.

Gradniki grafikona

Gradniki za dvo- in tridimenzionalne grafikone so prikazani na sliki 3.69:

• Stena grafikona (Chart Wall) je ozadje za podatkovnim področjem grafikona.

• Področje grafikona (Chart Area) je ozadje za vsemi gradniki grafikona.

• Tla grafikona (Chart Floor) so spodnje področje v 3D grafikonih, ki se ne pojavlja pri
drugih vrstah.

• Naslov (Main Title), podnaslov (Subtitle), legenda (Legend), oznake (Labels)
in imena osi (Axis Titles) so v področju grafikona in se lahko dodajo v čarovniku v
zadnjem koraku.

V zadnjem koraku čarovnika (slika 3.70) bomo določili le še dodatne označbe grafikona –
naslov, podnaslov, imena osi in mreže. Naslov naj bo nedvoumen in tak, da usmeri pozornost
na tisto, kar želimo prikazati. Slika 3.69 vsebuje vse gradnike, ki jih lahko dodamo.
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Slika 3.70: Čarovnik za grafikon – izbira gradnikov grafikona

1. Vnesemo naslov in podnaslov v ustrezni vnosni polji.

2. Vnesemo imena osi v vnosni polji Os X in Os Y. Polje za os Z je aktivno le, če izdelujemo
3D grafikon.

3. Izberemo potrditveno polje Pokaži legendo in lokacijo legende – levo, desno na vrhu ali
na dnu.

4. V razdelku Pokaži mreže izberemo potrditveni polji Os X ali Os Y za prikaz mreže. Os Z
je aktivna le, če izdelujemo 3D grafikon. Mreže niso na voljo za tortne grafikone.

5. Kliknemo Dokončaj. Predmet je umeščen na delovni list.

Gumb Dokončaj zapre čarovnika. Grafikon je še vedno v urejevalnem načinu. Z izdelavo
končamo, če kliknemo zunaj grafikona na katerokoli celico.

3.4.2 Urejanje grafikona

Že narejene grafikone lahko urejamo. Urejamo lahko lokacijo podatkov, vrsto in videz grafikona,
možnosti je veliko več kot jih je v čarovniku.

Z urejanjem začnemo tako, da grafikon dvokliknemo. S tem preidemo v urejevalni način.
Grafikon dobi sivo obrobo, menijske izbire se spremenijo. Vstavi in Oblika se zdaj nanašata na
grafikon, ostale izbire so okrnjene ali deaktivirane. Prikaže se tudi orodna vrstica Oblikovanje,
kjer lahko izberemo posamezen gradnik za urejanje. Alternativno ga izberemo tako, da v
grafikonu kliknemo nanj.

Menijske izbire Vstavi→Naslovi, Vstavi→Legenda, Vstavi→Osi in Vstavi→Mreže
(Title, Legend, Axis, Grid) odprejo pogovorna okna, podobna že opisanim čarovnikovim
korakom.

Ostale izbire so:
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• Oznake podatkov (Data Labels) dodajo vrednost iz preglednice vsaki podatkovni točki.
Uporabno, če želimo prikazati podrobnosti, a potrebno je paziti, da grafikon ne postane
nepregleden.

• Trendne črte (Trend Lines) uporabimo, ko imamo razpršene skupine točk v grafu in
želimo prikazati razmerja med točkami. Calc ponuja nekaj vrst regresije za trendne črte
– linearno, logaritemsko, eksponentno in potenčno. Če imamo izbran en niz podatkov,
dobimo črto le za ta niz. Samo za 2D grafikone, brez tortnih in borznih.

• Črte srednje vrednosti (Mean Value Lines) – Calc izračuna srednjo (povprečno)
vrednost za vsak niz podatkov in vstavi barvne črte v grafikon. Če imamo izbran en
niz podatkov, dobimo črto le za ta niz. Je samo za 2D grafikone, brez tortnih in borznih.

• Stolpci napake X in Y (X/Y Error Bars) – uporabimo, ko prikazujemo nezanesljive
podatke z verjetno napako – merilno, vzorčno ali kakšno drugo.

3.4.3 Oblikovanje grafikona

Oblika grafikona, namenjena za predstavitvev na projektorju ni nujno primerna tudi za tisk.
Calc ponuja številne podrobne nastavitve za vsak posamičen gradnik grafikona, do katerih ne
moremo dostopati preko čarovnika.

Izbira posameznega gradnika

Za izbiro gradnika:

1. Dvoklikni na grafikon za vklop urejevalnega načina. Grafikon dobi sivo obrobo.

2. Izberi gradnik, ki ga želiš oblikovati. Gradnik bo označen z izbirnimi kvadratki. Vsak
gradnik ima svoje oblikovalne nastavitve.

3. Pogovorno okno za oblikovanje prikličemo z izbiro ustrezne možnosti v meniju Oblika ali
z desnim klikom iz kontekstnega menija.

Če ima grafikon veliko gradnikov, je priporočljivo vklopiti zaslonske namige (ang.
tooltips). Izbirno polje najdemo pod Orodja→Možnosti→LibreOffice→Splošno (Tools→
Options→LibreOffice→General) v razdelku Pomoč. Ko se z miškinim kazalcem ustavimo nad
gradnikom, bo Calc prikazal njegovo ime. Tako bomo lažje izbrali želen gradnik. Ime se bo
pojavilo tudi v statusni vrstici.

Možnosti oblikovanja

V menijski izbiri Oblika (Format) so na voljo:

• Oblikuj izbor (Format Selection) odpre pogovorno okno za polnilo področja, obrobe,
prosojnost, pisavo in ostale lastnosti izbranega gradnika.
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• Položaj in velikost (Position and Size) odpre pogovorno okno za določanje
položaja, velikosti in rotacije grafikona.

• Razporeditev (Arrangement) ima dve možnosti Postavi naprej in Pošlji nazaj. Eno
izmed možnosti izberemo, če želimo spremeniti vrstni red prekrivajočih se nizov podatkov.

• Naslov (Title) oblikuje naslove grafikona in osi.

• Legenda (Legend) oblikuje legendo in njeno pozicijo v grafikonu.

• Os (Axis) oblikuje črte in pisavo osi.

• Mreža (Grid) oblikuje črte mreže grafikona.

• Stena (Chart Wall), tla (Chart Floor) in področje grafikona (Chart Area)
oblikuje prikaz stene, tal (le pri 3D videzu) in področja grafikona.

• Vrsta grafikona (Chart Type) spremeni vrsto grafikona in videz v 3D iz 2D in obratno.
3D videz ni na voljo za vse vrste.

• Obsegi podatkov (Data Ranges) spremeni obseg in niz podatkov (kot že opisano pri
čarovniku).

• Pogled 3D (3D View) določa parametre (perspektive, osvetlitve) v pogledu 3D.

Premikanje gradnikov

Gradnike lahko premikamo in skaliramo neodvisno od ostalih. Premaknemo lahko na primer
legendo iz privzete pozicije v prazen prostor v grafu. Lahko recimo izvlečemo posamezne kose
iz tortnega grafikona. Ne moremo pa spreminjati posameznih točk v nizih, saj bi to pomenilo
spremembo podatkov, ne le oblike.

Za premik gradnika:

1. Dvokliknemo na grafikon za vklop urejevalnega načina. Grafikon dobi sivo obrobo.

2. Kliknemo na gradnik in ga povlečemo (ang. drag&drop) na želeno mesto.

Ob izbiri tridimenzionalnega grafikona kot gradnika najprej vstopimo v način izbire 3D
kota. To je razvidno iz izbirnih rdečih krogcev okoli gradnika in miškinega kazalca, ki je v
obliki polkrožne puščice. Če želimo grafikon premakniti, moramo preiti v ”premikajoči” način s
ponovnim klikom na gradnik. Kazalec mora biti v obliki dveh pravokotnih puščic, gradnik mora
biti očrtan z izbirnimi zelenimi kvadratki.

3.4.4 Galerija vrst grafikonov

Podatke lahko predstavimo z različnimi grafikoni, a sporočilo, ki ga želimo posredovati občinstvu,
je tisto, kar naj določi vrsto grafikona. V tem razdelku bodo prikazani primeri z dodatnimi
pojasnili, kjer bo to potrebno.
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Slika 3.71: Primeri vodoravnih stolpčnih grafikonov (vir: StatCounter [2])

Navpični stolpčni grafikon (Column)

To vrsto ponavadi uporabljamo za prikaz trendov skozi čas. Stolpčni grafikon je privzeta vrsta
grafikona, saj je ena najbolj uporabnih vrst in najlažja za razumeti. Je najprimernejša za
sorazmerno majhno število podatkovnih točk. V primeru daljše časovne vrste je črtni grafikon
boljša izbira.

Grafikon je sestavljen iz navpičnih stolpcev z višino, ki je proporcionalna vrednosti podatka.
Os X prikazuje kategorije, os Y vrednosti za vsako kategorijo.

Podvrste grafikona so:

• Navaden (Normal) prikaže vrednosti vsake kategorije eno poleg druge. Poudarek je na
primerjavi posameznih vrednosti.

• Naložen (Stacked) prikaže vrednosti vsake kategorije eno nad drugo. Poudarek je v
celotni vrednosti kategorije.

• Odstotkovno naložen (Percent Stacked) prikaže relativne odstotke vrednosti glede na
vsoto kategorije. Poudarek je na prispevku vrednosti skupnemu seštevku kategorije.

Primer navpičnega stolpčnega grafikona je na sliki 3.66 na strani 138.

Vodoravni stolpčni grafikon (Bar)

Ta vrsta prikazuje stolpčni grafikon z vodoravnimi stolpci. Lastnosti in podvrste grafikona so
enake kot pri prvi vrsti, le da tu os Y prikazuje kategorije, os X pa vrednost vsake kategorije.

Uporabljamo jih pri primerjavi podatkov, kjer čas ni pomemben, recimo pri primerjavi
priljubljenosti izdelkov na trgu.

Tortni grafikon (Pie)

Tortni grafikon prikaže vrednosti podatkov kot izseke polnega kroga. Dolžina loka je sorazmerna
z vrednostjo.

Podvrste so:
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Slika 3.72: Primeri tortnega grafikona

• Navaden (Normal) prikaže vrednosti kot barvne izseke le za en podatkovni niz. Vsak
posamezen izsek lahko izvlečemo iz celote ali ga vrnemo nazaj.

• Razkosan (Exploded Pie Chart) prikaže grafikon z že izvlečenimi izseki.

• Kolobarni (Donut) lahko prikaže več podatkovnih nizov. Vsak niz je prikazan kot en
kolobar z luknjo na sredini, kjer je lahko naslednji niz. Tudi tu lahko posamezne izseke
izvlečemo.

• Razkosani kolobarni (Exploded Donut Chart) prikaže kolobarni grafikon z že
izvlečenimi izseki.

Tortni grafikoni so primerni za primerjavo deležev. Recimo, za primerjavo porabe med
posameznimi oddelki podjetja (slika 3.72). Najbolje delujejo z manjšim številom vrednosti, do
okoli deset. Več kot to in ne bo več pravega vizualnega učinka. Grafikon lahko polepšamo v
pravo umetnino, dodamo sence, ga nagnemo itd. Paziti je treba le, da vanj ne natlačimo preveč
podrobnosti in da nagib ne izkrivi proporcev izsekov.

V čarovniku lahko izberemo razkosan grafikon, a to je po principu ”vse ali nič”. Če želimo
poudariti le en izsek, ga izberemo in povlečemo iz celote. Pri tem je treba povečati območje
grafikona, če želimo ohraniti prvotno velikost.

Ploščinski grafikon (Area)

Ta vrsta prikazuje vrednosti kot točke na osi Y, na osi X pa kategorije. Vrednosti Y posameznega
niza so povezane s črto, področje med dvema črtama je zapolnjeno z barvo. Namen ploščinskega
grafikona je poudariti razlike med sosednjima kategorijama.

Podvrste so:

• Navaden (Normal) izriše vrednosti kot absolutne vrednosti Y. Najprej izriše območje
zadnjega stolpca v obsegu podatkov, nato naslednjega in tako do prvega. Če so vrednosti
v prvem stolpcu višje od ostalih, prekrijejo prejšnja izrisana območja.
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Slika 3.73: Kolobarni grafikon

Slika 3.74: Primeri ploščinskih grafikonov (navaden, naložen, odstotkoven) (vir: SI-
STAT [1])

• Naložen (Stacked) izriše vrednosti naložene eno na drugo. To zagotovi, da so vidni
vsi podatki, a vrednosti Y ne predstavljajo več absolutnih vrednosti, razen pri spodnjem
stolpcu.

• Odstotkovno naložen (Percent Stacked) izriše vrednosti kumulativno eno nad drugo,
umerjene kot odstotek seštevka kategorije.

Ploščinski grafikon je podoben črtnemu grafikonu. Uporabimo ga, če želimo poudariti obseg
sprememb. Ima večji vizualni učinek kot črtni, a ni primeren za vse vrste podatkov.

Črtni grafikon (Line)

Črtni grafikon predstavlja časovno zaporedje. Idealen je za neobdelane podatke in za grafikone z
obilico podatkov, ki prikazujejo trende oziroma spremembe skozi čas. Vrednosti so točke na osi
Y, os X predstavlja kategorije, ponavadi časovne.

Podvrste so:

• Samo točke (Points Only) izriše le točke.
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• Točke in črte (Points and Lines) izriše točke in jih poveže s črtami.

• Samo črte (Lines Only) izriše le črte.

• 3D-črte (3D Lines) poveže točke s 3D črto.

S potrditvenim poljem Naloži nize naložimo vrednosti Y kumulativno eno nad drugo.
Vrednosti tako niso več absolutne. Če izberemo Odstotkovni, se vrednosti izrazijo v odstotku
skupne vsote kategorije. Vrsto črte izberemo s spustnega seznama, s čimer določimo, kako
bodo povezane točke. Na izbiro so ravne črte, gladke črte, ki izrišejo krivulje skozi točke in
stopnjevite črte, ki izrišejo črte po korakih od točke do točke.

Razpršeni grafikon oziroma grafikon XY (XY Scatter)

Razpršeni grafikon je v osnovni obliki zasnovan na enem nizu podatkov, ki ga sestavljajo ime,
seznam vrednosti X in seznam vrednosti Y. Vsak par (x, y) je prikazan kot točka v koordinatnem
sistemu. Ime niza je povezano z vrednostmi Y in prikazano v legendi.

Podvrste grafikona so podobne kot pri črtnem grafikonu.
Uporabimo ga, če želimo primerjati podatke z nekimi konstantnimi vrednostmi. Primeri

so vremenski podatki, reakcije pod različnimi nivoji kislosti, pogoji na različnih nadmorskih
višinah . . . Pravzaprav je primeren za kakršnekoli podatke, ki jih lahko zapišemo v dveh številskih
zaporedjih. Obenem je tudi edina vrsta grafikona, ki je primerna za prikaz matematičnih
vrednosti – izris funkcij.

Za primer bomo vzeli primerjavo med japonskim jenom in drugimi valutami (slika 3.75)
Pri ponovitvi tega primera je treba biti pozoren, saj sama označitev podatkov za čarovnika

ne bo dovolj. Pod Oblika→Obsegi podatkov→Nizi podatkov (Format→Data Ranges→Data
Series) moramo določiti, da prva vrstica podatkov predstavlja os X. Ostale vrstice primerjamo
s prvo. Čeprav tabela kaže mesečne podatke, grafikon mesecev ne vsebuje. Tudi vrstice z jeni
ni, uporabljena je kot konstantno zaporedje za primerjavo.

Mehurčni grafikon (Bubble)

Mehurčni grafikon je svojevrstna nadgradnja razpršenega grafikona, kjer podatkovne točke
zamenjamo s krogi (mehurčki). Prikazuje relacije treh spremenljivk. Dve določata pozicijo
na oseh X in Y, tretja pa je prikazana kot relativna velikost kroga.

Ponavadi je laže ročno nastaviti nize podatkov, kot se zanašati na avtomatiko čarovnika.
Pogovorno okno za niz podatkov grafikona ima vnos, ki določa obseg podatkov za velikosti
krogov, poleg obsegov za vrednosti x in y.

To vrsto pogosto uporabimo za prikaz finančnih ali socialno-demografskih podatkov.

Mrežni grafikon (Net)

Mrežni grafikon prikazuje vrednosti kot povezane točke v mreži, ki spominja na pajkovo mrežo
ali prikaz na ekranu radarja. Za vsak stolpec podatkov je prikazana radialna os, na kateri so
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Slika 3.75: Primer razpršenega grafikona

Slika 3.76: Primer mehurčnega grafikona
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Slika 3.77: Primer mrežnega grafikona

nanizani podatki. Te so ekvivalentne osem Y pri drugih vrstah grafikonov. Priporočljivo število
osi je med tri in osem, sicer grafikon postane nepregleden.

Ta vrsta je uporabna pri primerjanju podatkov, ki niso časovno zaporedni, a kažejo na
razlike pod različnimi okoliščinami, kot na primer vrednosti količine v znanstvenem poskusu.
Prikažemo lahko tudi več nizov podatkov, idealni so za sliko ”prej-pozneje” ali za primerjavo med
pričakovanimi in dejanskimi podatki.

Borzni grafikon (Stock)

Borzni grafikon prikaže tržni trend, podan z otvoritvenim, najnižjim, najvišjim in zaključnim
tečajem. Možen je tudi prikaz prometa, to je obsega trgovanja. Tudi tu je potrebno ročno vnesti
vse nize podatkov v čarovniku, saj sam ne zmore razpoznati namenov posameznih podatkovnih
stolpcev.

Primeren je tudi za znanstvene podatke oziroma pri predstavitvi raznih sprememb, recimo
za temperaturna nihanja skozi leto.

Navpični stolpčni in črtni grafikon (Column and Line)

Gre za kombinacijo stolpčnega in črtnega grafikona. Uporaben je za prikaz dveh različnih, a
sorodnih nizov podatkov, na primer prodaja po času (stolpci) in stopnja dobička (črta).

Primer na sliki 3.78 prikazuje stroške izdelave in dobiček za dva izdelka v obdobju šestih
mesecev.

Na koncu si oglejmo, kako priti do takšnega grafikona. Najprej označimo tabelo s podatki
in zaženemo čarovnika za grafikone. V prvem koraku za vrsto grafikona izberemo navpični
stolpčni in črtni grafikon z dvema črtama in podatki v vrsticah. Izberemo še naslov, ki poudari
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Slika 3.78: Primer navpičnega stolpčnega in črtnega grafikona

namen grafikona. Čarovnika zapremo in se posvetimo olepšavi gradnikov. Z dvoklikom odpremo
urejevalni način grafikona, izberemo črto in z desnim klikom iz kontekstnega menija izberemo
Oblikuj niz podatkov (Format Data Series).

Tu bomo spremenili dve stvari. Najprej barve črt, ki se ne ujemajo z barvami stolpcev. Črta
za niz dobiček (burek) naj bo iste barve kot za niz stroški (burek), enako naj velja za drugi izdelek.
Črte lahko obenem naredimo bolj vidne tako, da povečamo debelino na 0,10 cm.

Obrobiti želimo še stolpce. Izberemo enega izmed stolpcev in iz kontekstnega menija izberemo
Oblikuj niz podatkov. Pod zavihkom Obrobe izberemo zvezno črno črto. Enako storimo še z
drugim nizom podatkov.

Za spremembo ozadja izberemo steno in iz kontekstnega menija Oblikuj steno. V zavihku
Področje s spustnega seznama izberemo Preliv. Izberemo enega izmed ponujenih prelivov in
ga naredimo svetlejšega – v zavihku Prosojnost jo nastavimo na 70 %.

Recimo, da nas moti še mreža, ki v tem primeru ne prinaša dodane vrednosti. Odstranimo
jo tako, da pod Vstavi→Mreže (Insert→Grids) odstranimo kljukico za os Y.
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Recenzije

Knjiga je namenjena tistim posameznikom (inženirjem, študentom, učencem in ostalim), ki so
se pri svojem delu odločili uporabljati odprtokodno rešitev in ne komercialno zbirko MS Office,
ki je sicer najbolj razširjena. Praksa kaže, da urejevalnik besedil in preglednico, tipa programov,
ki ju knjiga predstavlja, pri svojem delu potrebuje velika večina uporabnikov računalnikov. V
knjigi sta tako predstavljena programa Writer in Calc iz zbirke LibreOffice, ki je odprtokodna
rešitev in si jo lahko vsak posameznik brezplačno namesti na svoj računalnik.

Knjiga oba programa obdela in predstavi na sistematičen način, kjer bralca od osnov
postopoma uvede do uporabe tistih funkcionalnosti, ki so pomembne za veliko večino
uporabnikov. Glede na način predstavitve bralcu hkrati omogoča, da težje in specifične
funkcionalnosti spozna sam. Pohvalno je, da knjiga za primere uporabi situacije, potrebe in
probleme, ki so pri delu najbolj tipični za večino uporabnikov. Bralcu na ta način precej olajša
branje in spoznavanje obeh programov.

Knjigo priporočam vsem, ki jim je zelo širok nabor funkcionalnosti zbirke MS Office
preobsežen za to, kar v praksi dejansko uporabljajo in hkrati za nakup zbirke tako imenovanih
pisarniških programov ne želijo plačati nezanemarljivega zneska. Pisarniška zbirka LibreOffice
bo s programoma Writer in Calc zagotovo zadovoljila veliko uporabnikov.

Doc. dr. Rok Rupnik, PMP
Univerza v Ljubljani, Fakulteta za računalništvo in informatiko

Učbenik je razdeljen na 3 poglavja. Uvodnemu poglavju, v katerem avtorji predstavijo zbirko
LibreOffice, sledi poglavje o urejanju besedil s programom Writer ter poglavje o uporabi
preglednic, ki jih je moč urejati s programom Calc. Avtorji so nazorno predstavili delovno
okolje pisarne, kot tudi način uporabe programov za potrebe pisarniškega poslovanja. Pohvalila
bi prikaz reševanja problemov iz vsakdanjega življenja, tako v Writer-ju kot v Calc-u, kar bo
študentom in drugim uporabnikom gradiva olajšalo prehod na LibreOffice.

Uporaba računalniških orodij za podporo pisarniškemu poslovanju se pogosto povezuje s
komercialnimi programskimi rešitvami kot je MS Office. V slovenskih šolah se tako učence,



156 LITERATURA

dijake in študente uči uporabljati orodja, ki so mladim cenovno nedostopna, kar jih sili v nelegalno
nabavo programov. Na spletu obstajajo številna odprto-kodna orodja, ki uspešno nadomeščajo
komercialne programe in jih uporabniki brezplačno lahko namestijo na svoje računalnike in pri
tem ne kršijo avtorskih pravic. Razvijanje odnosa do avtorsko zaščitenega dela je naloga učiteljev
na vseh nivojih izobraževanja. Žal odprto-kodna programska oprema v šole vstopa zelo počasi.
Eden izmed razlogov je nedvomno v tem, da v slovenščini skorajda ni sodobnih priročnikov za
uporabo odprtokodne programske opreme. Pričujoče delo je zato odličen priročnik, ki bo odprto-
kodno pisarno LibreOffice približal uporabnikom. Čeprav je gradivo pisano za študente, bodo po
njem lahko posegli vsi, ki potrebujejo brezplačna pisarniška računalniška orodja. Priročnik bo
uporaben tudi za ljubitelje zbirk OpenOffice.org ali pisarne NeoOffice.

Izr. prof. dr. Viktorija Florjančič
Univerza na Primorskem, Fakulteta za management

Avtorji izred. prof. dr. Borut Jereb, Darja Kukovič in Gregor Štrubelj so pripravili učbenik z
naslovom “Uporaba računalniških orodij za podporo pisarniškemu poslovanju”, ki zajema snov za
študente visokošolskega strokovnega študijskega programa na Fakulteti za logistiko Univerze v
Mariboru. Vsebina učbenika pokriva tri osnovna poglavja: Pisarniške zbirke, Urejevalnik besedil
in Preglednica.

V učbeniku je na izviren način predstavljena uporaba prosto dostopnih programskih
rešitev. Avtorji so v okviru treh sklopov sistematično predstavili zahtevnejše in obsežne vsebine
razumljivo ter strokovno korektno. Vsako poglavje vsebuje teoretično ozadje, opis problema in
primer njegove uporabe. Razlaga je zelo obširna in jasna, snov pa je tudi predstavljena s pomočjo
slik. V luči tega je prikazano, kako si je mogoče učinkovito olajšati delo pri reševanju problemov
v poslovanju. Na ilustrativen način je predstavljena uporaba pisarniške zbirke LibreOffice ter
v okviru tega najpogosteje uporabljena programa, urejevalnik besedil “Writer” in urejevalnik
preglednic “Calc”. Podana so navodila za uporabo programov, kar je podprto z nekaterimi
realnimi primeri v povezavi z logistiko. Tako je učbenik v prvi vrsti pisan za študente Fakultete
za logistiko Univerze v Mariboru, saj jim bo v pomoč pri razumevanju in reševanju določenih
poslovnih problemov. Vendar bodo zaradi izredno zanimive tematike gradiva našli uporabo
vrednost tudi vsi, ki se srečujejo ne samo z logističnimi izzivi, temveč tudi širše.

Red. prof. dr. Maja Fošner
Univerza v Mariboru, Fakulteta za logistiko
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